Unanswered Question
Dec 22nd, 2008


I am looking for a documentation on how to update a VSS-1440 system with modular IOS.

I think follwing link describes only an IOS update (eFSU) with a native IOS.


I must test the IOS update in my testlab. Because for now there is no newer IOS with eFSU(ISSU) support available, I have to test the update from 12.2(33)SXI to 12.2(33)SXI.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
gnijs Wed, 03/04/2009 - 09:58

I had exactly the same problem.

There is an ISSU upgrade document at:


(don't know if it is also valid for the modular ios though)

what i did is the following: i renamed one of the two images to another name, then followed the ISSU upgrade procedure.

Of course, it worked flawlessly. (you can't have much incompatibility between two same versions...differentiating only by name...doh).

If you have a NDA with Cisco, you could ask for an engineering version to test with, however, make sure it is the same packaging level (ie. ip base,ip services). i had to cancel because it was a different version.



gnijs Thu, 04/02/2009 - 06:15


Cisco has just released the SXI1 release. Now we can finally test ISSU upgrade functionality (i just did it: from SXI -> SXI1 and it worked perfectly: no downtime longer than 500 ms at reboot points). no session loss througout upgrade process.

(PS i did not use modular IOS)


gnijs Thu, 08/20/2009 - 11:54

I was talking about a VSS setup, so two seperate chassis'. ISSU works by completely rebooting one chassis. I think you are talking about dual supervisors in the same chassis. I haven't tested that.


This Discussion