PPPoE interface error

Unanswered Question
Dec 22nd, 2008

When I try to execute the PIX 501 version 6.3 command "ip address ext pppoe", where "ext" has been defined as the name of ethernet0, I get an error message, "PPPoE client can only be started on outside interface". But ethernet0 is the outside interface, isn't it? I have looked for documentation on this error message and found none.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
ajagadee Mon, 12/22/2008 - 19:33


I believe you can enable PPPoE only on the outside interface and the interface has to be name "outside" and the name is case sensitive. For example, if you configure the E0 with OutSide and try to enable PPPoE, the chassis will return the above error message.

Example 1:

pixfirewall(config)# nameif e0 PPP sec0

pixfirewall(config)# ip add PPP pppoe

PPPoE client can only be started on outside interface

Example 2:

pixfirewall(config)# nameif e0 OutSide se0

pixfirewall(config)# ip add OutSide pppoe

PPPoE client can only be started on outside interface

So, your only option is to reconfigure the outside interface with a name of "outside" and then configure PPPoE.



*Pls rate all helpful posts*

jpool Mon, 12/22/2008 - 20:23

You are correct. Just before I saw your reply, I tried the experiment of renaming the interface "outside", issuing the ip command, and then naming the interface back to "ext". It worked. Looks like a bug to me.

Thanks very much.


This Discussion