BGP EIGRP race condition?

Unanswered Question
Dec 22nd, 2008

Hi all,

I'm not sure if my problem is because of a race-condition or not.

I have a head-office that can access a data center via metro ethernet or a MPLS circuit. For all network traffic to from the head-office, the metro ethernet is preferred.

If the metro ethernet fails, the MPLS DS3 will access the data-center via that connection as well as other sites.

We're redistributing BGP into EIGRP, but we're only redistributiing 'connected' into BGP. EIGRP is not being redistrbuted. (Check out the configs below). My problem is that some of the BGP routes are being overridden by the EIGRP routes. But it only seems to be routers with an Origin of (i) IGP that get overridden.

I copied my config from the router with the EIGRP routes in the routing table instead of BGP.

!

! This is the Chicago router.

!

interface GigabitEthernet0/0

ip address 172.28.10.113 255.255.255.252 secondary

ip address 10.77.226.53 255.255.255.240

duplex full

speed 100

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial1/0

bandwidth 44210

no ip address

encapsulation frame-relay IETF

dsu bandwidth 44210

frame-relay lmi-type cisco

!

interface Serial1/0.100 point-to-point

description MPLS Circuit

ip address 152.176.47.202 255.255.255.252

frame-relay interface-dlci 100 IETF

!

router eigrp 333

redistribute bgp 65028 metric 1536 700 255 1 1500 route-map block-aggregate

network 10.77.226.48 0.0.0.15

auto-summary

!

router bgp 65028

no synchronization

bgp log-neighbor-changes

network 172.22.0.0 mask 255.254.0.0

network 192.168.168.0 mask 255.255.254.0

redistribute connected

neighbor 152.176.47.201 remote-as 65000

neighbor 152.176.47.201 advertisement-interval 0

neighbor 152.176.47.201 route-map denyChicagoRoutes in

no auto-summary

!

ip route 172.22.0.0 255.254.0.0 Null0

ip route 192.168.168.0 255.255.254.0 Null0

!

!

ip access-list standard DenyAggregate

permit 172.22.0.0 0.1.255.255

permit 192.168.168.0 0.0.1.255

ip access-list standard DenyChicagoRoutes

permit 172.22.0.0 0.0.255.255

permit 172.23.0.0 0.0.255.255

permit 192.168.168.0 0.0.0.255

!

!

route-map block-aggregate deny 10

match ip address DenyAggregate

!

route-map block-aggregate permit 20

!

route-map denyChicagoRoutes deny 10

match ip address DenyChicagoRoutes

!

route-map denyChicagoRoutes permit 20

!

!

As always, thanks for the help.

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
tomek0001 Mon, 12/22/2008 - 19:09

Mike

Can display the output of

"show ip route"

"show ip bgp"

and for the routes you see overwritten by eigrp

"show ip bgp x.x.x.x"

That would be easier to troubleshoot. Without that information I would check if you don't have the same routes in EIGRP and iBGP, sine the administrative distance of EIGRP (90) will win over iBGP (200).

Thanks

(please rate if helpful)

msrohman Tue, 12/23/2008 - 08:07

Thanks for taking a look. I attached a network diagram too.

I used an example from the San Francisco site. The 10.10.3.0/24 network should be in the routing table via BGP, but it's not.

The other MPLS sites have all of the San Francisco routes in the BGP table and IP routing table.

I attached the output to this message.

tomek0001 Tue, 12/23/2008 - 10:34

Mike

Base on this

wwacker2-1103009>sh ip route

D EX 10.10.3.0/24 [170/87808] via 10.77.226.51, 2d16h, GigabitEthernet0/0

[170/87808] via 10.77.226.50, 2d16h, GigabitEthernet0/0

I would follow the source of 10.10.3.0/24 advertisement to EIGRP. From your output I can see that the next step is your two routers 10.77.226.51 and .50. Go to these see what they say for the same route (sh ip route 10.10.3.0) if they are learning it from EIGRP from another rotuer follow it until you reach the first point of advertisment of that route into EIGRP. You can post the config from that router or check out how that route gets to EIGRP.

/hope that helps, please rate if helpful.

Tom

tomek0001 Tue, 12/23/2008 - 10:45

hmm. just thought of something else.

Check out what the router peering with onuv-wwacker2-1103009 is advertising to you

sh ip bgp neighbors 152.176.47.201 advertised-routes

see if you see the 10.10.3.0/24. If not that's another way to troubleshoot. I am thinking that if that was advertised to that router you would get it through eBGP and not through EIGRP coming from your Downer Grove site.

Check that out.

Tom

sdoremus33 Tue, 12/23/2008 - 12:51

Could you also post IP CEF 10.10.3.0 on onuv-wwacker2-1103009 ( Chicago router ). Thanks

msrohman Tue, 12/23/2008 - 13:16

wwacker2-1103009>sh ip bgp neighbors 152.176.47.201 advertised-routes

BGP table version is 3345, local router ID is 152.176.47.202

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 10.77.226.48/28 0.0.0.0 0 32768 ?

*> 152.176.47.200/30

0.0.0.0 0 32768 ?

*> 172.22.0.0/15 0.0.0.0 0 32768 i

*> 172.28.10.112/30 0.0.0.0 0 32768 ?

*> 192.168.168.0/23 0.0.0.0 0 32768 i

Total number of prefixes 5

This is what I'm advertising to the EBGP neighbor.

I'm not allowed to perform the following:

wwacker2-1103009>sh ip bgp neigh 152.176.47.201 received-routes

% Inbound soft reconfiguration not enabled on 152.176.47.201

-wwacker2-1103009>sh ip cef 10.10.3.0

10.10.3.0/24, version 1025, epoch 0, per-destination sharing

0 packets, 0 bytes

via 10.77.226.51, GigabitEthernet0/0, 0 dependencies

traffic share 1

next hop 10.77.226.51, GigabitEthernet0/0

valid adjacency

via 10.77.226.50, GigabitEthernet0/0, 0 dependencies

traffic share 1

next hop 10.77.226.50, GigabitEthernet0/0

valid adjacency

0 packets, 0 bytes switched through the prefix

tmstats: external 0 packets, 0 bytes

internal 0 packets, 0 bytes

tomek0001 Tue, 12/23/2008 - 19:36

based on all of this i would say you check 152.176.47.201 and if what routes you have there. if 10.10.3.0 is there and it being send to 152.176.47.202. otherwise follow this route and find the source of 10.10.3.0 advertisement into EIGRP.

What is the routing table at 152.176.47.201?

Where does 10.10.3.0 originate advertisement to EIGRP?

msrohman Thu, 12/25/2008 - 19:39

Thanks. I'm going to have oru provider check the routing and BGP tables on their pier. I opened a ticket a few days ago.

The 10.10.3.0/24 route is getting redistributed from the other Illinois MPLS connection. It's the primary route, but the wacker router should be receiving BGP routes.

-Mike

-Mike

Actions

This Discussion