Internet lease Line

Unanswered Question
Dec 23rd, 2008

I hv 2 MB Internet lease Line. ISP has given me public IP of serial port for router, Gateway public IP & six public IP.

Now I wants to configue Internet for our LAN(private ip). How to do this pls guide me in configuration of router.

Its urgent for me.......

Thanks

Ak

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
netview69 Tue, 12/23/2008 - 20:17

Hi Edison,

If u tell me step by step commands its very helpfull for me pls do needfull.

Regds

AK

viyuan700 Tue, 12/23/2008 - 21:28

U can see in that article, which example is matching to ur case and then use the steps mentioned their.

We dont have idea how ur netowrk is connecetd.

netview69 Tue, 12/23/2008 - 22:50

See ISP gave me one public IP for serial int & one for gayeway. So I put that public ip to serial int & gave one privte ip to ethernet.

ip nat inside for ethernet

ip nat outside for serial intface

ip access-list 1 permit any

ip nat inside source list 1 interface Serial0/0 overload

ip route 0.0.0.0 0.0.0.0 gateway ip

This all I configured on router but internet is not working in LAN. Pls help me.

Regds

AK

viyuan700 Tue, 12/23/2008 - 23:07

Router(config)#ip nat pool netview xxx.xxx.xxx.xxx(First IP from the pool ISP gae you) xxx.xxx.xxx.xxx(last IP from the pool ISP gave you) netmask (whatever IP mask ISP gave you)

(I used pool name as netview you can use any name u want to give)

Router(config)#access-list 1 permit any

Router(config)#ip nat inside source 1 (access-lisr number u have used 1) pool netview(which is assume u can write as per udefine above)

Remove this

ip nat inside source list 1 interface Serial0/0 overload

Add those 3 command and delete i told u and let me know how is it going.

paste your sh run after u have done config. u can hide ur IP address and password etc

netview69 Wed, 12/24/2008 - 04:09

Viyuan,

My router hv IOS 11.3 this.......

Router(config)#ip nat pool netview........ command is not working.

its giving error on pool

Router(config)#ip nat inside source 1 pool netview

its giving error on 1

How to do????? pls help me out. pls tell soon

Waitinggggg

Regds

AK

Edison Ortiz Wed, 12/24/2008 - 06:21

Before proceeding, I highly recommend upgrading the IOS on that router as soon as possible.

You are running a very old IOS version that is exposed to several security vulnerabilities. Placing this device facing an internet connection wouldn't be ideal for this implementation.

Once you do that, follow the link I posted originally and all the commands listed on the link should work.

HTH,

__

Edison.

viyuan700 Wed, 12/24/2008 - 09:41

If ur router dont take pool command then ur configuration

ip nat inside for ethernet

ip nat outside for serial intface

ip access-list 1 permit any

ip nat inside source list 1 interface Serial0/0 overload

ip route 0.0.0.0 0.0.0.0 gateway ip

is correct instead of permit any u can try your Private IP address range.

ping from your LAN to gateway IP.

check sh ip nat translation command

One more thing you can check, is ISP have done configuration from ISP router to your router.

netview69 Wed, 12/24/2008 - 20:13

Viyuan,

Boss if I do this config Internet is working

ethernet...public Ip

Serial.... Public Ip

ip route 0.0.0.0 0.0.0.0 gateway ip

Only these three commands..Internet is working n pinding to DNS, Gatway etc etc

But when I put do this config internet is not working on LAN

ethernet....private IP

Serial.... Public Ip

ip route 0.0.0.0 0.0.0.0 gateway ip

ip nat inside ethernet

ip nat out side serial

Router(config)#ip nat pool netview........ command is not working.

its giving error on pool

Router(config)#ip nat inside source 1 pool netview

its giving error on 1

How I can ping from LAN IP to gatway???? I will not ping. pls give me solution. I dont hv new IOS. As I told u my router hv 11.3 IOS

REgds

AK

Actions

This Discussion