Cisco MDS 9222 - Unable to connect via hyperterminal

Answered Question
Dec 23rd, 2008
User Badges:

Hi,


I am accessing the MDS via console port. The other end is connected to my serial/usb adaptor (driver installed). I am using the following settings

Baud Rate: 9600

Parity: None

Stop Bits: 1

Data Bits: 8

Flow Control: (Tried all three options)


Sometimes junk chars appear. I have been however successful once in connecting through xON/xOFF option.


I connect to dozen other various Cisco devices with the same PC & adapter. Is there something different for MDS switch.


Regards

Correct Answer by Michael Brown about 8 years 3 months ago

In my setup I user Tera-term and the flow control is set to 'none' and I am able to connect usually with no issues.


I just tested with Hyper-term and the settings of Speed=9600, Data=8, Stopbit=1, Parity=none, and Flow=none worked just fine.


Hit the enter key several times after the window pops up. I do this to sync the clocks across the serial line. Some times it works even without hitting the enter a few times....seems the first time I connect to a new MDS I have to do this. Once the connection is made, the subsequent connections do not require the multiple enters to sync up.


Hope this helps,

Mike


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Michael Brown Tue, 12/23/2008 - 05:55
User Badges:
  • Cisco Employee,

It sounds like a speed mis match to me. I have used 57600 to attach to some MDSs. IF you can access the MDS command line via telnet or SSH, issue this command to view the settings on the console port. "show line console"


od1-9216i-32# show line console

line Console:

Speed: 9600 baud

Databits: 8 bits per byte

Stopbits: 1 bit(s)

Parity: none

Modem In: Disable

Modem Init-String -


Hope this helps,

Mike

new_networker Tue, 12/23/2008 - 06:38
User Badges:

Below is the output on the switch. I am using the same but doesn't connect. Which should the flow control be ?


SAN_SWITCH# sh line console

line Console:

Speed: 9600 baud

Databits: 8 bits per byte

Stopbits: 1 bit(s)

Parity: none

Modem In: Disable

Modem Init-String -

default : ATE0Q0V1&D0&C0S0=1\015

Correct Answer
Michael Brown Tue, 12/23/2008 - 07:35
User Badges:
  • Cisco Employee,

In my setup I user Tera-term and the flow control is set to 'none' and I am able to connect usually with no issues.


I just tested with Hyper-term and the settings of Speed=9600, Data=8, Stopbit=1, Parity=none, and Flow=none worked just fine.


Hit the enter key several times after the window pops up. I do this to sync the clocks across the serial line. Some times it works even without hitting the enter a few times....seems the first time I connect to a new MDS I have to do this. Once the connection is made, the subsequent connections do not require the multiple enters to sync up.


Hope this helps,

Mike


inch Tue, 12/23/2008 - 20:29
User Badges:
  • Bronze, 100 points or more

I would use teraterm as Mike suggested :)

Actions

This Discussion

 

 

Trending Topics: Storage Networking