IP Phone 7921 not able to make outgoing calls only receiving

Answered Question
Dec 23rd, 2008

i have cisco wireless phone 7921. It works fine with this configuration shown below like it can make and receive calls:-

voice-port 0/0/0

connection plar 5775477

!

!

dial-peer voice 1 pots

answer-address 5775477

destination-pattern .T

port 0/0/0

!

!

ephone-dn 1 dual-line

number 5775477

!

ephone 1

mac-address 0021.55D5.E280

type 7921

button 1:1

!

!

But when i switch my configuration to this shown below:

voice-port 0/0/0

connection plar 5775477

!

!

dial-peer voice 1 pots

answer-address 5775477

destination-pattern A1

port 0/0/0

!

!

ephone-dn 1 dual-line

number 5775477

trunk A1

!

ephone 1

mac-address 0021.55D5.E280

type 7921

button 1:1

!

!

then the wireless fone 7921 only receives calls but not able to make calls. Any idea or hint will highly commendable.

Thanks,

Mukarram.

I have this problem too.
0 votes
Correct Answer by Nicholas Matthews about 7 years 10 months ago

And this is what the sample corlist looks like:

dial-peer cor list 1004Outbound

member 1004Outbound

!

dial-peer cor list 1005Outbound

member 1005Outbound

!

dial-peer cor list 1006Outbound

member 1006Outbound

!

dial-peer cor list 1007Outbound

member 1007Outbound

!

dial-peer cor list 1008Outbound

member 1008Outbound

!

dial-peer voice 1000 pots

corlist outgoing 1004Outbound

destination-pattern 9T

port 0/0/0

!

dial-peer voice 1003 pots

corlist outgoing 1007Outbound

destination-pattern 9T

port 0/0/3

!

dial-peer voice 1002 pots

corlist outgoing 1006Outbound

destination-pattern 9T

port 0/0/2

!

dial-peer voice 1010 pots

corlist outgoing 1008Outbound

destination-pattern 9T

port 0/1/0

!

dial-peer voice 1001 pots

corlist outgoing 1005Outbound

destination-pattern 9T

port 0/0/1

!

ephone-dn 1 dual-line

corlist incoming 1004Outbound

!

!

ephone-dn 2 dual-line

corlist incoming 1005Outbound

!

!

ephone-dn 3 dual-line

corlist incoming 1006Outbound

!

!

ephone-dn 4 dual-line

corlist incoming 1007Outbound

!

!

ephone-dn 5 dual-line

corlist incoming 1008Outbound

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 10 months ago

You can check this thread that is going on also now that is the same issue. There are some helpful links in here that may help you with the configuration:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.2cc2ef79

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 10 months ago

Don't forget to put it on the ephone-dn:

 

ephone-dn 1

corlist incoming <>

Correct Answer by Nicholas Matthews about 7 years 10 months ago

You can keep the .T dial peer, but apply an outgoing corlist to the phone. Make sure that the only phone that has access to dial out of that dial peer is the 7921 that has an incoming corlist defined on the ephone-dn. For help on configuring corlists, I posted a link in one of my other messages.

Corlists limit which ephones can use which dial peers. It's commonly used to match one user to one port - this exact situation.

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 10 months ago

With the original configuration, it sounds like one of two things:

1) This isn't supported on this phone

2) It's a bug.

I wasn't able to find any information on either 1 or 2. You can open a TAC case to have someone investigate, or you could go with the work around that I mentioned earlier.

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 10 months ago

Hi Malik,

Connection plar will automatically ring the IP phone when the FXO rings. opx is just a keyword we add in certain scenarios, but it shouldn't make a difference here.

connection plar is for inbound calls, and corlists are for outbound calls. Your config now will work for inbound, but not outbound.

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 10 months ago

This sounds like a bug in the 7921 firmware. If you're on 1-2-1 there's a good chance this isn't something that has been looked at yet, as the trunk configuration is not used very often.

What are you using the trunk configuration for?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (10 ratings)
Loading.
tiger_401 Mon, 12/29/2008 - 08:25

Dear Fellow,

Thanks for your reply. I have eight 7921 wireless phone and seven 7911. All the eight wireless ip phone are not working like they are only receving calls. With the same configuration 7911 are wokring fine.

Attached is the configuration of my router. I hope it will help you diagnose the problem.

Your concern in this regard will highly be commendable.

Regards,

Mukarram,

JOHN SHOEMAKER Mon, 01/19/2009 - 11:11

Hi Mukarram,

I had a very similar issue. It seemed to be caused by ephone-templates. When I removed the ephone-templates from the phones they dialed fine. Please let me know if this helps.

JOHN SHOEMAKER Mon, 01/19/2009 - 11:17

I apologize... I posted without having looked at your config first. I notice now you don't have ephone-templates.

What firmware version are the phones using? You may want to try to upgrade. I'm using CP7921G-1.2.1.LOADS

tiger_401 Tue, 01/20/2009 - 05:23

Dear fellow,

Can you plz tell how can i download the firmware of the wireless ip phone and how can i upload it in my cme router. I will be very thankful to you. Its urgent.

Thanks & Regards,

Malik.

tiger_401 Tue, 01/20/2009 - 02:07

Dear fellow,

Yes i tried the same config with 7911 and they are working fine. I dont know whats the problem with 7921 ip phones. Can you plz support me in this regard. I m in deep trouble.

If you have my confusion, plz do let me know.

Thanks & Regards,

Malik

Correct Answer
Nicholas Matthews Tue, 01/20/2009 - 13:40

This sounds like a bug in the 7921 firmware. If you're on 1-2-1 there's a good chance this isn't something that has been looked at yet, as the trunk configuration is not used very often.

What are you using the trunk configuration for?

tiger_401 Wed, 01/21/2009 - 05:26

Dear,

I am using truck config to configure direct number for each wireless ip phone. And i want that user to use FXO port which i assigned to him. This is the reason why i m using trunk config. Any tip aur suggestion from your side will highly be commendable.Plz help me in this issue. I will be greatful to you.

Thanks & Regards,

Mukarram.

tiger_401 Wed, 01/21/2009 - 22:31

Thanks for your reply. I just want to confirm that what will be the use to cor list my scenario. My main goal is that i want all wireless ip phone users to use their own fxo port for incoming and out going calls.

Attached is the running config on my router.

what will connection-plar opx will do.

Thanks again. Waiting for your reply.

Malik.

Correct Answer
Nicholas Matthews Thu, 01/22/2009 - 17:39

Hi Malik,

Connection plar will automatically ring the IP phone when the FXO rings. opx is just a keyword we add in certain scenarios, but it shouldn't make a difference here.

connection plar is for inbound calls, and corlists are for outbound calls. Your config now will work for inbound, but not outbound.

hth,

nick

tiger_401 Fri, 01/23/2009 - 21:36

Thanks for your reply. Kindly tell me how can i make outing calls from my wireless ip phones 7921. And on the other hand 7911 are working absolutely fine with the same configuration. Can u plz help me solving this issue. I will be very thankful to you.

Correct Answer
Nicholas Matthews Sun, 01/25/2009 - 21:09

With the original configuration, it sounds like one of two things:

1) This isn't supported on this phone

2) It's a bug.

I wasn't able to find any information on either 1 or 2. You can open a TAC case to have someone investigate, or you could go with the work around that I mentioned earlier.

hth,

nick

tiger_401 Sun, 01/25/2009 - 23:02

Thanks for your reply. I really appriciate for your support. The thing is that when i configure the wireless ip phone 7921 with .T dial peer its work fine for example it can receive and make outgoing call but when i use trunk access i.e. A1 or A2 then it receives only but it cant make outgoing call.

The problem is that i cant use .T dial peer because i want ip phone users to use thier own FXO ports for making outgoing and incoming calls. Please help me solve this issue. I m really in deep trouble. I want to solve it myself before opening a TAC case.

Thanks & Regards,

Malik

Correct Answer
Nicholas Matthews Mon, 01/26/2009 - 05:35

You can keep the .T dial peer, but apply an outgoing corlist to the phone. Make sure that the only phone that has access to dial out of that dial peer is the 7921 that has an incoming corlist defined on the ephone-dn. For help on configuring corlists, I posted a link in one of my other messages.

Corlists limit which ephones can use which dial peers. It's commonly used to match one user to one port - this exact situation.

hth,

nick

tiger_401 Thu, 01/29/2009 - 04:26

Dear Mr. Nick,

Thanks for your help and support. I can understand that i need to configure corlist in my voice router. But can you plz tell me how can i configure it. Like for example can you plz add some sample configuration in the post so that i can understand exactly which commands i need to configure.

Your consideration in this regard will highly be commendable.

Will be anxioulsy waiting for your reply.

Thanks & Regards,

Malik.

tiger_401 Sat, 01/31/2009 - 22:29

Dear Mr. Nick,

Please just confirm me that is this what you want me to configure:

Find below configuration and you need to select “Cor list “ maching from Phone in  “GUI Phone option.

 

 

!

dial-peer cor custom

 name c5776363

 name c5776347

 name c5775942

 name c5775903

 name c5775836

 name c5775833

 name c5775826

 name c5775787


dial-peer cor list CALL-5776363

 member c5776363

dial-peer cor list CALL-5776347

 member c5776347

dial-peer cor list CALL-5775942

 member c5775942

dial-peer cor list CALL-5775903

 member c5775903

dial-peer cor list CALL-5775836

 member c5775836

dial-peer cor list CALL-5775833

 member c5775833

dial-peer cor list CALL-5775826

 member c5775826 

dial-peer cor list CALL-5775787

 member c5775787


dial-peer voice 8 pots

 answer-address 5776363

 corlist outgoing C5776363

 destination-pattern .T

 port 0/2/0

 

!

dial-peer voice 9 pots

 answer-address 5776347

 corlist outgoing C5776347

 destination-pattern .T

 port 0/2/1

 

…….. more Dial-peer need to create…..

 

 

 

tiger_401 Tue, 02/03/2009 - 12:13

Dear Mr. Nick,

I configured my router according to your suggestions. Please find attached configuration of my router.

But the problem is that all the three ip phone i.e. one 7921 and three 7911 are still picking the random FXO ports. Can you please guide me in this regard. I will be very thankful to you and please do reply me. I am in deep trouble.

My main goal is that I want ip phone users to use their own FXO ports which are assigned to them.

Correct Answer
Nicholas Matthews Tue, 02/03/2009 - 17:28

You can check this thread that is going on also now that is the same issue. There are some helpful links in here that may help you with the configuration:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.2cc2ef79

hth,

nick

Correct Answer
Nicholas Matthews Tue, 02/03/2009 - 17:38

And this is what the sample corlist looks like:

dial-peer cor list 1004Outbound

member 1004Outbound

!

dial-peer cor list 1005Outbound

member 1005Outbound

!

dial-peer cor list 1006Outbound

member 1006Outbound

!

dial-peer cor list 1007Outbound

member 1007Outbound

!

dial-peer cor list 1008Outbound

member 1008Outbound

!

dial-peer voice 1000 pots

corlist outgoing 1004Outbound

destination-pattern 9T

port 0/0/0

!

dial-peer voice 1003 pots

corlist outgoing 1007Outbound

destination-pattern 9T

port 0/0/3

!

dial-peer voice 1002 pots

corlist outgoing 1006Outbound

destination-pattern 9T

port 0/0/2

!

dial-peer voice 1010 pots

corlist outgoing 1008Outbound

destination-pattern 9T

port 0/1/0

!

dial-peer voice 1001 pots

corlist outgoing 1005Outbound

destination-pattern 9T

port 0/0/1

!

ephone-dn 1 dual-line

corlist incoming 1004Outbound

!

!

ephone-dn 2 dual-line

corlist incoming 1005Outbound

!

!

ephone-dn 3 dual-line

corlist incoming 1006Outbound

!

!

ephone-dn 4 dual-line

corlist incoming 1007Outbound

!

!

ephone-dn 5 dual-line

corlist incoming 1008Outbound

hth,

nick

tiger_401 Thu, 02/05/2009 - 05:43

Dear Mr. Nick,

Thanks a lot for your help and support from the beginning of my post. I am really very very thankful to you. After struggling for so my weeks we managed to fix the problem.

I followed your sample configuration given in your post above.

I removed the answer-address command from my dial-peers and it starts working fine.

The problem is that the wireless ip phones 7921 doesnt support trunk configuration like A1 or 80 (this is what my experience is). It works with trunk A1 or 80 only when you configure secondary-dialtone 9 under telephony-servcie command, and make outing call from 7921 by pressing 9 first.

Can you please tell me why FXO port pick random ports when i conifgure answer-address command in my dial peers but it work fine when i removed that command. As answer-address command is for out going calls not for incoming calls. Right ???.

Attached is my running config which is working absolutely fine.

I really appricate your help and support.

Thanks & Regards,

Malik.

Nicholas Matthews Thu, 02/05/2009 - 06:26

Answer-address will cause your dial peer selection to work quite differently.

The order is:

Incoming called-number

answer-address

destination-pattern

port

We were matching destination-pattern before, and by adding answer-address it will cause ports to be chosen in a different manner.

hth,

nick

Actions

This Discussion