How do you connect to an ASA 5505 ?

Answered Question
Dec 23rd, 2008

I have tried by putting https://192.168.1.1 into my browser, and that gets me to a screen where I can install a launcher, run a settup wizard or run an applet.

I have installed the launcher. It asks for the IP, username and password. Following section 5 in the manual I give it an IP of 192.168.1.1 and leave the username and password blank.

After a long wait I get "permission denied." I have managed to get in with the blue cable in Com1 and created a password, but I still get the same result from the browser.

When I try it with either the applet or the wizard I get "error. Click for details". The details consists of this:

load: class com.cisco.nm.dice.loader.Loader not found.

java.lang.ClassNotFoundException: com.cisco.nm.dice.loader.Loader

at sun.applet.AppletClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadCode(Unknown Source)

at sun.applet.AppletPanel.createApplet(Unknown Source)

at sun.plugin.AppletViewer.createApplet(Unknown Source)

at sun.applet.AppletPanel.runLoader(Unknown Source)

at sun.applet.AppletPanel.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

I would be glad to set it up with the blue cable, but I cannot find a list of commands.

I did at one point find an opportunity to reset it to defaults, but it didn't work. The reset hole in the front doesn't work either.

Where can I find a command reference for it ?

I have this problem too.
0 votes
Correct Answer by John Blakley about 7 years 11 months ago

That's odd. I'm running version 6 update 7, and it works fine for me. What do you have listed in Windows Add/Remove Programs?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (3 ratings)
Loading.
John Blakley Tue, 12/23/2008 - 11:54

You're having a problem with java. It seems that ASDM only works well with certain versions. You may either want to downgrade or upgrade your java version.

HTH,

John

MyersEngineering.com Tue, 12/23/2008 - 12:04

How do I do downgrade or upgrade ?

Where can I find an older or newer version?

I have gone to sun.com, Downloads A-Z, and there is only one option for Windows.

John Blakley Tue, 12/23/2008 - 12:11

What version are you running now? You can tell by going to Control Panel/Java and then click on the About button. It should say what version, and then I can point you to the right direction (hopefully).

HTH,

John

MyersEngineering.com Tue, 12/23/2008 - 12:49

It was xpiinstall-6u11-fcs-bin-b90-windows-i586-25_nov_2008.exe

I uninstalled that and installed j2re-1_4_2_19-windows-i586-p.exe

Then I tried to get into the ASA 5500. It told me I needed to install a plugin, and when I clicked to let it, it started to put the same old 6u11 back again.

So if folks can downgrade, how do they do it? The only other version I can find on Sun's site is apparently so old that it isn't even recognozed as valid, and I am directed right back to what doesn't work.

Correct Answer
John Blakley Tue, 12/23/2008 - 13:00

That's odd. I'm running version 6 update 7, and it works fine for me. What do you have listed in Windows Add/Remove Programs?

MyersEngineering.com Tue, 12/23/2008 - 13:09

V1.4.2_19

And it isn't working, and I suspect you'll want to know what's in there after I reinstall the previous one. One moment please.

MyersEngineering.com Tue, 12/23/2008 - 13:20

OK, it is not Java(TM) 6 Update 11

And now when I try my launcher I get ASDM is unable to read the configurartion from the ASA ...

MyersEngineering.com Tue, 12/23/2008 - 13:23

So I tried it with the applet, ant IT WENT IN :)

Thank you very much. Have a merry Christmas.

And now I must go hack my way through the ice on my wife's car :(

MyersEngineering.com Wed, 12/24/2008 - 04:59

And this morning, rereading yesterday's posts, where I said "OK, it is not Java 6 (TM), the w in not should have been a w in now. It is indeed Java 6 update 11. Sorry.

Actions

This Discussion