Unable to change console speed on C2960 with set/unset BAUD

Unanswered Question
Dec 23rd, 2008
User Badges:

Hi,

I have just recover my c2960 switch uploading IOS by xmodem. During the orocedure I changed the baud rate to 115200 to make faster, and now I am not able to change it. I tried unset BAUD, set BAUD 9600... anytime I reboot the switch is again with 115200.

In show run after rebooting appears


line console 0

speed 115200


I have changed it with speed command and save, but is appears again after reboot.

Any idea?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
viyuan700 Tue, 12/23/2008 - 13:38
User Badges:
  • Silver, 250 points or more

check ur sh startup-config, what is the value ?If 9600 there.


Then ur switch configuration register is set to a value where it bypass the statupconfig file a boot.


ullasupendran Tue, 12/23/2008 - 14:09
User Badges:

Hi


Try changing your config-register value to 0x2101 or 0x2102.save it and restart. That will set the baud rate back to 9600.


"Pls Rate if it helps"


Ullas

loretomarquez Mon, 12/29/2008 - 03:21
User Badges:

Hi Viyuan,

My startup configuration was empty ¿? I retype again speed 9600 in line console 0, save and copy running into startup-config

With this, my startup configuration now is correct. I reloaded the switch and I still have 115200. I think the router doesn't chose the correct config file for booting.

Switch#dir

Directory of flash:/


2 -rwx 616 Mar 1 1993 00:43:58 +00:00 vlan.dat

3 -rwx 5 Mar 1 1993 00:06:23 +00:00 private-config.text

5 -rwx 4671232 Jan 1 1970 02:44:02 +00:00 c2960-lanbase-mz.122-2-25.SEE3.bin

7 -rwx 1905 Mar 1 1993 00:06:23 +00:00 config.text

621 drwx 192 Mar 1 1993 00:24:55 +00:00 c2960-lanbase-mz.122-25.FX


32514048 bytes total (22154752 bytes free)

Switch#show boot

BOOT path-list : flash:c2960-lanbase-mz.122-25.FX/c2960-lanbase-mz.122-25.FX.bin

Config file : flash:/config.text

Private Config file : flash:/private-config.text

Enable Break : no

Manual Boot : no

HELPER path-list :

Auto upgrade : yes

NVRAM/Config file

buffer size: 65536

Any idea?


glen.grant Mon, 12/29/2008 - 05:58
User Badges:
  • Purple, 4500 points or more

Whats does your config register say ? Do a show version and it will tell you what it is. If its not 0x2101 or 0x2102 then it is incorrect and you have to change it . Putting anything on the line console interface will not help. The register governs the console speed.

loretomarquez Mon, 12/29/2008 - 08:49
User Badges:

Hi Glen,

As you can see config register is 0xF. I hadn't change it, this is the factory value.


Switch#show version

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Wed 12-Oct-05 22:05 by yenanh


ROM: Bootstrap program is C2960 boot loader

BOOTLDR: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)SEE1, RELEASE SOFTWARE (fc1)


Switch uptime is 3 hours, 58 minutes

System returned to ROM by power-on

System image file is "flash:c2960-lanbase-mz.122-25.FX/c2960-lanbase-mz.122-25.FX.bin"


cisco WS-C2960-48TC-L (PowerPC405) processor (revision C0) with 61440K/4088K bytes of memory.

Processor board ID FOC1121ZDJE

Last reset from power-on

1 Virtual Ethernet interface

48 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.


64K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address : 00:1C:57:74:AA:80

Motherboard assembly number : 73-9835-07

Power supply part number : 341-0097-02

Motherboard serial number : FOC1121400G

Power supply serial number : DCA111486MQ

Model revision number : C0

Motherboard revision number : C0

Model number : WS-C2960-48TC-L

System serial number : FOC1121ZDJE

Top Assembly Part Number : 800-26672-02

Top Assembly Revision Number : D0

Version ID : V02

CLEI Code Number : COM3F00BRA

Hardware Board Revision Number : 0x02



Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 50 WS-C2960-48TC-L 12.2(25)FX C2960-LANBASE-M



Configuration register is 0xF


Switch#

viyuan700 Mon, 12/29/2008 - 07:13
User Badges:
  • Silver, 250 points or more

An mentioned in other post ur configuration register looks like is 0x2142(can be something else) in this setting it dont read the startup-config.


YOu change to this value if you forgot the password and cannot login.


loretomarquez Mon, 12/29/2008 - 09:49
User Badges:

Hi,

Yes I know what you mean I have use those values with other models for password recovery, but in this case the config register is 0xF which is normal in this model as I has been reading. You can see the show version in the answer I wrote before to glen.grant.


viyuan700 Mon, 12/29/2008 - 12:01
User Badges:
  • Silver, 250 points or more

BOOT path-list : flash:c2960-lanbase-mz.122-25.FX/c2960-lanbase-mz.122-25.FX.bin


Config file : flash:/config.text


Your config file path has /,u can try without it like in flash path.


Though it doesnot make sense but sometimes i see problem when i include / in defining path.

loretomarquez Tue, 12/30/2008 - 03:56
User Badges:

I have another 2960 with the same path and everithing goes correct.


Anyway I tried by changing the path to


flash:c2960-lanbase-mz.122-2-25.SEE3.bin


and the problem persists. The load of the image is normal but I still can't change the console baud rate.

This is very strange. It must be something fixed before the load of the image.


loretomarquez Tue, 12/30/2008 - 06:29
User Badges:

:o) It works.

This is what I did:

-shutdown the switch

-press Mode button while power on the switch to enter in switch: mode.

-enter set command to see the BAUD=115200

-enter flash_init command

-now is the right moment to enter unset BAUD command

-continue booting the switch in my case with

boot flash:c2960-lanbase-mz.122-2-25.SEE3.bin


I have reloaded the switch several times after this and fortunately it remains with the correct bau rate.

Anyway thanks for your help.


normbeef Sun, 08/07/2011 - 13:11
User Badges:

This works for 3560's as well been driving me insane o my lab..


many thanks loretomarquez



You must be precise with the syntax  


the command is    unset BAUD   from switch:

Peter Marshall Wed, 05/28/2014 - 05:39
User Badges:

Boot the switch in ROMMON

Change it in ROMMON (case sensitive):

set BAUD 9600

Reboot the switch.

Actions

This Discussion