How to change ani of redirected extension in CME

Answered Question
Dec 23rd, 2008

Have an issue whereby the redirected call presents its extension number rather than correct callerid for pstn.

Scenario:

Call comes in from PSTN and rings on reception phone. Reception phone redirects to internal extension this then redirects back out to PSTN.

Unfortunately the redirected extension doesnt change its callerid with the translation rules for some reason.

Is there a way to do this on the redirected call?

Thanks..

I have this problem too.
0 votes
Correct Answer by Nicholas Matthews about 7 years 11 months ago

You can use voice translation rules for this:

This will change a 4 digit number into a 7 digit number preceded by 555

voice translation-rule 1

rule 1 /^\(...\)$/ /555\1/

voice translation-profile 1

translate redirect-called 1

translate redirect-target 1

dial-peer voice x voip

translation-profile out 1

hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Nicholas Matthews Tue, 12/23/2008 - 15:37

You can use voice translation rules for this:

This will change a 4 digit number into a 7 digit number preceded by 555

voice translation-rule 1

rule 1 /^\(...\)$/ /555\1/

voice translation-profile 1

translate redirect-called 1

translate redirect-target 1

dial-peer voice x voip

translation-profile out 1

hth,

nick

clougher01 Sun, 12/28/2008 - 12:59

Hi,

Noticed on a 3725 router that you only have an option for redirect-called. As i want to change the orginal A party ani number this doesnt seem to work.

Pstn Inbound > Sip server > cme router(3725) > 7941(callfwd) > 7941(callfwd) > cme router > Sip server > Pstn Outbound

In order for the redirected call to work it has to go out with a specific ani number and not the original one on the first Pstn inbound call.

For some reason translation rules wont change the ani number for the redirect calls?

Any way of doing this?

Actions

This Discussion