Migrate VM from Unity 4.2 to 5.0 - VM not available

Unanswered Question
Dec 23rd, 2008

I used Cobras to backup Unity 4.2 (homed in exch03) and restore it to Unity 5.0 (homed in exch07). I could see all of my VM messages in my Outlook Inbox. However, when I tried to access VM from the phone, it's saying that "Your message is not available now. To send a message, press 2. You have no old messges". Does anyone have the same issue?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lindborg Tue, 12/23/2008 - 21:54

COBRAS Versions? Both backup and restore. I'd like to look at the logs as well - I assume the messages play ok from the desktop? In other words the wav files are there but the voice mail conversation doesn't like the attachment?

lindborg Wed, 12/24/2008 - 08:48

also - what codec are those messages in? COBRAS doesn't transcode when restoring to Unity (it does when restoring to Connection 7.0) - it's possible the codec you used on the old system is not installed on the new one - not likely but possible.

They could also be messages marked secure on the backup - shouldn't include those in the backup but that's another possibility - if they plan from the desktop then that preculdes that.

If you want, you can FTP me your backup - or better, do another backup of your old system and only include messages from one mailbox that you know has this problem (and you don't mind me hearing) and I can run through it in the lab.

ktran-anet Wed, 12/24/2008 - 10:56

Jeff,

Same COBRAS version 1.0 Build 37 for both backup and restore. You're absolutely right. I can play the messages fine from the desktop.

Attached is the import logs. As you can see, there are 3 Warnings in the logs. However, I don't think they are related.

Besides, I noticed something strange that when I tried to retore the messages ONLY for the selected subscribers (check box at step 20 is checked, i.e. Restore Voice Messages For Selected Subscribers), then proceeded with the restore like normal, COBRAS appears to hang. So I had to kill it from the Windows Task Manager. I then tried a second time to see what happens and it still hung. The 3rd time I tried and this time I unchecked the check box at step 20 and it went through alright. So looked at the Windows Event Application Viewer logs and I saw some errors at about the same time when COBRAS hung. See attached event viewer logs. Have you ever seen that before?

Thanks.

lindborg Wed, 12/24/2008 - 12:23

Couple things here.

1. The latest export is 1.0.45 - always good to try the latest, lots of fixes along the way.

2. The latest import is 1.1.11 - if you're using 1.0.37 it's back from October - many, many fixes since then - don't do anything until you try the updated version.

After you get an updated export and try the updated import (just with a single user is fine) then we can check it from there.

Presumably messages being left from the desktop via VMO and/or via the phone interface are being presented via the conversation correctly on the 2007 server, right? Just checking...

ktran-anet Thu, 12/25/2008 - 14:02

Jeff,

Thanks for your advice. I will try the latest version of import and export. FYI, I did not use VMO to leave messages. Only did that via the phones. Everything on the Unity 5.0 is default. I can get you to access my server if you like.

Thanks,

Kevin

lindborg Thu, 12/25/2008 - 16:17

If you can get an updated backup, that'd be ideal - some of the fixes related to messages (i.e. secure message handling) was in the export portion.

It'd be great if I could get a backup from you (either old or new) to walk through in the lab - if there's something wonky with the message format and/or MAPI tags, I'll see it during the message insertion process easiest as opposed to looking at the system after the fact.

ktran-anet Thu, 12/25/2008 - 17:29

Sure I can give you the old backup files (16mb). But I am trying to figure out how to get it sent over to you. Do you have any ftp server or something like that I can upload it?

lindborg Fri, 12/26/2008 - 14:18

sure - ping me off line (lindborg at cisco dot com) and I'll send you the FTP instructions for the TAC site we can use to shuttle big files around.

Actions

This Discussion