Upload Prompt Feature in IPCCX Fails after upgrade from 4.0 to 5.0.2

Unanswered Question
Dec 24th, 2008
User Badges:

I had a recording script I use that worked in 4.0.5. However, once IPCCX got upgraded to 5.0.2, the upload prompt feature within the script fails. I have authenticate user and password setup before this node so Im not sure if anyhting's changed in terms of requirements from the upgrade...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jbayuka Tue, 12/30/2008 - 09:47
User Badges:
  • Bronze, 100 points or more

Can you upload prompt manually via AppAdmin? What errors you are getting when uploading the prompt is failing?


SAN J Tue, 12/30/2008 - 12:41
User Badges:

Yes, I can upload the prompt files manually without any issues. There's no actual errors I can see when I run the reactive debug. ALl it does is it goes to the "unsuccessful" path each time after it hits the upload prompt node. The authentication I have in front of it is successful as well so I'm not sure what I'm missing if any...

mymite060708 Wed, 02/18/2009 - 06:06
User Badges:

I am getting the same issue. auth works but upload goes to unsuccessful each time

any ideas?

Chris Deren Wed, 02/18/2009 - 07:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

The authentication method was changed in UCCX 5.0, User ID requires variable of type user rather than string.


HTH,


Chris

SAN J Mon, 02/23/2009 - 13:35
User Badges:

I tried using the following steps to no avail:


1. Get User - where User ID is a string variable and Output User is a User variable.

2. Authenticate User - where User is same as Output User variable mentioned above and Password is a string variable.

3. Upload Prompt - where User is same as Output User variable menitoned above.


Still not working but manual upload does. Again, this was working just fine on 4X version. Is there a specific way the User setup needs to be before the Upload Prompt?

webberr Thu, 11/05/2009 - 13:01
User Badges:

Hi,


I'm having the same issue - did you ever resolve it?


Thanks - Rob.

SAN J Thu, 11/05/2009 - 13:09
User Badges:

Remove the "Get User" if you're using it. I ended up just using the Auth User with the user variable being USER[name] and the password being a string.

webberr Thu, 11/05/2009 - 14:24
User Badges:

Hi,


Thanks for the reply. So the "user" portion of the AuthenticateUser step seems to be looking for a String. Did you enter USER[username] directly into the step, or in that step did you reference a String variable that was USER[username]?


Thanks - Rob.

SAN J Thu, 11/05/2009 - 14:50
User Badges:

I pointed both entries to the variables. I used a "User" type for the username variable with a value of USER[name] and "string" type for the password with a value of "password". Hope that helps...

webberr Fri, 11/06/2009 - 05:01
User Badges:

Hi,


That did the trick - use an Authenticate User step right before the Upload Prompt step. For the User use a variable of type "User" with a value of USER[username]. For Password use a variable of type String with a value of "password".


Thanks for your help!

Rob.

Actions

This Discussion