vlan protocol down on NM-16ESW port installed in 3725 router

Answered Question
Dec 24th, 2008

Hello all,

I have been struggling with a problem and not sure how to fix this.

I have confirmed etherswitch nm-16esw mod in 3725 router. I have created 2 vlans for voice and data under vlan database. I have created SVI's for these vlans on the router and define ip helper-address.

I have two IP phones connected with etherswitch port 1 and port 2 so that they can send the dhcp request to register over the WAN with Call Manager.

Now the issue is I couldn't get the VLAN data and voice to be up up. The line protocol is constantly down on them.

I am running c3725-adventerprisek9_ivs-mz.124-3j on 3725. Following are my configs:

interface Loopback0

ip address 10.61.65.254 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

description SiteB-Ph1

switchport trunk native vlan 63

switchport mode trunk

switchport voice vlan 306

spanning-tree portfast

no routing dynamic

!

interface FastEthernet1/1

switchport trunk native vlan 63

switchport mode trunk

switchport voice vlan 306

spanning-tree portfast

!

interface FastEthernet1/2

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Serial2/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay lmi-type cisco

!

interface Serial2/0.102 point-to-point

ip address 172.1.2.2 255.255.255.0

frame-relay interface-dlci 102

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Vlan1

no ip address

!

interface Vlan92

description Data Vlan

ip address 10.106.65.254 255.255.255.0

ip helper-address 10.6.64.11

!

interface Vlan104

description Voice Vlan

ip address 10.206.65.254 255.255.255.0

ip helper-address 10.60.64.11

!

router ospf 1

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

network 172.0.0.0 0.255.255.255 area 0

=================vlan database=========

VLAN ISL Id: 92

Name: Data

Media Type: Ethernet

VLAN 802.10 Id: 100063

State: Operational

MTU: 1500

VLAN ISL Id: 104

Name: Voice

Media Type: Ethernet

VLAN 802.10 Id: 100306

State: Operational

MTU: 1500

Also, I have noticed that etherswitch ports fa 1/7 and fa 1/15 keep flaping even though I have not configured anything

I have this problem too.
0 votes
Correct Answer by richard.m.gilbert about 7 years 11 months ago

If I understand it correctly, you have a phone and a computer plugged in on both interface 1/0 and 1/1? If so, I think you want to have those interfaces configured as shown below ...

!

!

interface FastEthernet1/0

description SiteB-Ph1

switchport access vlan 92

switchport voice vlan 104

switchport mode access

spanning-tree portfast

no routing dynamic

!

interface FastEthernet1/1

switchport access vlan 92

switchport voice vlan 104

switchport mode access

spanning-tree portfast

no routing dynamic

!

!

As for fa1/7 and 1/15 ... have you taken the module out and blown out the bay in the router as well as the module? That might help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
glen.grant Wed, 12/24/2008 - 19:47

A lot of times you do not trunk the access ports that the phones are attached to . Set it up as a access port vlan 92 with a voice vlan 104 and get rid of the trunk statement and see what happens . If the SVI isn't up usually the port is not connected. I didn't understand the voice vlan setup , on the ports you have the voice vlan as 306 yet your definition in the vlan database and the SVI say 104 .

sakengineer Wed, 12/24/2008 - 20:29

Thanks Glen.

Please read the voice vlan as 104 and data vlan as 92. I copied the old configuration for fa 0/1 and fa 0/2.

I'll give it a try and will update you.

SAK

Correct Answer
richard.m.gilbert Wed, 12/24/2008 - 21:51

If I understand it correctly, you have a phone and a computer plugged in on both interface 1/0 and 1/1? If so, I think you want to have those interfaces configured as shown below ...

!

!

interface FastEthernet1/0

description SiteB-Ph1

switchport access vlan 92

switchport voice vlan 104

switchport mode access

spanning-tree portfast

no routing dynamic

!

interface FastEthernet1/1

switchport access vlan 92

switchport voice vlan 104

switchport mode access

spanning-tree portfast

no routing dynamic

!

!

As for fa1/7 and 1/15 ... have you taken the module out and blown out the bay in the router as well as the module? That might help.

Actions

This Discussion