Allocating BVI to the Context

Answered Question
Dec 25th, 2008


Similar to allocating VLANs to non-admin context, do BVI's also need to be allocated. Or the definition of BVI in Admin context is sufficient.

Correct Answer by Syed Iftekhar Ahmed about 8 years 2 months ago

Allocate client & Server side vlans for each context in Admin Context and then define vlan interfaces and BVI interfaces in each context.


Following is an example with two contexts


---------Admin context-------


context context1

allocate-interface vlan 101

allocate-interface vlan 102

context context2

allocate-interface vlan 201

allocate-interface vlan 202






-----------Context1----------


interface vlan 101

bridge-group 1

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

service-policy input VIPs

no shutdown

interface vlan 102

bridge-group 1

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

no shutdown


interface bvi 1

ip address 10.1.1.100 255.255.255.0

no shutdown





---------Context2--------------



interface vlan 201

bridge-group 2

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

service-policy input VIPs

no shutdown

interface vlan 202

bridge-group 2

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

no shutdown


interface bvi 2

ip address 10.2.2.100 255.255.255.0

no shutdown


Syed Iftekhar Ahmed

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Syed Iftekhar Ahmed Thu, 12/25/2008 - 11:58

Allocate client & Server side vlans for each context in Admin Context and then define vlan interfaces and BVI interfaces in each context.


Following is an example with two contexts


---------Admin context-------


context context1

allocate-interface vlan 101

allocate-interface vlan 102

context context2

allocate-interface vlan 201

allocate-interface vlan 202






-----------Context1----------


interface vlan 101

bridge-group 1

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

service-policy input VIPs

no shutdown

interface vlan 102

bridge-group 1

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

no shutdown


interface bvi 1

ip address 10.1.1.100 255.255.255.0

no shutdown





---------Context2--------------



interface vlan 201

bridge-group 2

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

service-policy input VIPs

no shutdown

interface vlan 202

bridge-group 2

access-group input BPDU

access-group input everyone

access-group output everyone

service-policy input MGMT

no shutdown


interface bvi 2

ip address 10.2.2.100 255.255.255.0

no shutdown


Syed Iftekhar Ahmed

Actions

This Discussion