Internal Integration between Ether Switch Module and CME Route Module

Unanswered Question
Dec 26th, 2008

Hi Team,

I am having Cisco 2811 CME router with NME-16ES-1G-P Module. I am able to login to the sevice module and configure the same.

But the switch service module is integrated with the router's gig interface externally using cat5 cable. I strongly believe that there must be a way to connect the switch service module with the router module internally by running some command/s.

I have already gone through "Cisco EtherSwitch Service Modules Feature

Guide" and didn't find any way to integrate them internally.

Kindly help me to understand this integration between Router Module with Switch service Module.

Thanks and Regards,

Ashish Sehgal

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
don-sullivan Mon, 12/29/2008 - 13:23

I couldn't find the document that helped. So I'll try to do my best. If you have any questions please ask.

The NME-16ES-1G-P module is managed with an ip address assigned to it's external gigabit port on the router. On the 2811 it fills the NM port on the router assigning itself to GI1/0.

Management is accomplished by the following:

interface gi10/0

ip address x.x.x.x x.x.x.x

service-module gigabitethernet 1/0 session

The module itself acts as an external 3750 switch. Any updates to the IOS should use 3750 images.

This is where it gets a little more complicated. Even though Gi1/0 is external on the NME module it can be used by the router itself and by the switch.

For example the router sees this port as Gi10/0. The switch sees this port externally as GI1/0/1. You may use this port as an uplink to additional external switches and or hubs. You can also send VLAN, VTP and trunking features across this interface.

The NME sees it's internal communications with the router using the internal port of GI1/0/2. You can send VLAN, VTP and trunking features. However these will be seen by the router.

ashish.sehgal@w... Mon, 12/29/2008 - 19:16

Thanks Don ,

for your efforts and study. But I am trying to find out the way to internally connect the switch with the router. I am sure there would be some command to integrate the same.

Thanks,

Ashish

don-sullivan Tue, 12/30/2008 - 07:36

If your talking about starting a session to the switch from the router IOS. You need to.

Conf t

interface Gi1/0

ip add ip.ip.ip.ip m.m.m.m

no shut

You don't need to use an ip address in your scheme. This address is only used to create a session to the switch.

If you wish to have the switch and router communicate. You can trunk the ports.

vlan database

vlan 2 Test2

vlan 10 Test10

exit

Above create the vlans. The exit command will also apply the above commands to the configuration.

conf t

interface gi1/0

ip add ip.ip.ip.ip m.m.m.m

no shut

Above: Again use an ip address not in your scheme.

interface gi1/0.1

encap dot1q 1 native

ip add ip.ip.ip.ip m.m.m.m

Above: Use an ip address appropriate for that vlan. You can add as many vlans as supported by adding more virtual interfaces. Another example is below.

interface gi1/0.10

encap dot1q 10

Above: This would create a subinterface on vlan 10. Again use an ip address for that subnet. If I remember correctly you cannot use isl for trunking you must use dot1q.

Next you need to start a session with the switch. From the # prompt type the following command.

service-module gigabitethernet 1/0 session

You should be able to press the enter key to get a Switch> prompt.

Use the en command to get to enable mode.

Then issue the following commands to trunk the switch.

conf t

int gi1/0/1

switchport trunk encap dot1q

switchport mode trunk

Use the above command to also trunk the external gigabit interface on the router.

int gi1/0/2

switchport trunk encap dot1q

switchport mode trunk

The above will create a trunk between the switch and the router.

int vlan 1

ip add ip.ip.ip.ip m.m.m.m

no shut

Above: Use an ip address for the range of this vlan. This should also be in the range for the above configuration for subinterface gi1/0.1.

exit

ip route 0.0.0.0 0.0.0.0 ip.ip.ip.ip (ip address used on subinterface gi1/0.1)

This will allow you to manage the switch without have to session through the router.

Hope all of this helps

ashish.sehgal@w... Wed, 12/31/2008 - 00:04

Thanks Ron,

With your explanation and configuration I understand that:

1. Assign an IP to Gi1/0 for the purpose of accessing the switch module from the router prompt using the command:

service-module gigabitethernet 1/0 session

2. Divide the main interface in to two sub-interfaces viz. Gi1/0.2 and Gi1/0.3, pointing to Vlan 2 and 3 respectively. Where Vlan 2 is for Voice traffic and Vlan 3 is for Data.

This will allow the inter Vlan communication between the two VLANs. And thus the configuration will be as follows:

Interface gi1/0

Ip address 10.10.10.10 255.255.255.0

No shut

!

Interface gi1/0.2

Ip address 10.2.2.1 255.255.255.0

Description Sub Interface for Voice VLAN

encapsulation dot1q 2

No shut

!

interface gi1/0.3

ip address 10.3.3.3.1 255.255.255.0

description Sub interface for Data VLAN

encapsulation dot1q 3

no shut

Now login to the switch and configure the Vlans as follows:

Vlan database

Vlan 2 name Voice

Vlan 3 name Data

Kindly verify and let me know if I have understood your explanation correctly.

Regards,

Ashish

don-sullivan Wed, 12/31/2008 - 16:48

1. You got it.

2. Your commands are fine until your login to the switch.

Before configuring interface gi1/0 add the following commands.

vlan database

vlan 2 name Voice

vlan 3 name Data

Now for your switch commands.

conf t

vlan 2

name Voice

vlan 3

name Data

exit

interface gi1/0/2

switchport trunk encap dot1q

switchport mode trunk

int vlan3

ip add 10.3.3.x 255.255.255.0

desc Interface for Data VLAN

no shut

int vlan 1

shut

exit

ip route 0.0.0.0 0.0.0.0 10.3.3.1 or ip default-gateway 10.3.3.1

That should be all the commands to setup trunking between the router and the switch. It should also allow you to telnet into the switch without having to go through the router.

ashish.sehgal@w... Thu, 01/01/2009 - 22:24

Hi Don,

Thanks for the reply. I understand that from the router I have to specify two route towards the Voice and Data VLAN each and single route on the switch towards the default gateway.

Correct me if I am wrong.

Hope I am very close to the solution.

Thanks and Regards,

Ashish

Actions

Login or Register to take actions

This Discussion

Posted December 26, 2008 at 7:35 AM
Stats:
Replies:6 Avg. Rating:
Views:550 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,051
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
116
105
103
76
72