cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
819
Views
13
Helpful
8
Replies

load balance Serial Fast Ethernet (Shape 2000)

pesanchez2002
Level 1
Level 1

------------------------------

| |

R1 --------- R2 Int FasEthernet (Metro Ethernet) - shape average 2000000

| Fast |

| |

------------

Serial

BW: 2048

R1 is now connected by a Fast Ethernet interface R2, through a

service provider that provides the link of 2 Mbps.

In this Link, we are applying this quality of service:

R2 configuration is:

policy-map A

class Voz

priority 500

set cos 5

class Signal

bandwidth 128

set cos 3

class business

bandwidth 300

set cos 3

class class-default

fair-queue

random-detect

policy-map B

class class-default

shape average 2000000

service-policy A

!

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.1.1.1 255.255.255.0

service-policy output B

I am placing new serial (BW 2048) link between R1 and R2, for load balancing and backup

Should I make the same configuration qos in R2 in serial interface that connects to R1?

How to configure load balancing between the links serial and fast ethernet (2 Mbits Shape)? Variance ?

Currently I have the following default route in R2

ip route 0.0.0.0 0.0.0.0 10.1.1.2 (10.1.1.2 is the address of interface fasethernet in R1)

Should I set default route to R2 in serial interface?

R2 is an access router

8 Replies 8

pesanchez2002
Level 1
Level 1

.

pesanchez2002
Level 1
Level 1

Hi,

Someone can help me?

Thanks

lejoe.thomas
Level 3
Level 3

Hi,

I am not sure if I fully understood your topology, as far as I have understood

R2 (serial and FE) ---------> (serial and FE) R1

You wish to load balance across serial and fast ethernet links.

1) Define default routes

ip route 0.0.0.0 0.0.0.0 next-hop (through FE)

track 2

ip route 0.0.0.0 0.0.0.0 next-hop (through serial) track 3

--With the above load balancing is achieved on per source-destination basis.

--Define tracking, which will remove inactive routes from load balancing.

2)Define Tracking (Pesudo code)

track 2 ip sla 22 reachability

track 3 ip sla 33 reachability

--Define sla operation 22 and 33

ip sla 22

icmp-echo next-hop for FE interface

--Define start time and life-time etc

ip sla schedule 22 start-time now life forever

Similarly do the IP sla for the serial interface as well.

3) Define QOS policy on the serial interface as well

eg: service policy output

4)I am assuming R2 is the ingress router, where the traffic originates, in which case on the ingress interface, consider using Policy based routing to explicitly set next-hop ip for VOIP traffic

eg:[Voip phones to IP PBX etc]

This is to ensure VOIP traffic always goes through Fast Ethernet or serial link (but not both) to avoid jitter and delay etc.

References

Track ip SLA

http://www.cisco.com/en/US/docs/ios/ipapp/command/reference/iap_s3.html#wp1064929

icmp-echo

http://www.cisco.com/en/US/docs/ios/ipsla/command/reference/sla_02.html#wp1050691

I hope this gives you a general guide on how to tackle your issue.

HTH

Lejoe

Joseph W. Doherty
Hall of Fame
Hall of Fame

"Should I make the same configuration qos in R2 in serial interface that connects to R1? "

You could, or if the serial is truly 2 Mbps, just use your policy map A.

"How to configure load balancing between the links serial and fast ethernet (2 Mbits Shape)? Variance ? "

Depends on how you're routing. Many dynamic routing protocols support equal cost, i.e. just insure the bandwidth is set for 2 Mbps on both links.

"ip route 0.0.0.0 0.0.0.0 10.1.1.2 (10.1.1.2 is the address of interface fasethernet in R1)

Should I set default route to R2 in serial interface?"

If you're using statics, define a similar default route to R2 should load balance too.

Thank you for respond,

I add information, to put more clearly the network.

I am also adding graphic.

The idea is that R2 and R3 can send the data and VOIP to R1 with qos and balance the load among serial links and the metro ethernet .

Am I using adequately the command "shape average" in the 3 router?

I do not understand when Lejoe said:

"This is to ensure VOIP traffic always goes through Fast Ethernet or serial link (but not both)

to avoid jitter and delay etc."

is not appropriate in VOIP to balance load?

Do I have to apply variance?

To have connected the 3 routers at the same network segment through the metro ethernet i am not going to generate loop, due to the other new serial connections?

I am using the command bandwidth in the interface fastethernet to adjust to the real values. Is correct?

--------------------------------------------

Conf:

R3 configuration is:

policy-map A

class Voz

priority 500

set cos 5

class Signal

bandwidth 128

set cos 3

class business

bandwidth 300

set cos 3

class class-default

fair-queue

random-detect

!

policy-map B

class class-default

shape average 2000000

service-policy A

!

!

interface FastEthernet0/0.10

bandwidth 2048

encapsulation dot1Q 10

ip address 10.1.1.1 255.255.255.0

service-policy output B

!

!

router eigrp 1

redistribute connected

network 10.0.0.0 0.0.0.255

no auto-summary

!

!

interface Serial0/0

Description connection to R1

bandwidth 2048

ip address 10.1.2.1 255.255.255.252

no ip mroute-cache

service-policy output B

-------------------------------------------------------

R2 configuration is:

policy-map A

class Voz

priority 500

set cos 5

class Signal

bandwidth 128

set cos 3

class business

bandwidth 300

set cos 3

class class-default

fair-queue

random-detect

!

policy-map B

class class-default

shape average 2000000

service-policy A

!

!

interface FastEthernet0/0.10

bandwidth 2048

encapsulation dot1Q 10

ip address 10.1.1.2 255.255.255.0

service-policy output B

!

!

router eigrp 1

redistribute connected

network 10.1.1.0 0.0.0.255

no auto-summary

!

!

interface Serial0/0

descrition connection to R1

bandwidth 2048

ip address 10.1.3.1 255.255.255.252

no ip mroute-cache

service-policy output B

-----------------------------------------------------

R1 configuration is:

policy-map A

class Voz

priority 500

set cos 5

class Signal

bandwidth 128

set cos 3

class business

bandwidth 300

set cos 3

class class-default

fair-queue

random-detect

!

policy-map B

class class-default

shape average 4000000

service-policy A

!

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.1.1.3 255.255.255.0

service-policy output B

!

interface Serial0/0

Description connection to R2

bandwidth 2048

ip address 10.1.3.2 255.255.255.252

no ip mroute-cache

service-policy output B

!

interface Serial0/1

bandwidth 2048 connection to R3

ip address 10.1.2.2 255.255.255.252

no ip mroute-cache

service-policy output B

!

!

router eigrp 1

bandwidth 4096

redistribute connected

network 10.1.1.0 0.0.0.255

no auto-summary

!

Hi Pedro,

I said to use one of links for voice because voice packets are sensitive to delay. So if there's variation in the network delay through FE and SE interfaces, voice quality is likely to be affected. This can be obtained by measuring those parameters, cacti graphs etc.

Anyways, assuming both interfaces will offer consistent delay, this shouldn't be a problem.

Now for the eigrp configuration on R1,R2, R3

add network statements for the serial interfaces as well, otherwise they'll only learn routes via FE.

When you do this, you'll need to add the variance command in EIGRP to loadbalance traffic across serial and FE interfaces, because by default delay on FE interfaces are 100usec and serial interfaces is 200usec. Hence the metric of routes learnt through the serial interface will be slightly higher.

On R1, you are applying the same policy map on serial interfaces with shaping rate exceeding the line rate.

Hence make the correction on R1

policy-map C

class class-default

shape average 2000000

service-policy A

interface Serial0/0

Description connection to R2

bandwidth 2048

ip address 10.1.3.2 255.255.255.252

no ip mroute-cache

service-policy output C

!

interface Serial0/1

bandwidth 2048 connection to R3

ip address 10.1.2.2 255.255.255.252

no ip mroute-cache

service-policy output C

The bandwidth command specifies how much bandwidth is available on a interface to various IOS tools, such as eigrp in this case, which uses it to calculate its metric. However, it does not affect the actual line rate.

HTH

Lejoe

Hi Lejoe,

Thanks for respond.

Whe you say "So if there's variation in the network delay through FE and

SE interfaces, voice quality is likely to be affected.

This can be obtained by measuring those parameters, cacti graphs etc."

While achieving install this tool, how can monitor these parameters

through commands of ios?

When i connect the 3 routers at the same network segment, through

the metro ethernet, i am not going to generate loop, due to the

other new serial connections?

Hi Pedro,

The various parameters you'll need monitor to make sure service levels are met are

(per direction) jitter , packet loss ,delay etc.

For measuring these parameters, IOS IP SLAs need to be configured. Under this, since voice packets are primarily UDP based, you need to measure udp-jitter.

http://www.cisco.com/en/US/docs/ios/12_4/ip_sla/configuration/guide/hsjitter.html

It defines two steps to measure UDP-jitter

- Configuring the IP SLAs Responder on the Destination Device (required)

- Configuring and Scheduling a UDP Jitter Operation on the Source Device

Read the paper above. Example would be, R2 and R3 should be configured as source devices, with R1 as a responder. Now the routers will start collecting the various parameters mentioned above (jitter,delay etc).

However tools such as Cacti can use this information to generate SLA graphs and store it for review later because routers do not keep the results for very long (i.e routers sort of keep this information buffered for a finite amount of time).

When i connect the 3 routers at the same network segment, through

the metro ethernet, i am not going to generate loop, due to the

other new serial connections?

No, in this there will not be any loops.

HTH

Lejoe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card