Router 1841 does not boot

Answered Question
Dec 28th, 2008

HI,


I have a router 1841 that when I power it on it boots into rommon. Below the output when the router bootsup.


Wrong system software for this hardware


System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2006 by cisco Systems, Inc.

PLD version 0x10

GIO ASIC version 0x127

c1841 platform with 393216 Kbytes of main memory

Main memory is configured to 64 bit mode with parity disabled



Readonly ROMMON initialized

program load complete, entry point: 0x8000f000, size: 0xcb80

program load complete, entry point: 0x8000f000, size: 0xcb80


program load complete, entry point: 0x8000f000, size: 0x1bb6200

Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################### [OK]


Wrong system software for this hardware


System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2006 by cisco Systems, Inc.

PLD version 0x10

GIO ASIC version 0x127

c1841 platform with 393216 Kbytes of main memory

Main memory is configured to 64 bit mode with parity disabled



Readonly ROMMON initialized

rommon 1 >


I have checked and the register is configured OK 0x2102. I have tried to change the register value to 0x2101 so that I can boot the router using the boot image so that I can reload the IOS of the router but was not able start the router using the boot Image as the router falls into a loop.


Any idea what is causing this problem and how I can solve it?


Regards,


Screech


Correct Answer by Richard Burts about 8 years 2 months ago

Screech


You do not tell us about it, but I would guess that you recently upgraded the code on this router. And it looks like the code that you loaded is not the correct code for this 1841. The key is this message:

Wrong system software for this hardware


Since it is already booting into rommon there is no benefit from changing the config register. I suggest that you check and get an image that is correct for this 1841 and then use the tftpdnld command to load the new image. (note that you will have to set some parameters in rommon for tftpdnld to be able to get to the tftp server and access the correct image)


It would be interesting to get the output of show flash of the current image to see what it is.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Correct Answer
Richard Burts Sun, 12/28/2008 - 20:34

Screech


You do not tell us about it, but I would guess that you recently upgraded the code on this router. And it looks like the code that you loaded is not the correct code for this 1841. The key is this message:

Wrong system software for this hardware


Since it is already booting into rommon there is no benefit from changing the config register. I suggest that you check and get an image that is correct for this 1841 and then use the tftpdnld command to load the new image. (note that you will have to set some parameters in rommon for tftpdnld to be able to get to the tftp server and access the correct image)


It would be interesting to get the output of show flash of the current image to see what it is.


HTH


Rick

Actions

This Discussion