Does ASR1004 support port-channel?

Unanswered Question
Dec 29th, 2008
User Badges:

Dear all,


I am facing issue on setting up the port-channel between ASR1004 and a switch. I have to configure "port-channel load-balancing vlan-manual" command to bring the channel up. But by doing that, the port-channel become active & standby mode which is not our initial objective (to aggregate the links).


Any helper?


Thanks & Regards.


example of my ASR config:

=================

port-channel load-balancing vlan-manual


interface Port-channel5

no ip address

negotiation auto

!

interface Port-channe5.24

encapsulation dot1Q 24

ip address 192.168.1.1 255.255.255.252

!

interface GigabitEthernet0/0/0

no ip address

negotiation auto

no cdp enable

channel-group 5

!

interface GigabitEthernet0/0/1

no ip address

negotiation auto

no cdp enable

channel-group 5



====

ASR Router#show vlans 24


VLAN ID: 24 (IEEE 802.1Q Encapsulation)


Protocols Configured: Received: Transmitted:

IP 88 28


VLAN trunk interfaces for VLAN ID 24:

Port-channel5.24


Port-channel5.24 (24)

Mapping for traffic load-balancing using bucket 1:

primary = GigabitEthernet0/0/0 (active, D, P)

secondary = GigabitEthernet0/0/1 (standby, D, P)


IP: 192.168.1.1


Total 1528 packets, 107550 bytes input

Total 38 packets, 3766 bytes output No subinterface configured with ISL VLAN ID 24

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 12/29/2008 - 01:17
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

in the IOS XE configuration guide there is a chapter about this


http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_cfg_gecvlan_ps9587_TSD_Products_Configuration_Guide_Chapter.html


However, it looks like that the implementation is Vlan based: for each Vlan a primary physical link can be defined and a secondary member link.

So if you have multiple Vlans over the bundle you can achieve some load sharing but for a single Vlan only a one link is used.


A possible suggestion is to try to configure the port channel manually and to see if it works without the command that enables ther per vlan load sharing


or even to give an LACP active role to ports on one side


is channel-group 5 active an accepted option ?


Hope to help

Giuseppe


doraemonheng Mon, 12/29/2008 - 17:42
User Badges:

Hi Guiseppe,


Thanks for reply.


Am experienced difficulty to follow the above configuration guide.

1. There is no "mode on" behind the channel-group 1. May be is by default?


2. The system will show you IP overlap when you configure below commands by following the guide.


===================================

interface Port-channel1.100

encapsulation dot1Q 100 primary GigabitEthernet1/1

secondary GigabitEthernet1/2

ip address 173.1.2.100 255.255.255.0

!

interface Port-channel1.200

encapsulation dot1Q 200 primary GigabitEthernet1/2

ip address 173.1.2.200 255.255.255.0

===================================


Thanks & Regards,

Giuseppe Larosa Mon, 12/29/2008 - 23:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello ,


the ip addresses in different vlan subinterfaces must be in different IP subnets this is sure.

So your configuration is not legitimate and you get a warning message


see if you can configure LACP on the system with the active option you need to define the LACP system id


Hope to help

Giuseppe




Giuseppe Larosa Tue, 12/30/2008 - 00:32
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Yee,

yes ASR allows this but you need the additional command that declares primary and secondary interfaces


interface Port-channel1.100


encapsulation dot1Q 100 primary GigabitEthernet1/1

secondary GigabitEthernet1/2


ip address 173.1.2.100 255.255.255.0


service-policy output subscriber


!


interface Port-channel1.200


encapsulation dot1Q 200 primary GigabitEthernet1/2


ip address 173.1.2.200 255.255.255.0


service-policy output subscriber


!


OR

even possible the example is wrong because the vlan id is 100 and 200.


In a normal router platform you cannot have lan (sub)interfaces with overlapping ip addresses.


to confirm this look this from the same doc:


ip address 173.1.2.300 255.255.255.0


have you ever seen an ipv4 address with 300 as fourth byte ?



Hope to help

Giuseppe


doraemonheng Tue, 12/30/2008 - 01:04
User Badges:

Hello Giuseppe,


Yes. Have tried the commands but it failed.

"% 173.1.2.0 overlaps with Port-channel1.100"


Yup. Did noticed the "300" also... : )



Thanks & Regards,


Giuseppe Larosa Tue, 12/30/2008 - 01:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Yee,

so the ASR behaves like a normal router and the example is wrong about IP addressing.


the different vlans should have different IP subnets.


Hope to help

Giuseppe


Actions

This Discussion