what is the use of no switch port command in L3 switch?

Unanswered Question
Dec 29th, 2008

what is the use of no switch port command in L3 switch?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Mon, 12/29/2008 - 06:01

It makes the port into a routed port and you can apply an IP address directly to the port.

Hope that helps.

glen.grant Mon, 12/29/2008 - 07:07

You use it as any routed port such as on a router. Instead of using a SVI and putting a port into that vlan you put the addressing info (gateway) directly on the port interface versus the SVI. You can then just connect to any other network device like a switch for layer 3 routing in that subnet.

hobbe Mon, 02/02/2009 - 09:05

This is for a 3750

interface GigabitEthernet1/0/1

description example router port1

no switchport

ip address 10.10.10.1 255.255.255.0

no ip redirects

interface GigabitEthernet1/0/2

description example router port 2

no switchport

ip address 10.10.11.1 255.255.255.0

no ip redirects

For default gateway you can use either

ip route 0.0.0.0 0.0.0.0 "ip of default gateway"

or

ip default-gateway "ip of default gateway"

do not forget to enable the ip routing in the switch.

stmaur_tech Sun, 12/02/2012 - 16:09

Hi

Could any one please advise the following :  I almost have same issues as above.

I have 2 router connected to a 3750. Router A is hooked up with Internet and Router B is also hooked up with Internet

Current all the Traffic is going to Router A, I have connected the Router B on the 3750 and configured as no switch port and given a IP.

I was woundering how can I determine or change some traffice to go to Router B as all are going to Router A.

Below is the configuration that I have :

ip   default-gateway 192.168.100.1
!
ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0   192.168.100.1
!
!
ip sla enable reaction-alerts
access-list 20 permit 0.0.0.0   255.255.255.0
access-list 40 permit 0.0.0.0   255.255.255.0
access-list 100 remark GUEST   NETWORK CONTROL

access-list 100 permit udp   172.20.20.0 0.0.0.255 host 192.168.171.1 eq domain

access-list 100 permit udp   172.20.20.0 0.0.0.255 host 192.168.171.30 eq domain

access-list 100 permit udp any   any eq bootps
access-list 100 permit udp any   any eq bootpc

access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.168.0   0.0.3.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.10.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.20.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.30.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.40.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.50.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.60.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.70.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 192.168.90.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 172.20.10.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 172.20.30.0   0.0.0.255 log
access-list 100 deny   ip 172.20.20.0 0.0.0.255 172.20.40.0   0.0.0.255 log
access-list 100 permit ip   172.20.20.0 0.0.0.255 any
access-list 100 remark
patrick.preuss Mon, 12/03/2012 - 05:19

Hi

it alll depends on you setup and the  feature sets.

When you have independent internet lines you can not simple loadbalance on the 3750.

You may whant to have a look into policy based routing wiht this you can assign protocols or hosts to a specific line.

HTH

Actions

This Discussion