CIFs cache on Core-7341 not working.

Unanswered Question
Dec 30th, 2008
User Badges:

I have a simple WAAS lab set up with a 7341 as the Core datacenter WAAS and an NM-WAE module in a 3845 as the remote WAAS. The two are connected via a dual-T1 multilink. I've attached a Visio showing the set up and WCCP config of the devices and routers.


On PC-A I login in to Server-A which is a Microsoft 2003 server. When I copy a file from the server to the PC, using the GUI for the NM-WAE, when I copy a file from the server to the PC, I see the CifsAO Cache increase by the size of the file. When I copy the same file again it is much faster proving the file was copied from the NW-WAE cache instead of the server.


But when I copy a file from the PC to the server, the CifsAO Cache on the 7341 stays at 0, but a second copy of the same file from the PC to the server is much faster, which I assume means it was delivered to the server from the 7341.


Shouldn't I see the 7341 CifsAO cache counter reflect the first copy from the PC to the server? Is DRE in play here for some reason instead of the CifsAO cache?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jkeeffe Tue, 12/30/2008 - 09:30
User Badges:

The WAAS version is 4.1.1c on all devices.

dstolt Mon, 01/05/2009 - 07:35
User Badges:
  • Cisco Employee,

Jim,


I would validate that you are indeed getting CIFS acceleration via the CLI or GUI in the connections listings. It's possible that it's only receiving Full Optimization (DRE/LZ/TFO). If you see it receiving the CIFS optimization, post the output of the connection and the statistics you are looking at in the forum so we can see if there is anything else that shows up.


Thanks,

Dan

jkeeffe Mon, 01/05/2009 - 07:49
User Badges:

I've attached a file that has a couple print screens of the 7341 showing nothing in the cache, even through the connections statistics shows that there is CIFS acceleration.


AMB-WAE-7341-A#sh statistics connection optimized cifs


D:DRE,L:LZ,T:TCP Optimization,

C:CIFS,E:EPM,G:GENERIC,H:HTTP,M:MAPI,N:NFS,V:VIDEO


ConnID Source IP:Port Dest IP:Port PeerID Accel

49696 164.72.54.25:3956 164.72.183.25:445 0:16:9d:38:f8:6f TCDL

49702 164.72.54.25:3962 164.72.183.27:445 0:16:9d:38:f8:6f TCDL

49704 164.72.54.25:3965 164.72.183.27:445 0:16:9d:38:f8:6f TCDL

49705 164.72.54.25:3968 164.72.183.107:445 0:16:9d:38:f8:6f TCDL

AMB-WAE-7341-A#




jkeeffe Mon, 01/05/2009 - 13:58
User Badges:

Possibly solved. I read in the WCCP-IOS-platform-support.pdf of the minimum IOS level required and realized I was not in compliance. The IOS on the 7206VXR router where WCCP redirects 61 and 62 to the 7341, was at 12.4.22. The document says it should be the 'T' train, so I upgraded to 12.4.(22)T and now it seems to be working.

I've attached a Word document with a print screen of the 7341 cache and now it shows there is CIFS caching going on, and not just TFP/LZ/DRE.


Does this sound like a plausible fix?



dstolt Wed, 01/07/2009 - 07:58
User Badges:
  • Cisco Employee,

Jim,


Glad to head that it's working now. I think it may have been something else that triggered the stats to start showing in the GUI, but finding it may require some digging in the logs/sysreport. Did you ever try the CLI to see if you were getting stats there?


Dan

jkeeffe Wed, 01/07/2009 - 08:14
User Badges:

Still not working unfortunately. The GUI states showed up for a short period of time and then stopped incrementing. I cleared the CIFs cache and now it is back to showing all zeros. However, at the CLI the 7341 does show CIFs optimization when I type "sh stats conn /opt"


So there is CIFs optimization, but something is keeping it from displaying properly in the GUI.


Can you think of anything else for me to check?

Actions

This Discussion