Moving from RIPv2 to OSPF?

Unanswered Question
Dec 30th, 2008

Hi,

I have set up a RIPv2 lab with 3 routers, and wondered how easy it would be to move over to OSPF? I'm notsure how long a task like this should take.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Tue, 12/30/2008 - 11:14

Hello Andy,

I would suggest you to use steps

1) make conversion without routing authentication

something like

router ospf 1

network 10.0.0.0 0.255.255.255 area 1

network 192.168.1.0 0.0.0.255 area 1

is enough do the same on all routers and verify if ospf neighbors are formed

using

sh ip ospf neighbors

sh ip ospf int

sh ip ospf int br

2) in a second moment you can play with multiple OSPF areas

you can also use redistribution of RIP into OSPF

3) you can add authentication features (MD5 authentication)

see

http://www.cisco.com/en/US/docs/ios/security/configuration/guide/sec_neigh_rtr_authen_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1000972

Hope to help

Giuseppe

whiteford Mon, 02/02/2009 - 12:59

Hi Giuseppe,

I have got OSPF work (still have RIP v2 on the routers), my next steps in my home labs to play around with the areas etc then either move onto EIGRP or NAT.

Not sure which order:

1.) Move from OSPF to EIGRP

2.) I will make router a and router b have the save LAN ranges, probably the loopback LAN's as I don't have any cat 5 cables at the moment just console cable then try and NAT between the offices using pools.

Does any of this sound possible with the equipment I have?

Thanks for your time.

richard.m.gilbert Tue, 12/30/2008 - 11:17

Hello,

Your migration to OSPF should be pretty easy by just putting the following in each router.

Router#config t

Router[config]#router ospf 1

Router[config-router]#network 192.168.100.0 0.0.0.255 area 0

Router[config-router]#network 10.10.10.0 0.0.0.255 area 0

Router[config-router]#exit

Router[config]#exit

Router#wr

Since RIP has an AD of 120, you can put OSPF in there now and it take over.

whiteford Wed, 12/31/2008 - 02:27

Hi,

That is useful to know about the admin distance, what is this area 0, as on some examples this can be 1 2 3 etc?

Once I have this done do you think I could easily migrate to EIGRP? This is just for me to understand really.

Many thanks again for your time!!

richard.m.gilbert Wed, 12/31/2008 - 07:44

OSPF allows you to run networks in different areas as long as you abide by certain rules. All areas must touch area 0, the backbone area. There are a couple of exceptions such as using virtual-link, but it is the biggest rule. The advantage to breaking OSPF into areas is making it very scalable which allows you to keep the routing tables smaller on each router ... which allows you to keep the processing stress minimal on your routers. YOu really can set it up anyway you want as long as you follow the rules ... and as Guiseppe pointed out, you can set it up in multiple areas.

If you are only doing this for lab and practice you should definitley tinker around with multiple areas before moving on to EIGRP. Set it up as all area 0 and then move sweet on to changing it to multiple areas and notice the changes in your network. Set up stub, not-so-stubby, and totally-stubby areas for practice.

You are right about EIGRP as well. If you advertise it, since it has a lower AD it should take over.

whiteford Mon, 02/02/2009 - 12:43

Hi,

You mention with OSPF all areas must "touch" area 0. The top example I don't see it touching area 0, sorry this is new to me.

example

router ospf 1

network 10.0.0.0 0.255.255.255 area 1

network 192.168.1.0 0.0.0.255 area 1

Thanks for your time

whiteford Mon, 02/02/2009 - 12:48

Your example worked! You said it's a good idea to mess around with areas, for my lab to work all 3 have to be in the same area?

Giuseppe Larosa Tue, 02/03/2009 - 05:39

Hello Andy,

an OSPF mono-area domain (using a single area) can use whatever area-id.

When you want to move to an OSPF multi areas domain as Richard has noted there are the following constraints:

- special area 0 backbone area has to be used

- all other areas need to be connected to area 0

- OSPF routers having some interfaces in area 0 and some interfaces in another area (one or more) act as ABR= Area Border Router.

With three routers you can play with OSPF areas before moving to another subject.

follow the suggestions of my first post.

I would suggest to use a topology like

R1 -- R2 -- R3

have links between routers in area 0

you can put loopbacks in non zero areas advertise them in OSPF

R1 will advertise in area 1 (or 0.0.0.1)

R3 will advertise in area 3 (or 0.0.0.3)

then examine the ospf database on R1, R2, R3 and see what happens to LSA type 3 when they go through the areas

Hope to help

Giuseppe

whiteford Tue, 02/03/2009 - 12:09

Hi,

What is LSA 3?

Is the outcome of your example mean all WAN serial interfaces are kept on one area and the loopback lANs are also all on different areas?

If so, does this mean all LAN's can still communicate with each other? I'm trying to work out why we are separating networks, is it to control route updates so not all the networks are flooded with updates?

Thanks again for spending the time to answer my questions.

Giuseppe Larosa Wed, 02/04/2009 - 05:54

Hello Andy,

LSA type 3 summary LSA are the data structures that carry OSPF inter - area routes.

My suggestion to work with multiple areas is to become confident with OSPF features in multi-area environment.

OSPF multi-area is required for scalability and so in the real world most implementations are multi area and so it is wise to practice this.

Area boundaries are points where you can control what is passed from one area to the others and what is accepted from area 0. (only exception are external routes).

And yes, if you want all emulated LANs can still communicate in an OSPF multiarea scenario.

I would suggest you some reading on this too.

Hope to help

Giuseppe

Actions

This Discussion