QOS for a Particular subnet in Router

Unanswered Question
Dec 31st, 2008

Hi

In our organization we have an MPLS from from centre A to Centre B. On this MPLS we need to dedicate 512kbps of bandwidth just for two IP's between centre A & B respectively. Moreover the MPLS is managed by the ISP's. All we do is provide static routes on the router pointing to the next hop.

I had planned to do the following PBR configuration on the routers :

access-list 1 permit 172.16.x.x

class-map match-all innovation

match access-group 1

!

!

policy-map innovation

class CUSTOMERX

bandwidth percent 20

interface Fa0/0

bandwidth 4000

service-policy output CUSTOMERX

However the service providers have asked me to do DSCP markings. I need help on the same.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 12/31/2008 - 04:47

Hello Solomon,

you need to mark traffic as enters the lan interface

access-list 11 permit 172.16.x.x

class-map match-all innovation1

match access-group 11

policy-map mark_dscp

class innovation1

set ip dscp

int f0/1

desc internal lan

service-policy input mark_dscp

traffic sent out f0/0 to provider will be marked if sourced from the subnet

the provider will use the DSCP settings to provide end-to-end QoS according to diffserv model

Hope to help

Giuseppe

daredevil24 Wed, 12/31/2008 - 05:10

Hi Giuseppe

Thanks a lot for the reply. i also have one more query. Do i have to do this configuration

on the interface between the router and the switch in the LAN. More specifically should i do the configuration ont the router?.

Also after i do thid configuration on the LAN, i need to do the configurations that i had previoulsy sent also right?

Giuseppe Larosa Wed, 12/31/2008 - 15:37

Hello Solomon,

yes on the internal LAN means where the traffic is received on the router.

the configuration has to be done on the router and you can use your configuration outbound on f0/0 the WAN interface.

Or you can use a different configuration like the one suggested by Joseph.

Another option is to define the class map based on the DSCP value on the outbound service policy, so that you can have your own counters of what traffic marked you are sending to the provider

Happy New Year

Hope to help

Giuseppe

Jon Marshall Wed, 12/31/2008 - 16:11

Giuseppe

Just wanted to say Happy New Year and hope you continue to stay in these forums in the coming year.

Your'e knowledge and experience have helped so many people.

Jon

Giuseppe Larosa Thu, 01/01/2009 - 01:58

Hello Jon,

Happy New Year to you too and to all people that make these forums useful and a plesant place.

My personal hope is that taking part in the forums help to stay tuned with new topics and to make easier to recertify.

I can say I've learned a lot about devices or concepts I haven't worked on directly.

Best Regards

Giuseppe

Joseph W. Doherty Wed, 12/31/2008 - 04:56

Your post appears to be CBWFQ, nor PBR?

If only just the two sites are attached to the MPLS cloud, i.e. you logically have a p-2-p link, you shouldn't need to set DSCP markings. Just an outbound service policy should work, although with yours, I believe the default FQ in (implicit) class-default would preclude your bandwidth guarantee (on most platforms). The latter, if an issue, can be adjusted by setting the class-default to use FIFO.

If you have multiple sites on the MPLS cloud, then beside using your policy as you've posted you will also need to set a ToS marking so that the MPLS provider can guarantee bandwidth at MPLS egress. In the latter IOS images, simply set dscp xx or set ip dscp xx in the policy map class. What marking to use will depend on what your MPLS provider offers.

e.g.

access-list 1 permit 172.16.x.x

class-map match-all innovation

match access-group 1

!

!

policy-map innovation

class CUSTOMERX

bandwidth percent 20

set ip dscp af31

interface Fa0/0

bandwidth 4000

service-policy output CUSTOMERX

[edit]

PS:

BTW: Since you have a Ethernet handoff, but only have(?) 4 Mbps MPLS bandwidth, it might be a very good idea to shape your outbound to 4 Mbps too. (Without using MPLS provider ToS markings, you'll need to shape. With ToS markings, you won't need to shape provided the provider won't drop any taffic in excess of 4 Mbps on MPLS ingress.)

daredevil24 Wed, 12/31/2008 - 05:19

Thanks Joseph,

So, will the above kind of marking huarantee that the two IP's at the two centre's would have 512kbps of bandwidth and not more than that?....

Joseph W. Doherty Wed, 12/31/2008 - 05:29

ToS markings for MPLS depend on the provider. Usually they offer various classes with a certain minimum percentages of bandwidth. Some allow you to select different profiles for bandwidth allocations per class. Provider should be able to provide documentation.

Actions

This Discussion