VTP Question

Unanswered Question
Jan 2nd, 2009

I have two Catalyst 2950 series. I just deleted the vlan.dat file and reloaded both of the switches. Now, when I try to configure the VTP domain on one of the switches in CLI, I am missing the "mode" option. I've enclosed a copy of the CLI from both switches.

Any ideas why this occurred? Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
glen.grant Fri, 01/02/2009 - 08:49

Looks like one has a really old code version on it and you may have to use the vlan database to configure . Check versions to see if the one is a really old version of IOS . Current versions are like 12.1.22a.ea12.

littlegiglow Fri, 01/02/2009 - 09:06

Yes, hostname Monnetteria has Version 12.1(9)EA1 and hostname switch has Version 12.1(6)EA2c. Thanks.

blueyesdude Fri, 01/02/2009 - 11:46

You could go into the vlan database mode from enable prompt and try it from there.

That should work.

Carlo Zaina Fri, 01/02/2009 - 13:04

I would suggest you to update both switches to the latest IOS version: this will make the things much easier!

Once in config mode, you will be able to configure the VTP Domain and the VTP mode as well.

for what concernes the vlan database configuration, it's being deprecated as you can see

C2950#vlan database

% Warning: It is recommended to configure VLAN from config mode, as VLAN database mode is being deprecated. Please consult user documentation for configuring VTP/VLAN in config mode.

glen.grant Fri, 01/02/2009 - 18:17

You will see the deprecated message on newer versions . Supposedly at some point cisco will drop the vlan database . Haven't used it in years anyway . Just set the switch as transparent and configure everything from the global command line . All your vlan info will show up in transparent mode in the running config. Those versions you are running are some of the oldest I have ever seen in that series .


This Discussion