Caller ID of out side callers does not appears?

Unanswered Question
Jan 4th, 2009

Dear support team,

I am using 1861 and running "c1861-spservicesk9-mz.124-20.T.bin" IOS over it.

But i am unable to receive caller ID of the out side callers on all the IP phones.

Please note that Caller ID is activated on my PSTN line connected to the FXO. I have verified it directly with a regular phone.

I have attached the configuration for your reference, please advice at your earliest.

Regards,

RAmeez

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (5 ratings)
Loading.
Rajesh Revuru Sun, 01/04/2009 - 06:25

Rameez:

See the following, probably you might have to change the "alerting" parameters under your voice port setting

**********

If you have caller-ID display problems on FXO ports, the following tips may be helpful:

•Disconnect the router from the phone line and attach a caller-ID equipped telephone to verify that the CO is sending caller-ID information:

-Listen and watch to see when the caller-ID information is displayed: before the first ring, after the first ring, or after the second ring?

-Make sure that the router configuration matches the timing of the display. If the phone is answered during the first ring, does this cause the phone not to display the caller-ID information? If so, the CO may be sending the caller-ID information after the first ring, requiring a change to a caller-ID alerting setting. Make sure the router is not configured to answer the call on the FXO before the Caller ID-information is received. If needed, increase the number of rings required before answering.

rameezk_1999 Sun, 01/04/2009 - 22:39

Dear Mr.Rajesh,

Thankyou for your response.

As you told, i checked the telephone line with Caller-ID telephone set, the ID information appears after the 1st ring.

I then changed the config on my Router's voice port to answer call after 2 seconds,3 seconds but still caller ID does'nt appear on IP phones.i used the "caller-id alerting ring 2" command for this purpose.

Please help so that i can fix this issue.

Regards,

Rameez

Nicholas Matthews Mon, 01/05/2009 - 00:14

You can try changing your cptone on your voice port to a different country, or back to default.

There are two different FSK formats, and it's possible that your provider is sending you a different one. That's kind of a long shot, though.

As mentioned, you can try changing the caller-id alerting to different rings to see if it changes the behavior.

Most of the the FXO cards have a 16,000 ft distance limitation on the FSK tones. Find out from your provider if your card is within that range.

You can also try this command:

caller-id alerting dsp-pre-allocate

hth,

nick

rameezk_1999 Tue, 01/06/2009 - 03:22

Hi nick,

Thanks for your response.

I tried as per your suggestion but still the same problem.

I have tried with different caller-id alerting rings but still it does'nt work.

Also, i have tried caller-id alerting dsp-pre-allocate but still the same.

The Cptone i am using is BE and it's working fine with our other clients.

Please find my voice-port configuration :

voice-port 0/1/0

supervisory disconnect dualtone mid-call

input gain 6

output attenuation 0

cptone BE

timeouts interdigit 2

timeouts call-disconnect 2

timeouts wait-release 2

connection plar 331

impedance complex2

caller-id alerting dsp-pre-allocate

Please help me out of this!!

Thanks & regards,

Rameez

Nicholas Matthews Tue, 01/06/2009 - 07:25

Hi Rameez,

I would try taking all of the attenuations, gains, impedances, timeouts, etc off. See if this will work with the very smallest configuration possible first, and then add commands as needed to see which could be breaking this.

hth,

nick

rameezk_1999 Wed, 01/07/2009 - 00:14

Dear Nick,

hey guess what i solved problem by my self...!!

and it was a very small thing!

i just upgraded the IOS to "c1861-spservicesk9-mz.124-11.XW9.bin" and it solved the caller-id problem.

so let's conclude that there is a caller-id bug in "c1861-spservicesk9-mz.124-11.XW6.bin" and "c1861-spservicesk9-mz.124-20.T.bin" IOS.

So if anyone has the same problem try to upgrade the IOS first!!

i really apprecaite your help guys.

Thanks for everything.

Regards,

Rameez

Actions

This Discussion