CME URL Services

Unanswered Question
Jan 4th, 2009

I have a question regarding the url services button in CME. It seems that even if I set "url services xxx". It doesn't change where the button points. Not matter what I do the XMLDefaults file always has serviceURL set to http://10.1.1.1:80/CMEserverForPhone/serviceurl. When I push the services button it then goes to something called CME Service Urls. The first item CME Service URL is set to whatever I set url services to under telephony-service. I'm wondering is there anyway to set it so that when I push the button it goes directly to the page I set? From what I can tell the only way I could do it would be to change the cnf file generation to flash then modify the file manually. However if I do that, wouldn't everytime I add a command which regens the cnf files, overwrite my changes?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Sun, 01/04/2009 - 10:55

Hi Daniel,


This functionality was changed in CME 4.2 with the addition of extension mobility. This is something that was required in order for extension mobility to work correctly.


So you have two choices, neither of which are very great to get around this:

1) Manually change the CNF files, and prevent them from automatically updating and rewriting themselves

2) Run CME 4.1 or earlier


What happens when the phone queries that URL is CME sends a XML document down with the URLs it should then query. So you get the same functionality, but there's a man in the middle.



hth,

nick

danielblock1 Mon, 01/05/2009 - 08:32

1. How do you prevent them from automatically updating and rewriting themselves?


2. I have another questions regarding the URL services. I would like to have a simple XML file that is located on the device (UC520) come up when I hit the services button. I have gotten that to work, however it keeps asking for a username and password. Is there anyway to to hardcode in the username and password on the url? I tried username:password@ and it did not work. Secondly, is there a way on the UC520 to turn off http authentication for a file or directory?

Nicholas Matthews Mon, 01/05/2009 - 08:52

1. I haven't done this before, but you would probably have to move the TFTP server to an external device off of the CME, and not give it write access. To add new devices you would write the files to CME, and then copy it over to your TFTP server. As far as I know, that's about the only way since CME dynamically rewrites the XML files on reboot, and a number of different configuration changes.


2. This one I'm not sure about. I think the only way to get around this is to remove ip http authentication for all files. The only place I would look is RADIUS based http authentication to see if it can do file/directory based, but I'm not very hopeful of that option.


hth,

nick

Actions

This Discussion