cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1080
Views
5
Helpful
5
Replies

Policy-Map / QoS

nelsonm
Level 1
Level 1

I have an issue at a remote site that when I run backups (on 1 server) that it brings the WAN to a grinding halt. I thought I would use QoS/Policy map to guarantee bandwidth for Citrix and printing but does not seem to be working. It appears that it's not interpreting the protocols citrix and printer. Just wanting a second pair eyes to see if maybe I'm missing something .

class-map match-all citrix

match protocol citrix

match protocol printer

!

!

policy-map Citrix-QoS

class citrix

priority percent 40

class class-default

fair-queue

!

interface Multilink1

description PPPML for FTR

ip address 172.16.*.* 255.255.255.252

ip nbar protocol-discovery

ip route-cache flow

no cdp enable

ppp multilink

ppp multilink group 1

service-policy output Citrix-QoS

!

interface FastEthernet0/0

no ip address

ip helper-address 10.1.1.104

ip nbar protocol-discovery

ip route-cache flow

speed auto

full-duplex

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.*.*.1 255.255.255.0

ip helper-address 10.1.1.104

ip nbar protocol-discovery

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 10.*.*.1 255.255.255.0

ip access-group 130 in

ip helper-address 10.1.1.104

ip nbar protocol-discovery

!

interface Serial0/0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial1/0

no ip address

encapsulation ppp

no fair-queue

no cdp enable

ppp multilink

ppp multilink group 1

!

router eigrp 333

network 10.0.0.0

network 172.16.0.0

no auto-summary

!

ip forward-protocol nd

ip flow-export source Multilink1

ip flow-export version 5

ip flow-export destination 10.1.1.124 9996

!

FTR-PTP-1760#sho policy-map interface

Multilink1

Service-policy output: Citrix-QoS

Class-map: citrix (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol citrix

Match: protocol printer

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 40 (%)

Bandwidth 1235 (kbps) Burst 30875 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

2764051 packets, 220776934 bytes

5 minute offered rate 99000 bps, drop rate 2000 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/152088/0

FTR-PTP-1760#

1 Accepted Solution

Accepted Solutions

Joseph W. Doherty
Hall of Fame
Hall of Fame

Instead of:

class-map match-all citrix

match protocol citrix

match protocol printer

Try:

class-map match-any citrix

match protocol citrix

match protocol printer

View solution in original post

5 Replies 5

Joseph W. Doherty
Hall of Fame
Hall of Fame

Instead of:

class-map match-all citrix

match protocol citrix

match protocol printer

Try:

class-map match-any citrix

match protocol citrix

match protocol printer

That fixed it! Awesome! Thank so much!

Is the NBAR making it possible to classify the protocols like this?

I didn't see it defined any where else:

match protocol citrix

match protocol printer

Richard

"Is the NBAR making it possible to classify the protocols like this"

Yes it is. The "match protocol" within a class-map is what triggers use of NBAR for classifying traffic.

Jon

Thanks Jon,

Are there guideline documents on how to use NBAR and QoS like this?

We have NBAR configured on our router interfaces, but it is not in use in QoS policies like this.

We have MARS monitoring the network, does it use NBAR?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: