VPN Client Won't Uninstall \ Install

Unanswered Question
Jan 5th, 2009

I have a new WinXP SP3 machine I am building and attempting to load the 4.6.00.0049 VPN client required by my office, but it hung up and stopped during the install (I killed the install after 1 hour stuck at 27% complete) and now it is in an endless cycle where I get a message like 'a previous version was detected, click OK and then the previous version will be removed'. I do so and reboot as instructed, but every time I try to re-install I get the same message. I have removed very trace of the Cisco stuff I can find in the registry, program files, etc. but still no go. Any ideas as to how to start fresh?

Best regards,

Dennis McMahon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Dennis,

Interesting situation, I can half help. Once you have removed the previous installation - install a program called CCleaner. This app is good for removing all traces of apps that have been uninstalled.

Once all trace removed - try installing again. If it fails again - try removing SP3 or install client version 4.8

HTH>

maddogs01 Tue, 01/06/2009 - 11:23

Thanks for the information Andrew. I have got it installed now successfully but with a few more twists. On your suggestion I downloaded and run CCClean.exe, fixing a lot of registry issues then tried to re-install the VPN client, but alas the same 'previous version detected \ reboot' looping still occurred. I had already did a search for anything in the registry like 'Cisco' and 'Deterministic Network Enhancer' and removed them.

What I did next was to find the CVPNDRA.sys and CVirtA.sys drivers in the C:\Windows\System\Drivers folder that I had run across references to in the registry, then deleted those for the first time. I next went to the services and stopped the Cisco VPN installer service that was running and to the registry and deleted the installer service from the ControlSets so it wouldn't start up again on reboot. After reboot, went back to registry to make sure things were gone, but somehow the HKLM\Software\Cisco Systems node was back so I deleted it. Next step to cross fingers and try re-installing the client - and Voila it worked! I did disconnect from any network and disable all firewalls and virus services first, which allowed it to get past hanging on the install of the deterministic network enhancer which started this mess.

I hope at some point this helps someone else.

Cheers,

Dennis McMahon

maddogs01 Tue, 01/06/2009 - 11:24

Thanks for the information Andrew. I have got it installed now successfully but with a few more twists. On your suggestion I downloaded and run CCClean.exe, fixing a lot of registry issues then tried to re-install the VPN client, but alas the same 'previous version detected \ reboot' looping still occurred. I had already did a search for anything in the registry like 'Cisco' and 'Deterministic Network Enhancer' and removed them.

What I did next was to find the CVPNDRA.sys and CVirtA.sys drivers in the C:\Windows\System\Drivers folder that I had run across references to in the registry, then deleted those for the first time. I next went to the services and stopped the Cisco VPN installer service that was running and to the registry and deleted the installer service from the ControlSets so it wouldn't start up again on reboot. After reboot, went back to registry to make sure things were gone, but somehow the HKLM\Software\Cisco Systems node was back so I deleted it. Next step to cross fingers and try re-installing the client - and Voila it worked! I did disconnect from any network and disable all firewalls and virus services first, which allowed it to get past hanging on the install of the deterministic network enhancer which started this mess.

I hope at some point this helps someone else.

Cheers,

Dennis McMahon

Actions

This Discussion