No BGP Peering between CE and PE

Answered Question
Jan 5th, 2009

Still in the process of modeling the MPLS network that we currently have with one of our Service Providers.

At this point I have placed the same config on the Lab CE's that exist in our production network. I have also followed Cisco Documentation to configure the PE routers, however I cannot get the CE to PE BGP peering.

What am I missing?

***********

*CE Router*

***********

nterface Loopback0

ip address 10.18.0.8 255.255.255.255

!

interface FastEthernet0/0

ip address 68.139.201.30 255.255.255.252

duplex half

!

interface FastEthernet1/0

no ip address

shutdown

duplex half

!

interface FastEthernet1/1

no ip address

shutdown

duplex half

!

interface FastEthernet2/0

no ip address

duplex full

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 68.139.201.29 remote-as 65000

***********

*PE Router*

***********

ip vrf vpn-mtb

rd 1:100

route-target export 1:100

route-target import 1:100

!

no ip domain lookup

mpls label protocol ldp

tag-switching tdp router-id Loopback0

!

!

!

!

interface Loopback0

ip address 68.2.0.1 255.255.255.252

!

interface FastEthernet0/0

ip address 68.2.1.2 255.255.255.252

duplex auto

speed auto

tag-switching ip

!

interface FastEthernet1/0

ip vrf forwarding vpn-mtb

ip address 68.139.201.29 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

router-id 68.2.0.1

log-adjacency-changes

network 68.0.0.0 0.255.255.255 area 0

!

router bgp 65000

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 68.2.0.3 remote-as 65000

neighbor 68.2.0.3 update-source Loopback0

no auto-summary

!

address-family vpnv4

neighbor 68.2.0.3 activate

neighbor 68.2.0.3 send-community extended

exit-address-family

!

address-family ipv4 vrf vpn-mtb

redistribute connected

neighbor 68.139.201.30 remote-as 1

neighbor 68.139.201.30 activate

neighbor 68.139.201.30 as-override

no auto-summary

no synchronization

exit-address-family

I have this problem too.
0 votes
Correct Answer by Harold Ritter about 8 years 1 week ago

Mark,

Re-entering the configuration obviously cleared the duplicate RID issue.

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Harold Ritter Mon, 01/05/2009 - 13:47

Mark,

The configs look good. Did you try pinging from the PE to the CE and vice versa.

Regards

mheick Mon, 01/05/2009 - 13:52

Harold,

No luck. When I do a show ip bgp summary, the address of the CE doesn't even show up as a potential neighbor. What am I not getting?

P.S. Thanks for all your help today.

Harold Ritter Mon, 01/05/2009 - 13:56

Mark,

On the PE side, You need to use "show ip bgp vpnv4 all summary" rather than the regular "show ip bgp summary". You should be able to use the "show ip bgp summary" to verify the connection on the CE side though.

You are very welcome.

Regards

mheick Mon, 01/05/2009 - 14:01

Here are the command outputs:

PE#show ip bgp vpnv4 all summary

BGP router identifier 68.2.0.1, local AS number 65000

BGP table version is 3, main routing table version 3

1 network entries using 137 bytes of memory

1 path entries using 64 bytes of memory

3/1 BGP path/bestpath attribute entries using 348 bytes of memory

1 BGP extended community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 573 total bytes of memory

BGP activity 3/0 prefixes, 3/0 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

68.2.0.3 4 65000 0 0 0 0 0 never Active

68.139.201.30 4 1 29 29 0 0 0 never Active

CE#show ip bgp summary

BGP router identifier 68.2.0.1, local AS number 1

BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

68.139.201.29 4 65000 4246 4246 0 0 0 never Active

mheick Mon, 01/05/2009 - 14:03

Harold,

I just re-entered the bgp configuration on the CE and the neighbor came up.

Thanks.

Correct Answer
Harold Ritter Mon, 01/05/2009 - 14:07

Mark,

Re-entering the configuration obviously cleared the duplicate RID issue.

Regards

Harold Ritter Mon, 01/05/2009 - 14:05

Mark,

The issue is that the router-id is the same on either side of the connection (68.2.0.1), hence the session not coming up. Change it on either side and it should fix the issue.

Regards

Actions

This Discussion