Connecting AP 1130ag to 2112 port

Unanswered Question
Jan 5th, 2009

I have been through the guides but cannot figure out this one.

I have an 1130ag AP (LWAPP) connected into port 7 (Poe) and trying to get it to associate with the WLC 2112. It never does. Do I need to configure that port to allow the APs to access the WLC through it? Maybe DHCP is not being passed to the AP so it is not getting an address to communicate over network?

When I connect the AP to my switch I have connected to port 1 (management port) of the 2112 it associates fine.

I am wondering if I am missing a step somewhere.... The quick start guide shows it easy as 1,2,3 but not for me....

Thanks,

Ed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Matthew Ratliff Tue, 01/06/2009 - 07:00

The reason this configuration isn't working for you is due to port 7 not being mapped properly. If you go to Controller - Interfaces - you will see that the management interface is mapped to port x. There probably isn't an interface assigned to port 7. You'll need to either use a switch connected up to the management interface or create the appropriate interface parameters for port 7. If you choose to create a new interface for port 7 you will have to come up with a new ip address subnet. It can't be the same as the management interface. Hope this helps!

Matthew Ratliff Tue, 01/06/2009 - 07:06

actually, after reading some guides on this you should be able to use the device as you are trying to. Make sure that POE is enabled on the port and verify that the LED turns green on the front side. If that doesn't work, try priming the AP on the dedicated management port first. Once the AP shows up in the controller and has downloaded the software, try moving it over to a POE port on the device.

Also, did you configure an ap-management interface during the initial setup? If not then one is required.

edvalasek Tue, 01/06/2009 - 07:31

Thanks for the reply!

I did try what you suggested on your first post with creating a new Management interface on port 7 and assigning an IP to it, but it kept telling me that the IP conflicted with another interface. From what I gather you cannot assign an IP in the same subnet to the other ports. With the project I am building everything is just your typical small office network with one subnet and VLAN.

I do have both required interfaces setup. The Managment Interface and the AP-Manager Interface. They each have their own IP assigned.

The AP I was using had already been registered with the WLC through a remote switch connected to Port 1 of the WLC and came up fine but as soon as I connect it to the 2112 on port 7 it just sits there and goes through the normal startup procedure over and over. I also does this connected to any other normal non-PoE port on the 2112 as well using power brick on the AP. The link lights are green and the AP is definitely powered up.

I went into the console and tried to watch for any LWAPP events with the debug option but nothing ever reports it as even trying.

Thanks for the reply though.... This is frustrating me because according to the docs I have found you should be able to just plug it in and it should work. I thought maybe the controller wasn't passing DHCP through the 2112 ports that are not assigned to anything so that might be why why the AP is not communicating but I cannot seem to find anything related to that. From my understanding the remaining ports should act as a switch.

Thanks again,

Ed

Matthew Ratliff Tue, 01/06/2009 - 11:05

Where is your DHCP server? Is it on the WLC or some other device/server?

If you have a dhcp server dedicated on another device make sure that the management port is connected to your network. Plug the AP into port 7. Does it grab an IP address?

Are you on a flat network?

Have you tried putting DHCP on the WLC? Try that as a test, but disconnect the management port from your network. Report back what you find.

edvalasek Tue, 01/06/2009 - 12:44

The DHCP Server is not the WLC. It resides on a normal Win2K3 box. Yes the Management Port (1) is physically connected into the network "core" switch which is a 3750.

When I plug the AP into the 3750 or any other IDF switch on the network is grabs an IP fine and works but when I plug it into port 7 it does not. The WLC is not configured to handle DHCP but I could certainly try that. I have a spare 2112 to test on.

It is a flat network so nothing major going on with routing across links or anything like that. It is a typical small office 20 user type site with 3 switches. The switching is all Layer 2 so no Layer 3 stuff going on through a core or anything like that....

Thanks,

Ed

Matthew Ratliff Tue, 01/06/2009 - 13:00

okay...

Connect the AP to your switch. Once associated to your controller, give it a static IP. Go to wireless - click on the listed AP - select the AP Static IP option - provide the ip/mask/gateway. Apply this. Allow the AP to reboot and re-associate to the controller. Now, unplug it from the switch and connect back to port 7 on your controller.

edvalasek Fri, 01/09/2009 - 12:22

Okay, I did exactly what you said and it does work now... In fact after I saw it associate with the Static address assigned, I went into the AP configuration on the 2112 and changed it back to DHCP and now it works with obtaining an IP with my DHCP server....

Thanks alot for your guidance on this... I still think something is not quite right with having to "prime" the AP to get it to work. That seems a little cheesey for a Cisco product given the Cisco reputation. Hopefully they can fix that if it is a known issue....

Thanks again,

Ed

Actions

This Discussion