CM 6.X - Caller ID displays 301 401 501 for international calls

Unanswered Question
Jan 6th, 2009

Hello,

We have Cisco 2851 Voice Gateways configured as MGCP connected to PSTN (ISDN Line). When we make international calls via PSTN the caller id displays 301, 401, or 501. We are running CallManager 6.X. Any help would be greatly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Tue, 01/06/2009 - 07:56

have you already configured calling number transformations???

or have you set the external phone mask to use it in the route pattern??

Or configured this at route list level or GW level???

HTH

java

if this helps, please rate

Chris Deren Tue, 01/06/2009 - 08:49

Is this only happening on international calls?

If so review your Route pattern configurations as well as route lists if different ones are used for LD vs Int.

HTH,

Chris

pwaehner1 Tue, 01/06/2009 - 09:28

Chris,

It is only happening on international calls but the LD/Local route lists are configured identical from what I can see. The phone company said I do not have E.164 enabled for the numbering plan. I do not see a option to enable though.

Chris Deren Tue, 01/06/2009 - 09:30

What about the route patterns? Are these PRIs? If so, what does debug isdn q931 show?

Chris

pwaehner1 Tue, 01/06/2009 - 10:13

Here is output from call to India from US.

000575: .Jan 6 18:08:24.651: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref

= 0x00D3

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98394

Exclusive, Channel 20

Calling Party Number i = 0x2081, '610*******'

Plan:Unknown, Type:National

Called Party Number i = 0xA1, '01191444*******'

Plan:ISDN, Type:National

000576: .Jan 6 18:08:24.979: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8 call

ref = 0x80D3

Channel ID i = 0xA98394

Exclusive, Channel 20

000577: .Jan 6 18:08:28.559: ISDN Se0/0/0:23 Q931: RX <- ALERTING pd = 8 callr

ef = 0x80D3

Progress Ind i = 0x8188 - In-band info or appropriate now available

000578: .Jan 6 18:08:30.839: ISDN Se0/0/0:23 Q931: RX <- CONNECT pd = 8 callre

f = 0x80D3

000579: .Jan 6 18:08:30.847: ISDN Se0/0/0:23 Q931: TX -> CONNECT_ACK pd = 8 ca

llref = 0x00D3

Rajesh Revuru Tue, 01/06/2009 - 12:13

Right now your international calls are being marked as Plan: National and Type:National. You can change this on your serial interface of your PRI with isdn map address

Look at the following

isdn map address 011* plan unknown type unknown

Chris Deren Tue, 01/06/2009 - 12:17

This is not going to work with MGCP gateway, you need to make the changes on gateway configuration on CallManager rather than the gateway.

HTH,

Chris

Actions

This Discussion