Unable to discover chassis (C6509) in Device Discovery

Unanswered Question
Jan 6th, 2009

Hi Experts,

SNMP strings and parameters configured have been verified to be correct.

IP Access list has already permit the device to send and receive trap from LMS Server.

I am now suspecting the DCR is not able to receive OID of the chassis as CSDiscovery.log (posted in the text file attached) in debugging modeshows that the sys OID is null when the process is called.

However, I am able to poll the sys OID using a MIB Browser running on LMS Server. So what could the reason that DCR is not able to get the sys object ID?


Yi Shyuan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Tue, 01/06/2009 - 08:54

The device is unreachable. If this device is already in DCR, then the SNMP credentials in DCR for this device are wrong. If the device is not in DCR, then you have not specified the correct SNMP credentials in the CS Discovery SNMP Settings interface.

If you start a sniffer trace filtering on UDP port 161 traffic to this switch, then run a Discovery, you should see Discovery polling the switch with the incorrect SNMP credentials.

jeeyishyuan Tue, 01/06/2009 - 19:46

Since only one SNMP RO community string is configured for all devices, the probability to have incorrect SNMP credential is very low. A screen shot of snmp setting is posted here.

Currently, the device is unreachable. Can unreachable status be considered as device not in DCR? Under what circumstance, a device is considered as unreachable?

Joe Clarke Tue, 01/06/2009 - 20:48

Unreachable means the SNMP credentials for the device are wrong. This screenshot means nothing for a device already in DCR. Once a device is in DCR, Discovery will use the credentials configured for that device under Common Services > Device and Credentials > Device Management. Try reentering the switch's credentials there, and see if Discovery works.


This Discussion