T1 to Chanelized DS3 EIGRP Flapping route

Answered Question
Jan 6th, 2009

I have a 3725 with a T1 connection that terminates into a channelized DS3 on a 7200.

The 3725 sends and recieves the multicast EIGRP messages with no encap failures (verified with debug IP packet that it is sending, and the addition of the 7200 into the EIGRP neighbor table for recieving).

On the 7200, I verified it is sending the multicast hello's with no encap failures, but it is not acknowledging the multicast packet from the 3725 (possibly not recieving it at all).

There are other T1's on the channelized DS3 that are working properly and are sending and recieving the multicast hellos.

There are no errors on the serial interfaces.

There are no errors when viewing "show controllers"

3725 Config

router eigrp 64

passive-interface FastEthernet0/1.201

passive-interface FastEthernet0/1.213

network 10.0.0.0

auto-summary

controller T1 0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

interface Serial0/0:0

ip address 10.249.16.2 255.255.255.252

ip nat outside

IP-EIGRP neighbors for process 64

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.249.16.1 Se0/0:0 13 00:00:53 1 5000 24 0

1 10.170.2.2 Se0/1:0 14 1w3d 5 200 0 11137

2 10.4.37.254 Fa0/1.4 13 8w0d 1 200 0 120875

.Jan 6 14:02:12 CST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 64: Neighbor 10.249.16.1 (S

erial0/0:0) is down: retry limit exceeded

.Jan 6 14:02:15 CST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 64: Neighbor 10.249.16.1 (S

erial0/0:0) is up: new adjacency

.Jan 6 14:03:35 CST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 64: Neighbor 10.249.16.1 (S

erial0/0:0) is down: retry limit exceeded

.Jan 6 14:03:38 CST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 64: Neighbor 10.249.16.1 (S

erial0/0:0) is up: new adjacency

7200 Config

router eigrp 64

network 10.0.0.0

no auto-summary

controller T3 2/1

t1 1 channel-group 0 timeslots 1-24

t1 2 channel-group 0 timeslots 1-24

t1 3 channel-group 0 timeslots 1-24

t1 4 channel-group 0 timeslots 1-24

t1 5 channel-group 0 timeslots 1-24

t1 6 channel-group 0 timeslots 1-24

t1 7 channel-group 0 timeslots 1-24

t1 8 channel-group 0 timeslots 1-24

t1 9 channel-group 0 timeslots 1-24

t1 10 channel-group 0 timeslots 1-24

t1 11 channel-group 0 timeslots 1-24

t1 12 channel-group 0 timeslots 1-24

t1 13 channel-group 0 timeslots 1-24

t1 14 channel-group 0 timeslots 1-24

t1 15 channel-group 0 timeslots 1-24

t1 16 channel-group 0 timeslots 1-24

t1 17 channel-group 0 timeslots 1-24

t1 18 channel-group 0 timeslots 1-24

t1 19 channel-group 0 timeslots 1-24

t1 20 channel-group 0 timeslots 1-24

t1 21 channel-group 0 timeslots 1-24

t1 22 channel-group 0 timeslots 1-24

t1 23 channel-group 0 timeslots 1-24

t1 24 channel-group 0 timeslots 1-24

t1 25 channel-group 0 timeslots 1-24

t1 26 channel-group 0 timeslots 1-24

t1 27 channel-group 0 timeslots 1-24

t1 28 channel-group 0 timeslots 1-24

interface Serial2/1/9:0

description ######################################

ip address 10.249.16.1 255.255.255.252

ip route-cache flow

service-policy output Voip-T1

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 11 months ago

Hello,

you probably should rewrite the acl 103 to deny eigrp packets

access-list 103 deny eigrp any any

access-list 103 permit ip any any

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Richard Burts Tue, 01/06/2009 - 11:57

Craig

There are a couple of things I notice for which I would like some additional details. On the 3725 the serial interface has nat outside. Can you provide that details of how NAT is configured on the router? And on the 7200 there is a service-policy configured. Can you provide details of the service policy?

HTH

Rick

xcz504d1114 Tue, 01/06/2009 - 12:19

Rick,

Thanks for the reply.

In regards to the NAT on the 3725, it is used Untrusted Guest Wireless use at that location, I'm not fond of the implementation they used for it.

ip nat inside source list 103 interface Serial0/0:0 overload

access-list 103 permit ip any any

interface FastEthernet0/1.99

encapsulation dot1Q 99

ip address x.x.x.1 255.255.255.0

ip nat inside

no ip route-cache

As for the 7200 service policy, it's for VoIP QA

policy-map Voip-T1

class VoIP-RTP-UnTrust

set dscp ef

priority percent 35

class VoIP-Control-UnTrust

bandwidth percent 5

set dscp af31

class BEST-EFFORT-DATA

set dscp default

class class-default

fair-queue

Richard Burts Tue, 01/06/2009 - 12:51

Craig

I do not see any obvious problem, but agree with you that I do not like the way that the NAT was done. Would it be possible to (temporarily) remote the nat outside from the serial interface and see if the behavior changes?

Have you tried a shut/no shut on the serial interface?

Could you also post the output of show interface from both routers?

HTH

Rick

xcz504d1114 Tue, 01/06/2009 - 13:17

From the 3725 (T1 Side)

Serial0/0:0 is up, line protocol is up

Hardware is GT96K Serial

Internet address is 10.249.16.2/30

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:09, output hang never

Last clearing of "show interface" counters 2w0d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 733

Queueing strategy: weighted fair

Output queue: 0/1000/64/733 (size/max total/threshold/drops)

Conversations 0/89/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1152 kilobits/sec

5 minute input rate 5000 bits/sec, 2 packets/sec

5 minute output rate 3000 bits/sec, 3 packets/sec

25699390 packets input, 4082553795 bytes, 0 no buffer

Received 150735 broadcasts, 0 runts, 0 giants, 0 throttles

229 input errors, 229 CRC, 80 frame, 36 overrun, 0 ignored, 122 abort

26691539 packets output, 3717628125 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

Timeslot(s) Used:1-24, SCC: 0, Transmitter delay is 0 flags

Here is the output of the Show Controller T1 as well

T1 0/0 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20040408, FPGA: 11

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (601 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

xcz504d1114 Tue, 01/06/2009 - 13:17

From the 7200 (Channelized DS3)

Serial2/1/9:0 is up, line protocol is up

Hardware is PA-MC-2T3+

Description: ###################

Internet address is 10.249.16.1/30

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, crc 16, loopback not set

Keepalive set (10 sec)

Last input 00:00:03, output 00:00:00, output hang never

Last clearing of "show interface" counters 2w0d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 96828

Queueing strategy: Class-based queueing

Output queue: 0/1000/64/96828 (size/max total/threshold/drops)

Conversations 0/146/256 (active/max active/max total)

Reserved Conversations 1/1 (allocated/max allocated)

Available Bandwidth 539 kilobits/sec

5 minute input rate 2000 bits/sec, 3 packets/sec

5 minute output rate 6000 bits/sec, 3 packets/sec

26691535 packets input, 3717629016 bytes, 0 no buffer

Received 150729 broadcasts, 0 runts, 0 giants, 0 throttles

97 input errors, 11 CRC, 36 frame, 0 overrun, 0 ignored, 50 abort

25699429 packets output, 4082567219 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions no alarm present

Timeslot(s) Used: 1-24, subrate: 1536Kb/s, transmit delay is 0 flags

non-inverted data

And show controller T3

T1 9 is up

timeslots: 1-24

FDL per AT&T 54016 spec.

No alarms detected.

Framing is ESF, Clock Source is Internal

Data in current interval (83 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs

0 Unavail Secs, 0 Stuffed Secs

Total Data (last 24 hours)

0 Line Code Violations,0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs

Richard Burts Tue, 01/06/2009 - 13:24

Craig

Thanks for the output, but I am afraid it does not show any problem. Does the 7200 see the 3725 as a neighbor? What is in the output of show ip eig int Serial2/1/9:0?

HTH

Rick

xcz504d1114 Tue, 01/06/2009 - 13:21

Good call on the NAT, sure enough as soon as I dropped it fromt he interface I saw the neighbor relationship come up on the DS3 side. Now I have to sit here for a minute and contemplate why :)

Thanks for the help Rick!

Correct Answer
Giuseppe Larosa Tue, 01/06/2009 - 13:25

Hello,

you probably should rewrite the acl 103 to deny eigrp packets

access-list 103 deny eigrp any any

access-list 103 permit ip any any

Hope to help

Giuseppe

Richard Burts Tue, 01/06/2009 - 13:28

Craig

I am glad that you found the issue was related to the NAT. I am not sure exactly what the issue is, but I have seen some strange stuff with NAT when it tries to use an extended access list with permit any any. I would suggest re-writing it to use a standard access list and in the standard access list specify the address range of the interface where the clients are.

HTH

Rick

xcz504d1114 Tue, 01/06/2009 - 14:10

Yeah, I re-wrote the access-list, it was definately the any any statement, I ended up using the extended ACL and just denying the EIGRP from being translated.

Thanks for all of your help Rick and Giuseppe,

Craig

Actions

This Discussion