trunking with Extreme switches

Answered Question
Jan 6th, 2009

Hi.

Several of our remote offices purchased some Extreme Summit X150 switches to replace a bunch of old unmanaged switches so we could get more insight and control on the network. In order to prep for that, I'm playing with a Summit X250 that I borrowed from a vendor. The problem is I can't get trunking to work between the X250 and the C2950 I've got it connected to. The two switches can see each other's mac addresses, so I know they're communicating, I just can't pass traffic over the trunk. Here's what I have:

Crossover cable between Summit X250 port 25 and Cisco 2950 port 3:

Summit X250 Side:

create vlan "MGT"

configure vlan MGT tag 1

configure vlan MGT add ports 25-26 tagged

configure vlan MGT ipaddress 192.168.200.6 255.255.255.128

enable ipforwarding vlan MGT

configure ports 25 auto off speed 100 duplex full

Cisco 2950 Side:

(ip address 192.168.200.42)

interface FastEthernet0/3

switchport mode trunk

switchport nonegotiate

no ip address

duplex full

speed 100

switchport trunk allowed vlan all

Everything I've been able to find on the subject says that this should work, yet I can't ping between the two. Any suggestions would be appreciated.

Correct Answer by Roberto Salazar about 8 years 1 month ago

Assuming that the 2950 and the Extreme switches ip addresses are in the same subnet (/25 mask). My suspicion is that the issue is native vlan mismatch. Native vlan in cisco is NOT taggged with vlanID, so it comes out raw and it expects untagged packets to be in vlan 1. Your extreme has "configure vlan MGT tag 1" I suspect this is tagging the vlan 1 traffic with Dot1Q vlan ID. In order not to complicate things explaining native vlan concept, I suggested the following on 2950:

"switchport trunk native vlan 999" under the interface your trunking to the Extreme. Vlan 999 is just a dummy vlan to change the Native vlan on 2950. Try that and tyr to ping between them, I am sure that will work.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.1 (5 ratings)
Loading.
Yudong Wu Tue, 01/06/2009 - 13:56

What's the output of "show interface trunk" on Cisco switch?

By default Cisco switch will allow vlan 1-4094 on the trunk port. But in your Extreme switch configuration, I can only see vlan 1 is added to trunk port 25.

jlmickens Tue, 01/06/2009 - 13:59

#sh int trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Fa0/3 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Fa0/3 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1,10,20,25,52,111,160,169,601,777

Fa0/3 1,10,20,25,52,111,160,169,601,777

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1,10,20,25,52,111,160,169,601,777

Fa0/3 1,10,20,25,52,111,160,169,601,777

Yudong Wu Tue, 01/06/2009 - 14:28

I did not see anything wrong on Cisco side.

Can you take a look at "show log" to see if there is a useful info regarding to this trunk port?

Basically, you need make the following items the same on both sides.

1. trunk protocol - 802.1q, this one should be OK.

2. active vlan - Cisco permit vlan 1,10,20,25,52,111,160,169,601,777 , but Extreme only permit vlan 1 based on your config.

3. native vlan - Cisco use vlan 1 and by default Cisco does not tag native vlan.

You can check Extreme side to make sure the above to match on cisco side.

jlmickens Tue, 01/06/2009 - 16:06

Vlan 1 is the only one I'm really concerned with right now - that's the vlan the management IPs run on. If vlan 1 will work, any others should as well. Can tagging of vlan 1 be turned on for the Cisco side? I'll also try adding one of the others to the Extreme side when I get back in the office tomorrow - right now I only have console access to the Extreme switch.

Yudong Wu Tue, 01/06/2009 - 21:21

I check 2950 switch config guide and did not find any command to turn on tag on native vlan. As far as I know, on some other Cisco switch, we can turn on native vlan tag.

Why don't you just turn off tag on Extreme side by the following:

create vlan NVLAN

conf NVLAN tag 1 <<< NVLAN number is 1

conf NVLAN add port 25 untagged <<

jlmickens Wed, 01/07/2009 - 05:49

Then the port wouldn't be a trunk - it would just be assigned to that vlan. Ultimatly I will need to pass 4 vlans through. Right now I'm just trying to get the one to work.

Yudong Wu Wed, 01/07/2009 - 07:43

Glad that you have problem resolved.

I guess that you changed the native vlan on Cisco side other than vlan 1 so that vlan 1 can be tagged. But this could bring a possible spanning tree loop in certain condition since native vlan is mismatched here.

I am not sure if you can try my previous soltion where vlan 1 is added as untagged on Extreme side. Then you can add the rest of vlan as tagged so that the port will become a trunk.

Correct Answer
Roberto Salazar Tue, 01/06/2009 - 16:32

Assuming that the 2950 and the Extreme switches ip addresses are in the same subnet (/25 mask). My suspicion is that the issue is native vlan mismatch. Native vlan in cisco is NOT taggged with vlanID, so it comes out raw and it expects untagged packets to be in vlan 1. Your extreme has "configure vlan MGT tag 1" I suspect this is tagging the vlan 1 traffic with Dot1Q vlan ID. In order not to complicate things explaining native vlan concept, I suggested the following on 2950:

"switchport trunk native vlan 999" under the interface your trunking to the Extreme. Vlan 999 is just a dummy vlan to change the Native vlan on 2950. Try that and tyr to ping between them, I am sure that will work.

joelgooding Wed, 05/08/2013 - 12:26

Same problem.

Roberto Salazar's input solved the issue. I also had to place voice vlan as untagged on the ports for the IP phones to work. Please mark this as answered.

Joel

Actions

This Discussion