Etherchannel and Host Flapping Issue

Unanswered Question
Jan 7th, 2009
User Badges:

I've just recently configured etherchannel and have noticed in my logs a lot of host flapping. Can you tell me why it's flapping and how to resolve it?

Attached is the "show log" and configuration on the switch. Any assistance would be greatly appreiciated.

Thanks.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mahmoodmkl Wed, 01/07/2009 - 04:15
User Badges:
  • Gold, 750 points or more

Hi


Verify that u have identical port config on both the switches.


How frequently u r getting the host flapping messgs.At the first time when u configure ether-channel there is temporary STP loop created.


Thanks

Mahmood

Giuseppe Larosa Wed, 01/07/2009 - 04:19
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello David,

the switch complains of MAC addresses that appear on two different port channels


or between Po1 and Po3 or between Po2 and Po4


%C4K_EBM-4-HOSTFLAPPING: Host 02:A0:98:08:8A:82 in vlan 8 is flapping between port Po2 and port Po4

Jan 6 10:36:43: %C4K_EBM-4-HOSTFLAPPING: Host 02:A0:98:08:8A:88 in vlan 8 is flapping between port Po3 and port Po1

Jan 6 10:55:45: %C4K_EBM-4-HOSTFLAPPING: Host 02:A0:98:08:8A:82 in vlan 8 is flapping between port Po2 and port Po4


the question is what is connected on Po1 to Po4 ?




po1 ports description provides

ESOCO26NTAP100

g5/17, g5/19,


po2 ports have description


10.20.33.212 (LACP)


po3 ports have description

description 10.20.33.211 (LACP)


po4 ports have description


description 10.20.33.212 (LACP)


I suppose that theres a multi NIC server out each pair of Port-channels and that device thinks it can use both port-channels (active/active) it will do so and the switch will complain of the problem.


So or you put all the ports inside a single port-channel or the server will change to an active/standby usage of the two bundles


Hope to help

Giuseppe


davidhuynh5 Wed, 01/07/2009 - 10:54
User Badges:

Thanks giuslar. That fixed the problem.

One last question:

If we have a server that has two nics with a single (192.168.0.1) running LACP.

NIC#1 is connected to switch1. NIC#2 is connected to switch2. How would I configure the etherchannel on the switches and how will the two switches interpet this connection?

Giuseppe Larosa Wed, 01/07/2009 - 11:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello David,

if the links go to different switches you cannot create the etherchannel on the server side and you need use some different form of teaming and you cannot create it on the switch side.

You should configure the server for active/standby.


Hope to help

Giuseppe


Actions

This Discussion