re-ip a switch

Answered Question
Jan 7th, 2009

Have a quick quesiton for you, I have a switch that I would like to change the IP address on, when I changed it even though I can ping it from other routers on tne network I cannot log into it and I see that my tac server cannot get to it as well. I went from vlan90 to the new one vlan192. Vlan 192 isn't working am I missing something?

Attachment: 
Correct Answer by glen.grant about 8 years 1 month ago

Maybe you could try clearing the crypto keys and see whats happens.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mikegrous Wed, 01/07/2009 - 10:10

aaa authentication login default group tacacs+ local

States use TACAS if TACAS is unavailable use local database. Local database would be:

username cisco password cisco

when you telnet to the switch do you get a username password prompt?

wgranada1 Wed, 01/07/2009 - 10:27

That is the think although I can ping from any router or my destop when I try to telnet

into it I cannot get a sign on screen just times out. So that is what is confusing

Correct Answer
glen.grant Wed, 01/07/2009 - 11:27

Maybe you could try clearing the crypto keys and see whats happens.

wgranada1 Wed, 01/07/2009 - 13:53

Grant wow that worked!!!! well actually I was going to do it but never got around to do it then all of a sudden I was able to log in so I guess the old crypto keys timed out or something? By the way how do you clear the crypto key...is it just a simple clear crypto key?

glen.grant Wed, 01/07/2009 - 15:59

Think it is crypto key zeroize rsa" or something close to that , then you have to recreate the keys in config mode with "crypto key gen my rsa and whatever key size you normally use .

wgranada1 Thu, 01/08/2009 - 06:51

Just an update on this, it wasn't the crypto key. I moved another switch to the same subnet as the first one and had the same issue. I cleared the crypto key but still wasn't able to log in. I went to my tac server and wasn't able to ping the switch on the new IP address. So I cleared the arp cache on the switch and then I was able to log in. I went back to my tac server and tried to ping the new ip address and this time it worked. I moved another switched and cleared the arp cache and had no issues so it was the clearing of the arp cache that did the trick......But thank you everyone for helping out I appreciate it!!!!!!

Actions

This Discussion