RME System Collection/Polling scheduled jobs

Answered Question
Jan 7th, 2009
User Badges:

How do I delete/disable System Collection/Polling Schedule jobs?

Correct Answer by Joe Clarke about 8 years 3 months ago

Replace NMSROOT with the path into which CiscoWorks was installed. Run this command from a DOS shell as a local Administrator.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 01/07/2009 - 10:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Inventory or Config?

kathegaj2 Wed, 01/07/2009 - 10:41
User Badges:

Inventory...seems there wasn't one there. I added one and it told me ICSU0039: Successfully updated System Job Settings notification. I read a little further (!) and decided the size of my network would be better off collecting and polling inventory in smaller increments but couldn't find a way to back the job out or delete it.

Joe Clarke Wed, 01/07/2009 - 10:55
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Inventory collection and polling are always run. They cannot be disabled. You can configure collection to run in the distant future, however. Typically, we recommend inventory polling runs daily, and collection runs weekly. The overhead is typically minimal as this is just SNMP polling of containment information.

kathegaj2 Wed, 01/07/2009 - 11:10
User Badges:

I cannot find evidence that they have ever run! Under Job Management>RME Jobs...no collection results. When I "updated" the default, there wasn't any information in the schedule fields, I added the day and time and my email(it didn't take what I submitted either...made 00:45:00 to 00:17:03)

Joe Clarke Wed, 01/07/2009 - 11:32
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Have you reinitialized your cmf database?

kathegaj2 Wed, 01/07/2009 - 11:48
User Badges:

No, I don't know what this is...


BTW I am in a LMS class right now and you are famous! So happy to meet you!

Joe Clarke Wed, 01/07/2009 - 12:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This could be a jrm problem, then. What version of LMS is this? Please post the output of the pdshow command as well as the ICServerUI.log.

Jason Fraioli Wed, 01/07/2009 - 12:26
User Badges:

What LMS class are taking? I'd appreciate recommendations for training.

kathegaj2 Wed, 01/07/2009 - 13:11
User Badges:

Global Knowledge: Implementing CiscoWorks LMS! Awesome class! Mike Fiedler is a rockstar of educators, passionate and knowledgeable, nothing close to Joe but highly recommended =-)

kathegaj2 Wed, 01/07/2009 - 13:03
User Badges:

Sorry it took so long, communication to server is slow over VZ connection through VPN...




Joe Clarke Wed, 01/07/2009 - 13:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I need to see the ICServerUI.log as well.

Joe Clarke Wed, 01/07/2009 - 23:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I must not have scrolled down far enough. However, the attachment appears to have gotten lost in the forum. Can you repost it?

kathegaj2 Thu, 01/08/2009 - 09:46
User Badges:

Here it is again...

Do you think this may have anything to do with why my Netconfig jobs "Failed" in this manner:

Deploy succeeded, Synchronization of RME archive with Device Config failed




Attachment: 
Joe Clarke Thu, 01/08/2009 - 11:23
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of RME is this?

Joe Clarke Thu, 01/08/2009 - 12:09
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The line numbers in your stacktraces do not line up with the RME 4.1.1 code. Since the jobs are not showing up, it may require you to re-register the system RME jobs. IF you're run Windows, run:


NMSROOT\bin\perl -I NMSROOT\objects\perl5\lib NMSROOT\dbupdate\dbupdate.pl NMSROOT\rigel\scripts\rme\createJobs.txt


If on Solaris, run:


/opt/CSCOpx/bin/perl /opt/CSCOpx/dbupdate/dbupdate.pl /opt/CSCOpx/rigel/scripts/rme/createJobs.txt


Then restart Daemon Manager, and see if your inventory jobs show up.

kathegaj2 Thu, 01/08/2009 - 12:46
User Badges:

Sorry Joe, I don't understand how to run this script on this server.

NMSROOT\bin\perl -I NMSROOT\objects\perl5\lib NMSROOT\dbupdate\dbupdate.pl NMSROOT\rigel\scripts\rme\createJobs.txt


Correct Answer
Joe Clarke Thu, 01/08/2009 - 12:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Replace NMSROOT with the path into which CiscoWorks was installed. Run this command from a DOS shell as a local Administrator.

kathegaj2 Thu, 01/08/2009 - 13:37
User Badges:

yeaaaa I tried that and it won't recognize the file or directory...


Joe Clarke Thu, 01/08/2009 - 14:07
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post a screenshot of what you're executing, and the error you receive.

kathegaj2 Mon, 01/12/2009 - 10:54
User Badges:



D:\Program Files\CSCOpx\bin>perl -I\PROGRA~1\CSCOpx\objects\perl5\lib\PROGRA~1\C

SCOpx\dbupdate\dbupdate.pl\PROGRA~1\CSCOpx\rigel\scripts\rme\createJobs.txt


This gyration worked but nothing happened.

(don't know if terminal monitoring is on so...)

I restarted daemon manager just in case... I think this did the trick. Will let you know...

Actions

This Discussion