Endpoint showing unknown for registration status

Unanswered Question
Jan 8th, 2009

Hi,

I'm using CUCM 6 and have setup a test voice gateway. I am using MGCP to control the gateway. The call manager reports the E1 endpoint registration status as unknown yet I can make calls out via the E1 PRI.

Here is a shown ISDN status

test-mgcp-rtr#show isdn status

Global ISDN Switchtype = primary-net5

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not appl

y

ISDN Serial0/0/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0xFFFF7FFF

Number of L2 Discards = 0, L2 Session ID = 3

Total Allocated ISDN CCBs = 0

The MGCP config is

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server x.x.x.x

ccm-manager config

!

mgcp

mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

Can anyone hep me understand why the status shows as unknown?

Help rated.

Regards

Gavin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Nicholas Matthews Thu, 01/08/2009 - 06:49

You may need to restart the Realtime Information Service (RIS) to clear up the discrepancy, and sometimes restarting the TFTP service helps as the TFTP service the gateway is using to auto-configure has gotten stuck and cannot complete.

You may want to check this against:

show ccm

show mgcp endpoint

hth,

nick

gavin.mckee Thu, 01/08/2009 - 07:06

Thanks Nick, I deleted the voice gateway and added it again, this seemed to resolve the issue.

Tim Smith Wed, 09/02/2009 - 05:49

Having the same issue here.

I already tried restarting RIS as this had caught me before. Also, if I do a ccm switch back to the backup server it shows as registered in CCM admin.

Tried TFTP after seeing this, but it didnt help.

When I switch back again it goes back to unknown.

Was there a bug id for this behaviour in 6.1(3)?

Calls still seem to be fine though.

Cheers,

Tim.

Actions

This Discussion