7937 Conference phone is forcing G.722

Unanswered Question
Jan 8th, 2009

We are running CCM 5.1.3. I have a TAC case open on this, and I have a work around, but I wanted to see if anyone else was having this problem.

We are not using G.722 in our network, even though we have the phones to support it, because it is not supported by our call recording application or our voice gateways (running MGCP). Therefore, I set the "Advertise G.722" option within Enterprise Parameters to false. However, the 7937 conference phones do not seem to get the message. Internal calls work and use G.711, but calls through the gateway fail. The ISDN q931 messages indicate a failure during call setup with an error of "cannot open channel". At first I thought it was an ISDN issue, but I checked the call status records on the 7937 and it indicates that it is trying to use G.722. Our gateway does not support G.722; It is not configured to and Cisco says that it is not supported on MGCP gateway (yet, I hope).

The SW version on the phone is 1.3(2) and the app load is apps37sccp.1-3-2-0.

Has anyone seen this? I have a workaround in place; I put these phones into a seperate region and required G.729 between this region and all others, which forces the phone to use G.729 (and no, forcing G.711 did not work; CCM assumes that better codecs at the same bandwidth, which g.722 is, can be subsituted for 711).

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dsweeny Sun, 01/18/2009 - 09:36

Send the output of the following from the gateway:

- debug isdn q931

- debug voip ccapi inout

Nicholas Matthews Sun, 01/18/2009 - 10:10

Actually you'd want to see the mgcp packets to see the codec negotiation, so add

debug mgcp packet

taylorscot Mon, 02/09/2009 - 10:53

I have the same issue with the 7937 phone forcing g722 and have also have a tac case open.

Did you ever have a resolution to this issue? I'll post back here if I get a satisfactory answer myself.

taylorscot Mon, 04/13/2009 - 12:11

Apparently the issue was on our Voice Gateway (which is H323). Cisco suggested the following:

"Add 'incoming called-number .' to one of the voip dial peers on the gateway...dial-peer voice 20 or 30 voip...."

"dial-peer 0 was trying to setup using g722"

Both of our 7937s, each on a separate VG started working fine after that addition.

Hope it works for you.

Wilson Gonzalez Thu, 12/18/2014 - 07:54

You can disable g.722 codec under enterprise service parameters so no devices are allowed to use it.

Actions

This Discussion