Redistributing BGP into EIGRP

Unanswered Question
Jan 10th, 2009

Hi,

Just a quick question as I feel I am banging my head against a brick wall here: is it actually possible to redistribute eBGP into EIGRP? I'm getting external BGP routes advertised across our MPLS, and I really need to stick them into EIGRP. If it is definitely possible I will post configs etc and explain in more detail!!!

Many thanks,

J

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
maahiraahi Sat, 01/10/2009 - 06:05

Redistribution of BGP in to EIGRP (IGP) is possible.

command is as below,

#router eigrp as#

#redistribute bgp as#

regards

jigsaw2026 Sat, 01/10/2009 - 06:23

Thank you, this is what I have already. Do you have an experience of it working?

Here's what I have:

router eigrp 100

redistribute static route-map redistribute-static-route-to-eigrp

redistribute bgp xxxxx route-map redistribute-bgp-route-to-eigrp

passive-interface default

no passive-interface Vlan21

no passive-interface GigabitEthernet5/0/1

network 192.168.22.0 0.0.0.7

network 192.168.22.8 0.0.0.7

distance eigrp 90 90

no auto-summary

router bgp xxxxx

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

network 192.168.2.40 mask 255.255.255.248

aggregate-address 10.3.0.0 255.255.0.0 as-set summary-only

redistribute static route-map redistribute-static-route-to-mpls

redistribute eigrp 100 route-map redistribute-eigrp-route-to-mpls

neighbor 192.168.2.46 remote-as xxxx

neighbor 192.168.2.46 description MLPS

neighbor 192.168.2.46 soft-reconfiguration inbound

neighbor 192.168.2.46 distribute-list 93 out

no auto-summary

!

route-map redistribute-bgp-route-to-eigrp permit 10

match ip address 92

Standard IP access list 92

20 permit 172.28.0.0 (2 matches)

30 permit 172.29.0.0 (2 matches)

40 permit 172.30.0.0 (2 matches)

sh ip route 172.28.0.0

Routing entry for 172.28.0.0/16

Known via "bgp "xxxxx", distance 20, metric 0

Tag xxxx, type external

Redistributing via eigrp 100

Last update from 192.168.2.46 1w3d ago

Routing Descriptor Blocks:

* 192.168.2.46, from 192.168.2.46, 1w3d ago

Route metric is 0, traffic share count is 1

AS Hops 2

And the same for the others. But these routes do not make it to the EIGRP topology table (there are no entries for these networks).

jigsaw2026 Sat, 01/10/2009 - 06:42

I just figured it out; I needed a default-metric configured.

Yay me! :)

Harold Ritter Sat, 01/10/2009 - 07:00

You need to configure a default-metric for routes being redistributed into Eigrp. The routes are otherwise not redistributed.

router eigrp 1

default-metric 10000 10 255 1 1500

or

route-map redistribute-bgp-route-to-eigrp permit 10

match ip address 92

set metric 10000 10 255 1 1500

Regards

Actions

This Discussion