Configuring IP

Answered Question
Jan 11th, 2009
User Badges:

I'm having issues with my CCUM 6 where my phones will not obtian an IP address, they just sit there with the mesage 'Configuring IP', its the first time I have used version 6, the last time I configured CCM from the ground up was at version 4.1 which used Windows 2000 DHCP, does anybody know why my phones would just sit here at this stage, my settings on configurations are below.


Thanks for you time and hope you can help me out here, if you need to see more settings or configurations then please let me know.


Here are my DHCP Server Settings


Host Server 192.168.3.248

Primary TFTP Server IP Address(Option 150) 192.168.3.248

Secondary TFTP Server IP Address(Option 150)

Bootstrap Server IP Address 192.168.3.248

Domain Name ccum

Here is my DHCP Subnet Settings

DHCP Server 192.168.3.248

Subnet IP Address 10.50.50.0

Primary Start IP Address 10.50.50.1

Primary End IP Address 10.50.50.50

Primary Router IP Address 10.50.50.250 which my VLAN 2 IP Address

Domain Name ccum

Primary TFTP Server IP Address(Option 150) 192.168.3.248

Bootstrap Server IP Address 192.168.3.248


Switch Settings


interface FastEthernet0/6

description ***IP Phone***

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

spanning-tree portfast


interface FastEthernet0/43

description ***CCUM 6***

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 2

spanning-tree portfast


interface Vlan1

description *** Data Vlan ***

ip address 192.168.3.250 255.255.255.0


interface Vlan2

description *** Voice Vlan ***

ip address 10.50.50.250 255.255.255.0


Correct Answer by Nicholas Matthews about 8 years 5 months ago

Hi Martyn,


Since the switch is configured for 'voice vlan 2' your PC will not get the voice vlan. This uses CDP which your PC does not use.


I would go through the phone settings and make sure DHCP is on, that you're connecting the phones with a straight through wire, and that they don't have any statically set IP settings.


You can also hook up a SPAN session and see what's going across the wire. See if the phones are sending out DHCP requests, which can also be done with the dhcp debugs. I just like watching the wire myself :)


You can also try changing some of the phone ports to something like this:


int fa0/1

switch mode access

switch access vlan 2

switch voice vlan 2


Or, go in and statically configure the IP addresses and see if you can ping it from the switch.


This may be a problem that has nothing to do with DHCP.




hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (4 ratings)
Loading.
Rob Huffman Sun, 01/11/2009 - 15:17
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Martyn,


I am no Network expert by any means, but it looks like the Voice Vlan is missing the IP Helper address (that points to your DHCP Server). There are some good tips in this doc;


http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080114aee.shtml


Hope this helps!

Rob

mcheatle Sun, 01/11/2009 - 16:05
User Badges:

Thanks for your reply Rob, added the line but still no Joy


Cheers

Nicholas Matthews Sun, 01/11/2009 - 16:16
User Badges:
  • Red, 2250 points or more

If you would like you can simplify some of this configuration by adding the DHCP server locally on the switch.


Configuration would be something like this:



ip dhcp excluded address

ip dhcp pool phones

network 10.50.233.0 255.255.255.0

default-router 10.50.233.1

option 150 ip 172.18.110.80

domain cisco.com



hth,

nick

mcheatle Mon, 01/12/2009 - 02:13
User Badges:

Thanks Nick, I will give that a try but I would like to know how to do it on the server if poss.


Cheers

drubery Mon, 01/12/2009 - 11:32
User Badges:

If I am not mistaken for helper addresses to function properly you need to enable the dhcp service.

Ronald Spencer Mon, 01/12/2009 - 15:29
User Badges:

You know, a draw back to the config you are proposing is that if your dhcp server fails, phones will not register. If you config the dhcp server on the switch, you bypass this issue.

mcheatle Mon, 01/12/2009 - 17:33
User Badges:

OK I have configured the DHCP server on the Switch: -


ip dhcp pool Voice

network 10.50.50.0 255.255.255.0

default-router 192.168.3.254

option 150 ip 192.168.3.248

dns-server 194.168.4.100 194.168.8.100

lease 14


Disabled DHCP on Callmanager but still I get no IP adddress.


Are my switch settings correct for my call manager?


interface FastEthernet0/43

description ***CCUM 6***

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

spanning-tree portfast


Thanks for your time

Nicholas Matthews Mon, 01/12/2009 - 19:05
User Badges:
  • Red, 2250 points or more

The default router has to be in the same subnet as the phones. In this case you would make it the switch VLAN 2 address.


hth,

nick

mcheatle Tue, 01/13/2009 - 08:36
User Badges:

First of all I would like to say thanks for your support here its very much appreciated.


I made the changes as suggested but still not joy, no IP's for my phones, no leases not offers and nothing in my Debug DHCP detail


DHCP server: ANY (255.255.255.255)

Leases: 0

Offers: 0 Requests: 0 Acks: 0 Naks: 0

Declines: 0 Releases: 0 Bad: 0


My switch setting are now looking like: -


ip dhcp pool Voice

network 10.50.50.0 255.255.255.0

default-router 10.50.50.250

option 150 ip 192.168.3.248

dns-server 194.168.4.100 194.168.8.100

lease 14


interface FastEthernet0/43

description ***CCUM 6***

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 2

spanning-tree portfast


interface FastEthernet0/48

description Martyn Desk Phone 7970

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

spanning-tree portfast


Thanks for your continued support


Martyn

mcheatle Tue, 01/13/2009 - 08:47
User Badges:

Update:, I have just plugged my laptop into the Switch to see if I get a 10. IP address, I get an IP address but it come from my Linksys Router on my 192 network.


Correct Answer
Nicholas Matthews Tue, 01/13/2009 - 10:05
User Badges:
  • Red, 2250 points or more

Hi Martyn,


Since the switch is configured for 'voice vlan 2' your PC will not get the voice vlan. This uses CDP which your PC does not use.


I would go through the phone settings and make sure DHCP is on, that you're connecting the phones with a straight through wire, and that they don't have any statically set IP settings.


You can also hook up a SPAN session and see what's going across the wire. See if the phones are sending out DHCP requests, which can also be done with the dhcp debugs. I just like watching the wire myself :)


You can also try changing some of the phone ports to something like this:


int fa0/1

switch mode access

switch access vlan 2

switch voice vlan 2


Or, go in and statically configure the IP addresses and see if you can ping it from the switch.


This may be a problem that has nothing to do with DHCP.




hth,

nick

mcheatle Tue, 01/13/2009 - 16:01
User Badges:

OK getting places now, I'm now getting TFTP timeouts, just going to check my settings.


Nick thanks for your help so far


Martyn

mcheatle Tue, 01/13/2009 - 16:37
User Badges:

OK all sorted now, I had made a few errors along the way which caused me much grief.


here is my final configuration: -


interface FastEthernet0/43

description ***CCUM 6***

switchport trunk encapsulation dot1q

switchport mode access

spanning-tree portfast


Which you suggested Nick But my biggest mistake was inter VLAN routing


IP ROUTING

Actions

This Discussion