WAAS 4.1.1.c problems

Unanswered Question
Jan 12th, 2009

Does anyone have as many problems as I do with these WAAS appliances. It seems as if I have a problem every week with these things.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
elliottreyes Mon, 01/12/2009 - 20:56

1. tfo accelerator overloads

2. dropping offline for no reason (Need to power cycle)

3. mapi accelerator issues with exchange 2007

4. cifs window shares disappear or problems with the accelerator restarting.

Patrick Murphy Thu, 01/15/2009 - 13:19

So far, I've found two issues:

1. Randomly sending email in Outlook 2003 users will get the below message. I have TAC case open for this.

---

This message could not be sent. Try sending the message again later, or contact your network administrator. The client operation failed. Error is [0x80004005-0x0004b9-0x000501].

---

2. Issue with using the Outlook viewmail plugin for the cisco phones. Outlook will freeze when the user hits the play button.

The odd thing is issue one only happens at site x and issue to happens at site y. Putting the specific flow in bypass seems to resolve the issue. I will let you know more once I resolve issue 1.

Thanks,

Patrick

nchidamb Tue, 01/27/2009 - 10:48

Patrick,

Are the above problem happened only after upgrading to 4.1.1c? If so, did you get a chance to open a TAC case to resolve it?

thanks

Nat

Patrick Murphy Wed, 02/25/2009 - 07:20

Nat:

The issues existed in 4.1.1a. Cisco recommended upgrading to 4.1.1c, but that did not fix the issue. I've sent in captures and sysreports to Cisco, but haven't pinpointed the issue yet. It is very random and sometimes resolves itself before I get to it.

nchidamb Tue, 01/27/2009 - 10:56

1. TFO accelerator overloads may happen due to the fact that there are many more TCP connections are hitting the WAE than it is designed to handle. What type of WAE (or) NME you are using?

2. Is CM showing you that a specific WAE is in offline status (or) you are unable to console/telnet into that WAE? If CM is showing that a specific WAE is offline are able to console or telnet into it? Are you able to ping that WAE at the time of 'offline' status? Is it happening only after you upgraded the WAE to 4.1.1c? What version of CM are you running?

3. What is the issue you are running with MAPI accelerator with Exchange 2007? Do you have encryption ON or OFF for the exchange mail traffic?

4. Are you using CIFS AO that was introduced in 4.1.1 or the older WAFS ( which is based on tunnel over port 4050?)

elliottreyes Tue, 01/27/2009 - 11:05

Does it matter whether encryption is on or off ?

I know how to turn off encryption on the client is there a overall setting on the server as well.

ckolasinski Wed, 02/11/2009 - 09:12

You can turn off encryption via a GPO...

We ran into the issue of exchange clients opening hundreds of connections to their exchange server and keeping the connections open. At first we thought this was a WAAS problem, but upon further investigation we were able to determine that clients at both Accelerated and Non Accelerated sites were having the issue. We are in the process of investigating the following MS KB948496

Richard Bradfield Sun, 02/15/2009 - 23:07

we have similar problems to you,

Cisco TAC were online to our system for a good 4 hours the other day, and from the traces they think some of the problems are to do with WCCP, and have passed info higher up the Cisco support chain

jorjes1984 Thu, 04/23/2009 - 05:30

Hi All

I have also many problem in the WAAS

it is running now on 4.1.1a

can you please advise if any had the same problems and how it was resolved??

REgards,

Attachment: 
dstolt Thu, 04/23/2009 - 05:59

Georges,

I think most of those issues would be resolved in that latest version of code (4.1.1d). I would try loading that as between 4.1.1a and 4.1.1d, there are a lot of bug fixes dealing with the new App Optimizers, etc. which is part of what you are seeing in your alarms.

You can see the resolved caveats in each version in the release notes: http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/v411/release/notes/ws411rn.html

Dan

JHaynes4 Thu, 04/23/2009 - 06:19

I can attest to 4.1.1d fixing most of our issues. I am waiting to see the feedback on the new 4.1.3 before upgrading to that code.

kmr Wed, 05/06/2009 - 08:24

I upgraded to 4.1.3 last night after reading this thread. My core WAE does not show any entries in the Connections Summary table (monitor, connection statistics), the remote WAE shows connections, but no acceleration, no applied policy for connections. Bounced the core and no changes. Very frustrating.

nchidamb Wed, 05/06/2009 - 09:16

This sounds to me that the core device is not intercepting the traffic. Are you using inline or WCCP for redirecting the traffic to WAE? If you are using inline card did you ensure that the inline interface is not in shutdown mode or you do not have 'no inline vlan all' command ( 'no inline vlan all' under inline interface means that do not intercept any traffic ).

In essence, the core WAE is not intercepting the traffic for some reason. So, you must ensure that the redirection technique you use properly redirects the traffic to WAE.

If WAE doesn't intercept the traffic then you will not see any 'connections' under WAE->Monitor->Connection Statistics.

Regards

-Nat

kmr Wed, 05/06/2009 - 09:26

Traffic was being redirected as expected before upgrading the code. No changes made except WAE code upgrade. "sh wccp routers" on core WAE does not have an entry for "Router(s) seeing this Wide Area Engine" but does list the IP of the router for "Routers not seeing" this wae. sho ip wccp 61 det and 62 det on the router indicates the "State: NOT useable". Looks like WCCP has stopped working on the router. NO changes were made to the router.

nchidamb Wed, 05/06/2009 - 09:42

From which version on WAE you upgraded to 4.1.3? I have done several times from 4.0.19 and 4.1.1x to 4.1.3 and I have never faced this problem because of upgrade.

Are you able to ping from WAE to router and vice versa?

Regards

-Nat

kmr Wed, 05/06/2009 - 09:46

ICMP working properly in both directions. router sho ver:

Cisco IOS Software, 3800 Software (C3825-ADVENTERPRISEK9_IVS-M), Version 12.4(15)T7, RELEASE SOFTWARE (fc3)

System image file is "flash:c3825-adventerprisek9_ivs-mz.124-15.T7.bin"

Cisco 3825 (revision 1.2) with 487424K/36864K bytes of memory.

Processor board ID FTX1303A00T

2 Gigabit Ethernet interfaces

27 Serial interfaces

3 Channelized T1/PRI ports

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

125440K bytes of ATA System CompactFlash (Read/Write)

nchidamb Wed, 05/06/2009 - 10:01

Now that I know you are using 38xx router as your traffic redirecting router could you tell me what is the redirect, egress & return method configured on the WAE? Perhaps, WCCP specific config from WAE might help to isolate the issue.

Regards

Nat

kmr Wed, 05/06/2009 - 10:48

(IP addys changed to protect the innocent)

WAE:

wccp router-list 8 1.1.9.251

wccp tcp-promiscuous router-list-num 8 l2-redirect assign-method-strict l2-return

wccp version 2

Router:

ip wccp 61

ip wccp 62

!

interface Multilink1

ip address 1.31.1.2 255.255.255.252

ip wccp 62 redirect in

interface GigabitEthernet0/0.101

encapsulation dot1Q 101

ip address 1.1.1.251 255.255.255.0

ip wccp 61 redirect in

ip wccp 62 redirect out

shutdown

!

interface GigabitEthernet0/0.102

encapsulation dot1Q 102

ip address 1.1.2.251 255.255.255.0

ip wccp 61 redirect in

ip pim sparse-dense-mode

!

interface GigabitEthernet0/0.103

encapsulation dot1Q 103

ip address 1.1.3.251 255.255.255.0

ip wccp redirect exclude in

shutdown

!

interface GigabitEthernet0/0.109

encapsulation dot1Q 109

ip address 1.1.9.251 255.255.255.0

ip wccp redirect exclude in

nchidamb Wed, 05/06/2009 - 14:05

The WAE is configured for 'L2 Return'. I am not sure whether WAE is L2 adjacent to 3825 router. So, can you can change the 'Return method to GRE'?.

Basically, remove the 'l2-return' from ' wccp tcp-promiscuous router-list-num 8 l2-redirect assign-method-strict l2-return ' command on your WAE.

kmr Wed, 05/06/2009 - 16:55

performed as suggested:

sho run

wccp tcp-promiscuous router-list-num 8 l2-redirect assign-method-strict

wccp version 2

!

#sho wccp routers

Router Information for Service: TCP Promiscuous 61

Routers Seeing this Wide Area Engine(0)

-NONE-

Routers not Seeing this Wide Area Engine

1.1.9.251

Routers Notified of from other WAE's

-NONE-

Multicast Addresses Configured

-NONE-

performed 'sho ip wccp 61 det' on router:

WCCP Client information:

WCCP Client ID: 1.1.9.101

Protocol Version: 2.0

State: NOT Usable

Initial Hash Info: 00000000000000000000000000000000

00000000000000000000000000000000

Assigned Hash Info: 00000000000000000000000000000000

00000000000000000000000000000000

Hash Allotment: 0 (0.00%)

Packets s/w Redirected: 0

Connect Time: 00:00:20

Bypassed Packets

Process: 0

Fast: 0

CEF: 0

Errors: 0

Note 'State: NOT Usable'

I've bounced router. Removed WCCP from router, added it back in, no change in WCCP state.

kmr Wed, 05/06/2009 - 18:11

Update:

Reverted code to 4.1.1c. sho ip wccp 61 det indicates:

WCCP Client information:

WCCP Client ID: 1.1.9.101

Protocol Version: 2.0

State: Usable

Initial Hash Info: 00000000000000000000000000000000

00000000000000000000000000000000

Assigned Hash Info: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

Hash Allotment: 256 (100.00%)

Packets s/w Redirected: 812

Connect Time: 00:02:03

Bypassed Packets

Process: 0

Fast: 0

CEF: 0

Errors: 0

kmr Wed, 05/06/2009 - 20:08

Update:

Changed router code to 12.4(25). 4.1.1c on WAE and WCCP worked.

Changed WAE code to 4.1.1d. WCCP worked. Went to 4.1.3 (just to see), WCCP failed. Changed back to 4.1.1d, WCCP worked.

A TAC case was opened for this by another person for this WAE. TAC recomended changes on the router (bounce, turn off/on WCCP). Neither had WCCP working with the 4.1.3 WAE code.

Actions

This Discussion