Unity 5.0 with Exchange 2007

Unanswered Question
Jan 12th, 2009

Hi everybody,

I am trying to integrate Unity 5.0 with Exchange 2007 (UM).

I tried the installation twice, and always subscribers while trying to view their messages: they got the message: "your messages are not available.", I searched Cisco and knew it is a MailStore problem. But Cisco Solution works only Exchange 2000/2003

My customer is having 2 different mailbox store databases in his Exchange, can Unity 5.0 support this?

In Permission wizard: I can define multiple stores, but in MessageStore configuration wizard, only one can be defined.

I shall be waiting for your answer

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Tue, 01/13/2009 - 04:29

in any Unity version you define a partner exchange server to which Unity will talk, all communication goes thru it. If the other exchange server is in the same exchange organization and you have delegated control and ran the PW you should be able to use it.

HTH

java

if this helps, please rate

ranpierce Tue, 01/13/2009 - 06:35

In addition to what Jaime has said,

PW only gives permissions to the mailstores and lets Unity know they are there.

MSCW does not give permissions. It chooses the partner Exchange server and default mailstore.

I am partnered with e2k7 here and you need to run both wizards, PW first.

It will work with E2k7

Randy

Bradford Magnani Tue, 01/13/2009 - 06:38

When Message Store Config. Wizard is ran for an Exchange 2007 partner mail store, it will auto-create a power shell script and place it on the desktop for you to put on the Exchange server and run via command line. Did this script run successfully and create all 3 of our system mailboxes? Otherwise, make sure you've done the proper delegation of UnityInstall and UnityDirSvc in Exchange and that Permissions Wizard was run successfully while logged in as a Domain Admin account.

Brad

mnasser78 Tue, 01/13/2009 - 07:54

Dear all,

I am very thankful for your replies.

In fact, it was very simple: it just came to my colleague mind to restart the exchange server, and it works very smooth after.

Actually, I have a second question: some users cannot be seen by Unity to be imported, for example: an OU contains 10 users, only 3 are detected, while I am sure they exist in the specified OU.I think maybe to synchronize Active Directory servers, do u have any suggestions?

Bradford Magnani Tue, 01/13/2009 - 07:58

Chances are they need to have the Unity attributes "wiped" from them, to become available for import again.

You may want to clean the user with the Remove Subscriber Properties Tool if you haven't already; located in the Commserver\Utilities\RemoveSubscriberProperties directory on the Unity server.

Right click on the subscribers in question and Remove Properties. See if that helps.

Brad

Actions

This Discussion