%Error opening tftp:// (Timed out)

Unanswered Question
Jan 13th, 2009

For some odds reasons, I am unable to upload to a TFTP server from this switch only. The TFTP server is working since I am able to upload other config to it. I even tried no config service but that did not seem to work either.

The switch is running ver 12.2(25)SEE3. I also don't think it is the version because another switch with the same version was able to upload its config to the TFTP server.

What could the problem be?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Collin Clark Tue, 01/13/2009 - 06:40

That error usually point towards no connectivity between the switch and the TFTP server. Can you ping the server from the switch and vise-versa?

Tshi M Tue, 01/13/2009 - 06:59

Yes, network connectivity is there. The server is also used for logging and snmp.

Tshi M Tue, 01/13/2009 - 07:30

I actually see the file with 0kb in the tftp server.

technicifiala Wed, 01/21/2009 - 09:06

Hi, did you solve this problem already?

I've been in the same soup since 11/05/08.

All my switches (C29xx) backups its configs via tftp regularly daily morning, but only two (routing core switches C35xx cs-a2p1 and ss-s01-1) stopped backuping, see "dir" command output:


21.01.2009 07:34 9 819 cs-a2p4.fzu.cz.config.text

21.01.2009 07:34 1 348 cs-a2p4.fzu.cz.vlan.dat

05.11.2008 07:31 49 035 cs-a2p1.fzu.cz.config.text

05.11.2008 07:31 1 776 cs-a2p1.fzu.cz.vlan.dat

21.01.2009 07:31 8 785 cs-bp1.fzu.cz.config.text

21.01.2009 07:31 1 396 cs-bp1.fzu.cz.vlan.dat


21.01.2009 07:32 9 385 ss-ap2.fzu.cz.config.text

21.01.2009 07:32 856 ss-ap2.fzu.cz.vlan.dat

05.11.2008 07:42 59 858 ss-s01-1.fzu.cz.config.text

05.11.2008 07:42 1 696 ss-s01-1.fzu.cz.vlan.dat

21.01.2009 07:32 9 271 cs-cp2.fzu.cz.config.text

21.01.2009 07:32 1 036 cs-cp2.fzu.cz.vlan.dat




DigitalWhitewater Mon, 06/13/2011 - 12:24

I had the same problem, same ios version too. I switched tftp server and now its working. Try using tftpd32 or tftpd64 depending on your os type. Worked on the first try after I changed mine.

manju.cisco Tue, 07/19/2011 - 10:29

Hi Tshi,

Assuming your tftp server is unix platform:-

There are few reasons why you are not able to upload configs to tftp server.

May be the file 3560-sw1-confg is readonly, i mean the permission of this file should be read and write for all user groups.

Another reason is the file doesnt exists in tftp server.

If the file exists may not exist in the proper directory.

Please do this:

Go to your tftp directory in your tftp server(hope u know your tftp directory path), and create a new file with permissions ( as below):

touch new-cfg-file

chmod 666 new-cfg-file

now from your switch/router, do this:

copy running-config tftp:

input tftp ip addres -

input desitnation file name as --- new-cfg-file

If your tftp server is windows using 3rd party software, then pls reinstall the tftp server software or use a different software. That should work then...

Hope this helps...


This Discussion