Cisco ip phone error 4

Unanswered Question
Jan 13th, 2009

We are trying to deploy the push2phone application and when the web admin (a developer)tries to push a message to the phone, he gets a CiscoIPPhoneError with a value of 4. Checked the enterprise paramaters and found that the URL Authentication value is set for http://x.x.x.x:8080/ccmcip/authenticate.jsp. I have associated with his phone for him to push the message. Still it does not work. Need to know what I am doing wrong here. Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sascha Monteiro Tue, 01/13/2009 - 13:12

Hey, does the developer authenticate when he is pushing? and the userid/password have a device association with the ipphone?


try this yourself 1st;

from a browser, go to an ipphone;

http://ipphone-ipaddress/CGI/Screenshot

you should get a pop up, enter the userid and password of the user that the developer is using and see what happens (you should get a screenshot if it's i.e. a 3rd gen phone like 7941)


I am not 100% sure however if you can authenticate with an end user, or if it needs to be an application user...haven't tried, I always use an application user with no roles, and only a device association with all ipphones...

kraghavansag Tue, 01/13/2009 - 14:44

It does not show anything. I tried the same in another call manager and now the error code is 0. what does this authentication URL do? No help from the call manager page. :(

Sascha Monteiro Tue, 01/13/2009 - 16:34

when you try to send a request to the ipphone, it will authenticate against the callmanager to verify you are allowed to do this.


what happens if you paste the url from enterprise parameters in your web browser?

kraghavansag Tue, 01/13/2009 - 16:37

It gives a message UN-AUTHORISED when I paste the url from enterprise parameters in the web browser.

msabir Wed, 01/14/2009 - 09:37

In your authentication URL, if you have host name (as opposed to IP address), that might be causing this problem. I have seen it a few times and by changing the host name to IP fixed it. You will need to reboot the phones to make it effective.

kraghavansag Wed, 01/14/2009 - 10:09

Hi,


I find that the authentication URL is using ip address instead of the DNS. I will try rebooting the phone and see if it fixes the problem. I tried extension mobility feature and it works like charm. Hopefully it also takes the same authentication URL for the phone. let me see how far this goes.

msabir Wed, 01/14/2009 - 10:12

We found issues with the built-in authentication in CUCM, specially in 4.x days. We have developed our own authentication for PhoneTop Messenger product.

msabir Wed, 01/14/2009 - 10:24

Yep. I am one of the lead developers.


This award-winning product is really easy to install and manage. It does audio paging, wave file broadcast, text notification, weather alerts, Amber alerts, surveys and more. You can download the eval. copy to play with.



kraghavansag Wed, 02/04/2009 - 08:34

Finally I got the ip phone error 4 to go away. Since our system was using LDAP for authentication, it was looking for case-sensitive user ids (in my case all caps). I have seen this happening with IPCC Express server and the CCM user pages and administration pages work just fine with lower case letters for authentication. Only the phone and IPCC servers (as far as I can see) look for case-sensitive user ids when authentication is done using LDAP. Interestingly, i have reported to the TAC and they are filing a defect case with the engineering team. hope it is corrected in the up-coming versions. :)

Actions

This Discussion