ISDN auto redial after 120 seconds

Answered Question
Jan 13th, 2009
User Badges:

HI all,

I am configuring ISDN as a backup connection between a HO router and a branch


All connections, routing and dialing are working fine, but the issue am facing is that when the ISDN dials the HO (when the Primary link is down), the calls last for 120s, disconnect then initiate a new call (Although there is an interesting traffic at all time and the IDLE time-out is not increasing)


I did many tests, and It is always disconnecting after that 120seconds passes.


Note: the Idle timeout is 300s, and there is always an interesting traffic passing while doing the test.


I have attached some debugs (debug dialer and debug isdn events) taken from the branch and HO while doing a test.



I have in the HO a 2 PRI channels, and in all the branches BRI connections.


This is config related to the ISDN in the HO router:

controller E1 3/6

pri-group timeslots 1-31

!

controller E1 3/7

pri-group timeslots 1-31

!

interface Serial3/6:15

ip address 172.16.6.100 255.255.255.0

encapsulation ppp

ip summary-address eigrp 1 192.168.0.0 255.255.0.0 5

ip summary-address eigrp 1 172.16.0.0 255.255.0.0 5

isdn switch-type primary-net5

ppp authentication pap

crypto map DIALUP

!

interface Serial3/7:15

ip address 172.16.6.101 255.255.255.0

encapsulation ppp

ip summary-address eigrp 1 192.168.0.0 255.255.0.0 5

ip summary-address eigrp 1 172.16.0.0 255.255.0.0 5

isdn switch-type primary-net5

ppp authentication pap

crypto map DIALUP



And in the branch this is config used:

interface BRI0/0

ip address 172.16.6.253 255.255.255.0

encapsulation ppp

load-interval 30

dialer idle-timeout 300

dialer string 01238019

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

ppp pap sent-username xxx password xxx

crypto map HO

!

ip route 0.0.0.0 0.0.0.0 BRI0/0 200


dialer-list 1 protocol ip list 101

access-list 101 permit ip host 172.16.253.253 host 172.16.253.100


(acl 101 represent the VPN peers)



Correct Answer by Richard Burts about 8 years 6 months ago

Georges


I have looked at what you have posted and I believe that I have found your problem. Your post states that there is always interesting traffic. And that is true of the Branch. But it does not seem to be true of HQ. Here are some significant lines from the HQ debug:

HO-999#

Jan 13 14:47:04: Se3/7:2 DDR: idle timeout

Jan 13 14:47:04: Se3/7:2 DDR: disconnecting call

this shows that HQ is declaring the idle timeout and is disconnecting the call.


The issue is that there is no dialer-group or dialer-list on HQ to define interesting traffic. So HQ has no interesting traffic. And with no interesting traffic its default idle timeout is 120 seconds and it disconnects the call.


Many people have a misconception about interesting traffic in dialup configuration. They associate interesting traffic as necessary to place a call. Since it is not required to have interesting traffic to answer a call, they assume that they do not need interesting traffic from dialer-group and dialer-list on the answering router. But the problem is that interesting traffic is necessary not only to initiate a call but also is necessary to keep the connection up. As your routers demonstrate if one end of the connection hangs up then the connection is broken - and will be re-established if there is interesting traffic on the calling end.


Configure interesting traffic on the HQ and let us know if it fixes your problem.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Richard Burts Tue, 01/13/2009 - 13:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Georges


I have looked at what you have posted and I believe that I have found your problem. Your post states that there is always interesting traffic. And that is true of the Branch. But it does not seem to be true of HQ. Here are some significant lines from the HQ debug:

HO-999#

Jan 13 14:47:04: Se3/7:2 DDR: idle timeout

Jan 13 14:47:04: Se3/7:2 DDR: disconnecting call

this shows that HQ is declaring the idle timeout and is disconnecting the call.


The issue is that there is no dialer-group or dialer-list on HQ to define interesting traffic. So HQ has no interesting traffic. And with no interesting traffic its default idle timeout is 120 seconds and it disconnects the call.


Many people have a misconception about interesting traffic in dialup configuration. They associate interesting traffic as necessary to place a call. Since it is not required to have interesting traffic to answer a call, they assume that they do not need interesting traffic from dialer-group and dialer-list on the answering router. But the problem is that interesting traffic is necessary not only to initiate a call but also is necessary to keep the connection up. As your routers demonstrate if one end of the connection hangs up then the connection is broken - and will be re-established if there is interesting traffic on the calling end.


Configure interesting traffic on the HQ and let us know if it fixes your problem.


HTH


Rick

Actions

This Discussion