Configuring Email Alerts in RTMT

Unanswered Question
Jan 14th, 2009
User Badges:

I have config the email server, alert actions and set the smtp server. Also rebooted the call manager. Please provide some suggestions to help me get the alerts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Jon Nelson Wed, 01/14/2009 - 08:17
User Badges:
  • Silver, 250 points or more

Check two things:

1. Make sure your UCM server is setup to resolve DNS

2. Make sure you are allowing your UCM server to relay off of your SMTP server




testeven Wed, 01/14/2009 - 10:16
User Badges:
  • Cisco Employee,


You can also try checking that the Exchange server is not blocking the emails for some reason. Sometimes if you have a rule blocking the mails from RTMT_Alert or other email addresses without a fqdn you don't get the alerts.

Check this bug too:


RTMT emails do not include domain in from field of SMTP header


Email alerts from RTMT may not be delivered to recipients.


RTMT alerts currently do not supply a domain in the from field of the SMTP header.

Example packet capture of problem:

Simple Mail Transfer Protocol

Command: MAIL FROM:\r\n

Command: MAIL

Request parameter: FROM:

CM logs show:

alertmgr.SendMail - SendMail::send: got address exception=

javax.mail.internet.AddressException: Missing domain in string ``RTMT_Admin@''


assign the fully qualified domain name to the servers involved using the following CLI:

set network dns primary

set network dns secondary

set network domain

Have a nice day!


keenerccna Fri, 01/16/2009 - 08:59
User Badges:

Thanks for the replies i was being blocked by my smtp server.


This Discussion