Routing Problems With Bgp And Eigrp Cisco 3825

Answered Question
Jan 14th, 2009
User Badges:

Hello everybody, I have a problem routing and i dont know where find the THE SOLUTION.

I have two ROUTERS connected by MICROWAVE, ROUTER A AND ROUTER B the router A is making BORDER WITH A ISP, I also have my own system SELF-DECLARED 42384.ROUTER A SET UP BGP4 (TO ISP) and EIGRP (TO MY COMPANY)MY PROBLEM IS:

1. ROUTER B NO PINGING TO EXTERIOR NETWORK, BUT IF PINGING TO ALL INTERFACE OF ROUTER A

2. THE ROUTER A PINGING TO EXTERIOR NETWORK AND INTERIOR NETWORK

Please can you help me ?? I'm desperate

Thanks a lot

I paste the output routers onfigurations

*****************************************ROUTER A

*****************************************

interface GigabitEthernet0/0

description ISP

bandwidth 200000

ip address 184.224.29.214 255.255.255.252

duplex auto

speed auto

media-type sfp

!

interface GigabitEthernet0/1

ip address 194.201.212.10 255.255.255.252

ip authentication mode eigrp 42384 md5

ip authentication key-chain eigrp 42384 CCC

duplex auto

speed auto

!

router eigrp 42384

passive-interface GigabitEthernet0/0

network 194.201.212.8 0.0.0.3

no auto-summary

!

router bgp 42384

no synchronization

bgp log-neighbor-changes

network 184.224.29.212

redistribute connected

neighbor 184.224.29.213 remote-as 9376

neighbor 184.224.29.213 description conexion con cz1

neighbor 184.224.29.213 password 7 55547010A66607298757C

neighbor 184.224.29.213 version 4

neighbor 184.224.29.213 prefix-list CCC-OUT out

no auto-summary

!

ip classless

!

ip prefix-list CCC-OUT description Prefijos anunciados por CCC

ip prefix-list CCC-OUT seq 5 permit 194.201.212.0/20

*****************************************

ROUTER B

*****************************************

interface GigabitEthernet0/0

description CCC TO IBEROSTAR MICROWAVE

ip address 194.201.212.9 255.255.255.252

ip authentication mode eigrp 42384 md5

ip authentication key-chain eigrp 42384 CCC

ip route-cache flow

duplex full

speed 1000

!

interface GigabitEthernet0/1

no ip address

duplex full

speed 1000

interface GigabitEthernet0/1.112

description BACKBONE

encapsulation dot1Q 212

ip address 194.201.212.18 255.255.255.240

ip authentication mode eigrp 42384 md5

ip authentication key-chain eigrp 42384 CCC

!

interface GigabitEthernet0/1.114

description CORPORATE NETWORK

encapsulation dot1Q 214

ip address 194.201.214.1 255.255.254.0

!

router eigrp 42384

passive-interface GigabitEthernet0/1.1

network 194.201.212.8 0.0.0.3

network 194.201.212.16 0.0.0.15

network 194.201.214.0 0.0.1.255

no auto-summary

*****************************************

SHOW IP ROUTE IN ROUTER B

***************************************

Gateway of last resort is 194.201.212.10 to network 0.0.0.0


10.0.0.0/24 is subnetted, 1 subnets

C 10.154.30.0 is directly connected, GigabitEthernet0/1.1

194.0.0.0/8 is variably subnetted, 6 subnets, 3 masks

C 194.201.212.8/30 is directly connected, GigabitEthernet0/0

C 194.201.214.0/23 is directly connected, GigabitEthernet0/1.114

C 194.201.212.16/28 is directly connected, GigabitEthernet0/1.112

S* 0.0.0.0/0 [1/0] via 194.201.212.10

*****************************************

SHOW IP ROUTE IN ROUTER A

*****************************************

Gateway of last resort is 184.224.29.213 to network 0.0.0.0


184.0.0.0/30 is subnetted, 1 subnets

C 184.224.29.112 is directly connected, GigabitEthernet0/0

194.0.0.0/8 is variably subnetted, 6 subnets, 3 masks

C 194.201.212.8 /30 is directly connected, GigabitEthernet0/1

D 194.201.212.0/23

[90/3072] via 194.201.212.9, 01:08:12, GigabitEthernet0/1

D 194.201.212.16/28

[90/3072] via 194.201.212.9, 01:08:14, GigabitEthernet0/1

B* 0.0.0.0/0 [20/0] via 184.224.29.213, 02:12:39

Correct Answer by Giuseppe Larosa about 8 years 5 months ago

Hello Alejandro,

nice to hear that you have solved.


However, as Kelvin as pointed out you may need to generate a default route in EIGRP on RouterA to be able to route from inside your network.


the static route on RB is fine for RB, but if there are other routers more internal they need to receive a default route in EIGRP.


About the policies and prefix-lists you should be fine: they are used as safety measures for example to avoid to advertise somebody's else IP address block.


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Giuseppe Larosa Wed, 01/14/2009 - 09:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alejandro,

on your BGP router RA you would like to advertise your public address ip block as specified by prefix-list CCC-out but there is nothing that allow to advertise that /20 prefix


you can check this with


sh ip bgp


sh ip bgp neigh 184.224.29.213 advertised-routes


you need under router bgp


or to redistribute eigrp into BGP


router bgp 42834

redistribute eigrp 42834


or to add network commands within 192.201.212.0/20


AND also

aggregate-address 194.201.212.0 255.255.240.0


to create the correct aggregate


Hope to help

Giuseppe


agrindley Wed, 01/14/2009 - 10:22
User Badges:

Many thaks Giuseppe ,


Im redistributing eigrp into BGP but the problem continues I can not pinging from the router B to exterio network


show the output of ip bgp neig


Origin codes: i - IGP, e - EGP, ? - incomplete


Network Next Hop Metric LocPrf Weight Path

*>0.0.0.0 184.224.29.213 0 6739 i

*>184.224.29.212/30 0.0.0.0 0 32768 ?

*>194.201.212.8/30 0.0.0.0 0 32768 ?

*>194.201.212.16/28 194.201.212.9 072 32768 ?

*>194.201.214.0/23 194.201.212.9 3072 32768 ?


Thanks

I appreciate your help

Giuseppe Larosa Wed, 01/14/2009 - 11:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alejandro,

have you also added the aggregate-address ?


I don't see it in the sh ip bgp and so if the prefix-list is applied still nothing is advertised to the provider (only /20 is allowed )


Hope to help

Giuseppe


kwillacey Wed, 01/14/2009 - 12:18
User Badges:
  • Bronze, 100 points or more

I'm not sure maybe I read what you have above wrong but it seems to me like routerA goes out to the Internet and routerB is behind routerA.


In that case bgp needs to be redistributed into EIGRP on routerA in order for routerB to get to the networks in front of routerA and based on the routing table of routerB it has none of the BGP learnt routes via EIGRP (DEX).

Giuseppe Larosa Wed, 01/14/2009 - 12:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Kelvin,

what you say is important


there is a static default route (or there was)


S* 0.0.0.0/0 [1/0] via 194.201.212.10


but this is something that has to be considered up to now we have focused on the return path.


Hope to help

Giuseppe


agrindley Thu, 01/15/2009 - 01:44
User Badges:

Hello Giuseppe perfect. you are great


Many thanks another time, your solutions its correct and the trafic it s working fine.


I think my provider had no knowledge of how I was trying the network.I am a newbie with these routing and I have many doubts


I am not very clear if I need to use prefix-list, routing policies, so I accept all kinds of tips

something else to keep in mind to the network


cheers

agrindley Thu, 01/15/2009 - 01:47
User Badges:

thanks to all who make this forum (giuseppe, kelvin, CISCO, etc etc)

Correct Answer
Giuseppe Larosa Thu, 01/15/2009 - 01:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alejandro,

nice to hear that you have solved.


However, as Kelvin as pointed out you may need to generate a default route in EIGRP on RouterA to be able to route from inside your network.


the static route on RB is fine for RB, but if there are other routers more internal they need to receive a default route in EIGRP.


About the policies and prefix-lists you should be fine: they are used as safety measures for example to avoid to advertise somebody's else IP address block.


Hope to help

Giuseppe


Actions

This Discussion