LMS 2.6 RME 4.0.5 : Unable to subscribe to SyslogCollector error SLCA0126

Answered Question
Jan 14th, 2009
User Badges:

Hi,


In RME+Tool+Syslog, I can't arrive to subscribe to the "Syslog Collector"


SLCA0126: Could not subscribe to the Collector.

1.Check whether the collector is running.

2.Make sure that SSL certificates are imported/exported correctly and process restarted.

3.Check whether the Certificates exported/imported are valid and have not expired.

4.Check whether SyslogAnalyzer process is running.


but my syslog are correctly collected to the "syslog.log" file located in CSCOpx\log directory.


The SyslogCollector and SyslogAnalyzer are running correctly


D:\LMS>pdshow SyslogAnalyzer

Process= SyslogAnalyzer

State = Program started - No mgt msgs received

Pid = 4632

RC = 0

Signo = 0

Start = 1/14/2009 7:30:19 PM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request


D:\LMS>pdshow SyslogCollector

Process= SyslogCollector

State = Program started - No mgt msgs received

Pid = 11928

RC = 0

Signo = 0

Start = 1/14/2009 7:26:00 PM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request



I'm in US regional setting and the TCP 4444 is not used (as shown by the netstat -an in attached file)


And see my Collector.properties is in attached file


Many thanks in advance for your help

Olivier



Correct Answer by Joe Clarke about 8 years 3 months ago

Please post the new pdshow output as well as the output of netstat -a -n -o -b.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 01/14/2009 - 11:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is most likely bug CSCsh66475. It is fixed in RME 4.0.6 which can be downloaded via Common Services > Software Center > Software Update.

ogor Thu, 01/15/2009 - 00:13
User Badges:

My server is not connected to the internet for security reasons, in case of, have you got the link of this update please ?

thanks

Olivier

ogor Thu, 01/15/2009 - 04:40
User Badges:

Hi,

I have downloaded the RME 4.0.6 service pack but a prerequisite of this update is to install the CS4.0.6 service pack but it no longer available on the cisco web site ?

Do you have the patch anywhere please ?

Olivier

Joe Clarke Thu, 01/15/2009 - 09:42
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Those are the correct links. If you also have Campus Manager or DFM installed, they will need to be upgraded as well. See http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus and http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-dfm respectively. The latest version of Campus is 4.0.12, and the latest version of DFM is 2.0.12.

ogor Fri, 01/16/2009 - 02:58
User Badges:

Hi,

I have updated the RME and CS but the pb is still the same.

The new behavior is that I arrived to subscribe to the certificate in CS, Server, Security and Peer Server Certificate Setup

before the RME 4.0.6 and CS3.0.6 it was not possible.


But also, the subscribing in RME, Tools, syslog is not possible the error SLCA0126 still remain.


Here is an error in SysloganalyzerUI.log


[ Fri Jan 16 11:38:10 WAT 2009 ],ERROR,[Ajp13Processor[9009][3]],SA0015: Cannot contact SyslogAnalyzer service for updating Collector status information

com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "SyslogAnalyzerService" : Not found !!

Correct Answer
Joe Clarke Fri, 01/16/2009 - 11:47
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the new pdshow output as well as the output of netstat -a -n -o -b.

ogor Tue, 01/20/2009 - 05:47
User Badges:

I saw the pdshow and the TCP 4444 is used by omnivision software so I will remove it and after it will be better ;) I hope


Olivier



Actions

This Discussion