NHRP strange ! Stuck !

Unanswered Question
Jan 14th, 2009

Hi guys, i searched cisco site, but could find any bug or troubleshooting regarding below mentioned issue.

I am using DMVPN, and its running successfully for like 20-30 spokes. On hub when i issued debug nhrp for some checking i got these with TONS, believe me 100 of msgs showing below

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

Now, 172.27.64.20 is tunnel ip of one of my spoke. call it spoke20. as soon as i shut the nhrp tunnel from spoke20 these msgs stop. Strange thing is that, when i do debug at spoke20 (debup nhrp) it shows me normal behaviour, whereas on hub i am still getting them continuously as soon as i bring up the tunnel. Can some1 guide me what might be the issue ? config are below

Hub

ip address 172.x.x.x 255.255.192.0

no ip redirects

ip flow ingress

ip nhrp authentication cisco123

ip nhrp map multicast dynamic

ip nhrp network-id 10

no ip nhrp cache non-authoritative

ip ospf network point-to-multipoint

ip ospf hello-interval 10

ip ospf mtu-ignore

tunnel source a.b.c.d

tunnel mode gre multipoint

tunnel key 1000

tunnel protection ipsec profile test

Spoke20

ip address 172.27.64.20 255.255.192.0

ip nhrp map 172.27.64.1 192.168.205.18

ip nhrp map multicast 192.168.205.18

ip nhrp network-id 10

ip nhrp nhs 172.27.64.1

ip nhrp registration timeout 500

ip ospf network point-to-point

ip ospf mtu-ignore

tunnel source 192.168.202.26

tunnel destination 192.168.205.18

tunnel key 1000

tunnel protection ipsec profile test

I am really confused as to why this happening, i have seen that after shutting this spoke20, i get same types of msgs for some other spoke !!! but they are not in that volume as compared to this particular spoke. Meanwhile i am changing the ios on spoke20, if you have any good ideas pls share with me. this is very critical

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 01/15/2009 - 02:43

Hello Ovais,

I may be wrong but I don't see any trouble on the message itself the number of messages can be a trouble for you during troubleshooting.

On hub when i issued debug nhrp for some checking i got these with TONS, believe me 100 of msgs showing below

1w0d: NHRP: NHRP successfully resolved 172.27.64.20 to NBMA 192.168.202.26

this just means NHRP is working well

I wonder if you should enable nhrp cache on hub

ip nhrp cache non-authoritative

caching the information should reduce NHRP activity and so the number of these messages.

Hope to help

Giuseppe

illusion_rox Thu, 01/15/2009 - 03:02

Dear Giuseppe, thanks alot for feedback, but i have already tried this but no use. There is 1 more thing i observed on spoke20. Ospf hellos are send like TONS within msecs !!!! see below

Jan 15 11:08:41.134: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.170: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.206: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.242: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.278: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.314: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.350: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.386: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.422: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.458: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.494: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.530: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.566: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.602: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

*Jan 15 11:08:41.638: IP: s=172.27.64.20 (local), d=224.0.0.5 (Tunnel222), len 80, sending broad/multicast

they are same like TONs of them. i did show ip ospf int tun 222

Last flood scan length is 1, maximum is 4

Last flood scan time is 0 msec, maximum is 13900 msec

Flood pacing timer due in 24 msec

flood pacing timer really caught my eye. I checked on other spokes but i only see this on this spoke20. Can some1 tell me how to disable this flood pacing, i tried interface level ip ospf flood reduction, but no use :(

kindly help me out

Actions

This Discussion