3560 Redundancy

Answered Question
Jan 15th, 2009
User Badges:

Hi Guys,


I have a new 2x 3560, do you have any suggestion on how can I make this redundant? Like you will just see 1 node for this two switches. I have configured an etherchannel on it but it seems it is not working.


interface GigabitEthernet0/1

channel-group 1 mode auto

switchport mode trunk

!

interface GigabitEthernet0/2

channel-group 1 mode auto

switchport mode trunk


Any help is very much appreciated. Thanks in advance.


Cheers!


Correct Answer by Jon Marshall about 8 years 3 months ago

Irvine


Can you post full configs for both switches.


if you want to connect the 2 switches togther with an etherchannel trunk


SW1(config)# int range gi0/1 - 2

SWI(config-if)# switchport

SWI(config-if)# switchport trunk encapsulation dot1q

SWI(config-if)# switchport mode trunk

SW1(config-if)# channel-group 1 mode on


do same config as above for SW2


Connect the 2 switches together on gi0/1 & 2.


3560 will run HSRP/GLBP. This is used for gateway redundancy. So an example


SW1


int vlan 10

ip address 192.168.5.2 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 pri 110

standby 10 preempt

standby 10 auth


SW2


ip address 192.168.5.3 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 pri 100

standby 10 auth


then any client in vlan 10 is given the default-gateway of 192.168.5.1


Jon





Correct Answer by Tshi M about 8 years 3 months ago

Hi,


what do you get when you do:

sh ether sum


what do you see in the log?




At the very basic, i will have:

po1

switchport trunk encapsulation dot1q

switchport mode trunk


g0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

g0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jon Marshall Thu, 01/15/2009 - 06:56
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Irvine


What do you mean by redundant. Do you mean connect them togther with etherchannel and perhaps run HSRP between the 2 switches ?


Can you post output of


"sh etherchannel summary" &

"sh int trunk"


from both switches.


Jon

gagamboy15 Thu, 01/15/2009 - 07:05
User Badges:

Hi Jon,


Yes, you're right. But I don't think 3560 supports HSRP, Is there any protocol or way for redundancy.


Please see attachment. Thanks.





Attachment: 
Correct Answer
Jon Marshall Thu, 01/15/2009 - 07:14
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Irvine


Can you post full configs for both switches.


if you want to connect the 2 switches togther with an etherchannel trunk


SW1(config)# int range gi0/1 - 2

SWI(config-if)# switchport

SWI(config-if)# switchport trunk encapsulation dot1q

SWI(config-if)# switchport mode trunk

SW1(config-if)# channel-group 1 mode on


do same config as above for SW2


Connect the 2 switches together on gi0/1 & 2.


3560 will run HSRP/GLBP. This is used for gateway redundancy. So an example


SW1


int vlan 10

ip address 192.168.5.2 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 pri 110

standby 10 preempt

standby 10 auth


SW2


ip address 192.168.5.3 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 pri 100

standby 10 auth


then any client in vlan 10 is given the default-gateway of 192.168.5.1


Jon





Tshi M Thu, 01/15/2009 - 07:21
User Badges:
  • Silver, 250 points or more

Your first mentioned that both g0/1 and g0/2 are part of the po1 ether but your attachment shows that g0/1 belongs to po1 and g0/2 belongs to po2.

Correct Answer
Tshi M Thu, 01/15/2009 - 06:58
User Badges:
  • Silver, 250 points or more

Hi,


what do you get when you do:

sh ether sum


what do you see in the log?




At the very basic, i will have:

po1

switchport trunk encapsulation dot1q

switchport mode trunk


g0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

g0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable



gagamboy15 Thu, 01/15/2009 - 07:41
User Badges:

Hi Guys,


Thanks for the feedback. It seems that I misconfigured the port channel mode and PO1 and PO2 group for both switches.


By the way is it advisable to do port-channel mode ON on both switches? or should I stick to auto-desirable?


Is there any another way to do redundancy aside from HSRP?


Thanks to you guys!


Cheers!

Tshi M Thu, 01/15/2009 - 07:55
User Badges:
  • Silver, 250 points or more

I will use mode on prevents negotiation and might a safe bet.


regards

Carlitos Carne Sat, 01/17/2009 - 17:28
User Badges:

Using 'port-channel mode on' means just what it says; there will be no negotiation. I use it because it is quicker. If you use it, you must always be certain that all ports you intend to physically connect are correctly configured BEFORE connecting them. Otherwise, you could wind up with a looping condition that could do some pretty nasty things on your network.

Actions

This Discussion