Tieing 2 key systems together with fxo/fxs and 1760 routers

Unanswered Question
Jan 15th, 2009
User Badges:

Hello,


I need some programming help from someone good on voice. I've got two offices that I'm trying to tie the phone systems together with 2x Cisco 1760 routers each with 2x PVDM-256K-4 1 DSP Modules. I've got the layout below and am basically looking to do two things.


First, I would like ext. 210 from the first site to dial a co group “1” or directly access a “CO line” that is connected to the Cisco and get dial tone to be able to dial the directory number for a “CO line” with the same setup at the second site and have it able to be answered like a normal call and be transferred.


The second connection I would like is to have ext. 210 be able to dial locally to one of site 1's analog single line extensions and have the Ciscos make a connection through to site 2 and go off-hook on one of the analog single line extensions of site 2 in order to get a site 2 dial tone and be able to dial locally @ site 2 to any extension, or dial one of site 2's co groups or directory number for one of site 2's real CO lines and place a “local” call to the outside world from site 2's lines.


Obviously this process would all be reversed for site 2 accessing site 1. I've come across a couple of documents, like ID: 15405, and a section of a VoIP Configuration guide labeled OL-1070-01 and have some command structure available, but the concept of how it all takes place and should be configured is a little fuzzy.


Thank you,

Mark


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Thu, 01/15/2009 - 10:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, decide some prefix that you want them to use when dialing off-site, and use that as destination-pattern for voip DP. Same on remote router to a pots DP matching a port, or a set as trunk-group. One you familiarize yourself with DPs it become very easy. You can make all the ports to be like a pool using preference option under dp and "no huntstop".

sandman420 Thu, 01/15/2009 - 10:42
User Badges:

I understand the dial peers only enough to probably program the first of two tasks that I'm trying to complete. The second task was to have an extension from site 1 call another s/l ext. at site 1 that is hooked up to the cisco and have the cisco answer the port and connect through to another s/l ext. at site 2 connected again to the site 2 cisco and provide site 2 key system dial tone back to the calling extension at site 1. That is the one I'm more concerned about and am really needing the help on, because I don't understand the dial peers to that degree to be able to program the second task.


Can anyone help me with this?

Nicholas Matthews Thu, 01/15/2009 - 10:41
User Badges:
  • Red, 2250 points or more

It's probably worth taking a look at this document:

http://www.cisco.com/en/US/partner/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml


Things to note:

If you explicitly match a number in a destination-pattern on a POTS dial peer, the number will be stripped. This can be altered with EITHER the 'no digit-strip' or tinkered with the 'forward-digits ' command.


You can put an incoming translation profile on pots dial peers for one side that prefixes the numbers with a certain digit, and set a destination pattern that starts with the prefix digit on the outgoing.


To do the translation, take a look at this document:

http://www.cisco.com/en/US/partner/tech/tk652/tk90/technologies_configuration_example09186a00803f818a.shtml



hth,

nick

sandman420 Thu, 01/15/2009 - 10:46
User Badges:

Sorry, but I do not pay for a service contract, therefore can not look at whatever it is those links contain.

Nicholas Matthews Thu, 01/15/2009 - 10:49
User Badges:
  • Red, 2250 points or more

Forgot to make them friendly :)


Quick note for anyone that cares - most links this can be converted by changing 'partner' to 'customer'.


It's probably worth taking a look at this document:

http://www.cisco.com/en/US/customer/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml


Things to note:

If you explicitly match a number in a destination-pattern on a POTS dial peer, the number will be stripped. This can be altered with EITHER the 'no digit-strip' or tinkered with the 'forward-digits ' command.


You can put an incoming translation profile on pots dial peers for one side that prefixes the numbers with a certain digit, and set a destination pattern that starts with the prefix digit on the outgoing.


To do the translation, take a look at this document:

http://www.cisco.com/en/US/customer/tech/tk652/tk90/technologies_configuration_example09186a00803f818a.shtml

sandman420 Thu, 01/15/2009 - 12:09
User Badges:

I see the customer/partner change, but still no go.


This is what I receive:


Forbidden File or Application


The file or application you are trying to access may require additional entitlement or you are trying to access a file with an invalid name. Additional entitlement levels are granted based on a users relationship with Cisco on a per-application basis.

sandman420 Thu, 01/15/2009 - 15:49
User Badges:

OK, let me simplify things. I think I'm putting way too much thought into it all. I've got site A and site B. Site A (currently for testing) has a single line extension from Site A's key system plugged into port 0 in fxo card in slot 2. Site A will have a patch from port 0 in fxs card in slot 3 to a CO line on the key system. Site B has the same setup. Both have fa 0/0 configured with IP addresses on the same network (just to simulate the connections - later I will actually move these to two separate internet feeds for more advanced testing).


Currently for testing I have disconnected the fxs patches to the phone systems and just have a regular analog phone plugged in. When my phone plugged into Site A goes off hook, I get dial-tone from the extension hooked up to Site B (which is the exact way I want it). When my analog phone is plugged into Site B (port 0 of fxs card in slot 3) and goes off hook, it will ring port 0 of fxs card in slot 3 of Site A. This I don't understand. If I can get both to behave like Site A, I'd be happy.


I need to know if this makes sense to anyone on how I want this to operate? Is it achievable?


Here's my base config on it (Site A first, then Site B):


!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Simmering

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$F/AM$ige2qFh9lVD6uNubE.qm80

!

no aaa new-model

voice-card 2

!

voice-card 3

!

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.254.30 255.255.255.0

speed auto

!

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 2/0

connection plar opx 290

!

voice-port 2/1

connection plar opx 291

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 3/0

connection plar 190

!

voice-port 3/1

connection plar 191

!

voice-port 3/2

!

voice-port 3/3

!

!

!

!

!

!

dial-peer voice 280 pots

destination-pattern 280

port 2/0

!

dial-peer voice 281 pots

destination-pattern 281

port 2/1

!

dial-peer voice 290 voip

destination-pattern 29

session target ipv4:192.168.254.40

!

dial-peer voice 180 pots

destination-pattern 180

port 3/0

!

dial-peer voice 181 pots

destination-pattern 181

port 3/1

!

dial-peer voice 190 voip

destination-pattern 19

session target ipv4:192.168.254.40

!

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password Corazon64789

logging synchronous

login

transport input telnet

!

end




SITE B:


!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Sigma

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$1H58$6.VsVieyi4srcC7v4Lndv0

!

no aaa new-model

voice-card 2

!

voice-card 3

!

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.254.40 255.255.255.0

speed auto

!

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 2/0

connection plar opx 280

!

voice-port 2/1

connection plar opx 281

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 3/0

connection plar 180

!

voice-port 3/1

connection plar 181

!

voice-port 3/2

!

voice-port 3/3

!

!

!

!

!

!

dial-peer voice 290 pots

destination-pattern 290

port 3/0

!

dial-peer voice 291 pots

destination-pattern 291

port 3/1

!

dial-peer voice 280 voip

destination-pattern 28

session target ipv4:192.168.254.30

!

dial-peer voice 190 pots

destination-pattern 190

port 2/0

!

dial-peer voice 191 pots

destination-pattern 191

port 2/1

!

dial-peer voice 180 voip

destination-pattern 18

session target ipv4:192.168.254.30

!

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password Corazon64789

logging synchronous

login

transport input telnet

!

end


sandman420 Tue, 01/20/2009 - 06:41
User Badges:

I'm still not making heads or tails of this. Anyone willing to help me out with the voice programming?

sandman420 Thu, 02/05/2009 - 11:19
User Badges:

I've finally got it. Here's what made it work for anyone trying to do the same:


SITE 1:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SITE 1

!

boot-start-marker

boot-end-marker

!

enable secret XXX

!

no aaa new-model

voice-card 2

!

voice-card 3

!

ip cef

!

interface FastEthernet0/0

ip address 192.168.254.30 255.255.255.0

speed auto

no shutdown

!

no ip http server

no ip http secure-server

!

control-plane

!

voice-port 2/0

connection plar opx 290

!

voice-port 2/1

connection plar opx 291

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 3/0

connection plar 190

!

voice-port 3/1

connection plar 191

!

voice-port 3/2

!

voice-port 3/3

!

dial-peer voice 180 pots

destination-pattern 180

port 2/0

!

dial-peer voice 181 pots

destination-pattern 181

port 2/1

!

dial-peer voice 190 voip

destination-pattern 19

session target ipv4:192.168.254.40

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password xxx

logging synchronous

login

transport input telnet

!

end




AND SITE 2:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SITE 2

!

boot-start-marker

boot-end-marker

!

enable secret XXX

!

no aaa new-model

voice-card 2

!

voice-card 3

!

ip cef

!

interface FastEthernet0/0

ip address 192.168.254.40 255.255.255.0

speed auto

!

no ip http server

no ip http secure-server

!

control-plane

!

voice-port 2/0

connection plar opx 280

!

voice-port 2/1

connection plar opx 281

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 3/0

connection plar 180

!

voice-port 3/1

connection plar 181

!

voice-port 3/2

!

voice-port 3/3

!

dial-peer voice 190 pots

destination-pattern 190

port 2/0

!

dial-peer voice 191 pots

destination-pattern 191

port 2/1

!

dial-peer voice 180 voip

destination-pattern 18

session target ipv4:192.168.254.30

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password xxx

logging synchronous

login

transport input telnet

!

end



Too bad I can't rate my own comment for answering my own question, LOL =)

Actions

This Discussion